291 - funny error

@Ken

thanks for the quick update - when I loaded mine in Win 7, I was doing a calibration run. When the run completed, I closed the sequencer window, disconnected and then hit the X in the top right corner of SGP to close the window. Instead, the sequencer window pops up again!

It is like one of those banners that says click here for a payrise…

If I shut down SGP using a different method and fire up again, the top right X works fine.

This morning my SGP 291 wouldn’t close either. Hitting the red X in the top corner just pops up the sequencer window. I had to close it through the task manager.

Did you get one? Wondering if I should fix this.

Not sure what this means. Different how?

There appears to be a difference in behavior if SGP is simply loaded and then shut down with the X and if you run a sequence and then try and shut it down with the X.
It is odd as the X is part of the window and I am assuming not part of the code as such. Maybe some obscure compile error.
@cmassa - what OS are you using? I’m 64-bit Win 7 Pro.

Ok, thx. I have still not been able to reproduce, but I may have figured out what it is…

@buzz @cmassa

Did either of you use the “Don’t ask again” options for either of these dialogs?

  • SGPro still has gear connected. Are you sure you want to exit?
  • The data in this sequence has changed. Do you want to save this sequence?

This reminds me of closing PixInsight using the ‘X’ and it will never re-open. To solve this is by closing PixInsight via File->Quit. PixInsight could never resolve this and many people experienced the same thing.

Peter

Sorry - I did not notice. My equipment was already disconnected after doing a dark run (which had completed). I’ll have to recreate it and take a screen grab.

I did a fresh install and had this same issue. The issue some how resolved itself when I went to make a video showing the problem to help find the bug and it closed with a click on the X per normal. If I can get it to happen again on camera I will post a link.

Oh also trying to get my camera to connect caused the whole computer to reboot. But that is another story.

@mpfjr

Did you use any of the new “Dont show again” feature?

I used the Don’t show again on another message but not anything related to shutdown. I had disconnected all equipment and then tried to close SGP with the X. The sequence window blinked off and on and the program did not shut down. I finally closed it with task manager. I did not try the file menu quit option (forgot).

Chris

Nope. Clean install as of this morning. Been having ascom issues so I uninstalled all my drivers and also SGP and did a fresh install of everything. So I don’t even have profiles of any kind on it.

Here is a video. https://youtu.be/K54-qXumR4k

I mentioned that I had OBS running both times I saw this happen. However shutting down OBS did NOT change the behavior.

@mpfjr

ok, thx. Well… I do think I have resolved this, just wasn’t able to reproduce it.

Oh, I’m not only one experienced this fun bug :wink: After my calibration sequence is done, disconnected gears, close sequence window and then clicked “X” on right top of SGP main window. Then sequence window was revived from grave!!

Hmm… honestly, I don’t think I remember correctly between the sequence was completed or I clicked “pause” then “finish immediately”… sorry…

New 295 seems to be working fine so far. No issues closing it down. Also I want to say a special thank you to whomever’s idea it was to have the “don’t show again” check box on everything. I honestly hate that software of any kind has to prompt for “are you sure?” messages all the time and for everything.

www.mainsequencesoftware.com