Beta - Can't connect to PHD2

Today I updated to the latest beta and now SGP can’t connect to PHD2. Not sure what’s going on. I tried to uninstall and re-install (the version I had before), but then the same sequence file would no longer load in SGP.


I use an NUC at the mount to control everything. I also have a spare NUC. I hooked up the spare NUC and all is good. SGP can connect to PHD2 just fine.

Still, I’d like to try and figure out why my main NUC won’t allow SGP to connect to PHD2. The main NUC is a lot faster etc.

I’ve been having a few other issues with the main NUC unrelated to SGP so I’ll probably end up nuking Windows and starting over with a fresh install.


In your logs:

[08/07/19 22:20:35.839][DEBUG] [PHD2 Listener Thread] Failed to establish client connection to PHD2 using port 1025: No connection could be made because the target machine actively refused it

This means that there is no service running on port 1025… May want to check PHD2 server startup in the PHD2 logs.

Here’s something else. On the spare NUC2 (which works) when I pulled up the PHD2 settings from within SGP I noticed that the port was set to 4400. However after establishing the connection I noticed that port now said 1025 in SGP.

So I went back to the main NUC and put in port 4400 and now SGP can connect to PHD2. And once again, after the connection was established the port in SGP reverted to 1025.

In any event, it looks like all is good now. Not sure what happened but it appears to be sorted out.

.213 should have resolved the port issue. Can you detail how the sequence was created. Where did the profile come from (was it created new in .213?) Was the sequence created with .213? Sounds like something is still defaulting incorrectly and I need to figure out why.


Both my sequence file and the profile it was created from originated from a past generation of SGP, maybe several beta releases ago. I tend to keep the same sequence file and add/subtract targets from it.