Aborting Autofocus Bug


#1

I had this lock up several times last session, if you commence the sequence and then forget something and tell it to abort the autofocus, it will lock up and grey out any functions and the only way to resolve is a Crt+alt+del.

It was fairly replicable.


#2

@Jkulin
I notice this same behavior on other things within SGP as well. What I think is happening is there’s a dialog box that pops up but it gets covered over by the SGP main window and there is no way to get to the dialog box. If you minimize SGP the dialog box also gets minimized. Everything gets grayed out in SGP as SGP is waiting for the user to respond to the dialog box. I notices this on several occasions but I haven’t had time to know enough to ping Ken and Jared on the issue. I believe there is a bug someplace within SGP when it comes to these popup dialog boxes. Over time I learned to let SGP finish doing what is was doing and not to interrupt it. I’m going from memory but I think this issue occurs if the Camera is connected and you try to open up the Camera tool icon, I seem to remember this would cause a popup dialog box and SGP would basically lockup. The only reason I say this is that for a very brief moment I remember seeing the dialog box before it was covered up and I wasn’t able to get to it.

Regards,
Mark


#3

Thanks Mark, I previously reported the dialogue box obliterating buttons so that they can’t be pressed on another thread but never heard any more.

The dialogue boxes are useful as long as they move out of the way, but I think with SGP their position is coded and therefore won’t move or close.


#4

Hi Jared & Ken,

Not had a reply to this or my original post, can you advise please?

Thanks.


#5

I think it will need specifics and a log file to understand the issue better - I imagine if this was an issue for the wider community, there would be more traffic on it. I kinda know what you are seeing. I sometimes have that with ASCOM chooser and properties and I have to alt-tab it to the front.


#6

I also reported the problem with pop-ups covering buttons and not being movable with no way to move forward. The issue may be related to screen size and resolution, so not everyone will experience it, but it has been posted a number of times with several people confirming the problem. It seems like it would be an easy fix.


#7

We’ll need logs and screenshots to help track down where this is happening.

Thank you,
Jared


#8

Hi Jared,

I finally have a screen shot to show you the problem

This pop up is not moveable or clickable, and you cannot guess where the yes is, the only option is to click NO and try again.

Hopefully that finally explains the problem.


#9

Jared, still no reply to thsi issue, any chance of an update please?


#10

What steps did you take to get to this state? Can you not drag the “Unsaved Profile” dialog out from under the tool tip?

Thanks,
Jared


#11

I too have seen this happen and have not found a way to get to the dialog. The tool tip stays in the way no matter what until the dialog is dismissed. I don’t know how to reproduce exactly except as you can see the save dialog is coming up under the tool tip when saving. It is probably a case of having the mouse cursor in the right place to have the tool tip in place.


#12

Hi Jared, As DesertSky said, you can’t do anything.

It was always replicable, simply if you are prompted to save the profile then the popup will not move out of the way to enable to press yes.


www.mainsequencesoftware.com