Additional info about controlling temperature compensation

Description

Last night I did some more testing of SGP managing the temperature compensation feature of my Optec focuser. The focuser is configured to automatically enable TC at power up. I opened the Optec ASCOM interface and verified TC was enabled and then started SGP. When I connected to the focuser (in the Sequence window), TC was disabled. I manually re-enabled TC. I then ran an auto focus routine manually (from docking module) and SGP properly disabled TC, performed the auto focus and turned TC back on. I then clicked “Run Sequence” and the TC was immediately disabled. I manually turned it back on. There was a 20 minute delay between “Run” and target start time. I noticed telescope tracking was not turned off.

When SGP began the on-target-start auto focus, it failed to turn off TC and the auto focus run timed out and failed. Subsequent auto focus runs properly turned off TC and then turned it back on.

It seems to me that the Control Panel needs a user option that tells SGP that it should manage the focuser’s built-in TC and keep TC enabled at all times – except when actually moving the focuser.

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
Ver: 3.1.0.432
.NET: 4.8

You should not do this. Once the sequence has started, let SGPro manage the state.

SGPro has never altered the state of the mount while waiting. We may consider this in a future release.

That’s because it had already turned it off, but it had been turned back on.

I have a better idea on how to handle this… more to come in 3.1.0.433

I think the method implemented in 3.1.0.433 is more reliable… let me know how it goes.

When “Run Sequence” disabled TC, I turned it back on because the previous night I did not turn it back on and TC was never re-enabled. I have downloaded .433 and may get a chance to try it tonight. Thanks for the quick response.

Charlie

Keep in mind that this does not alter the mysterious condition where your focuser’s temp comp is disabled on connect. I don’t know why that happens. After you re-enable it, though everything should be pretty solid after that. Note that manually altering the state of temp comp can throw SGPro for a loop and leave you in an unexpected state.

Ken:

Cloudy weather has prevented me from fully testing .433 but I did test two of the issues: TC disabled on focuser connect and TC disabled on Run Sequence. When connecting to the focuser from the Sequence window, TC was not initially disabled; however, about 10 seconds later, it was disabled. Run Sequence no longer disables TC.

Charlie

SGPro is not sending a command to do this. You should get a hold of your focuser logs to see if there is an explicit command coming from somewhere or if it is maybe driver behavior.

Ken:

I was able to do more testing of .433 tonight with good results in both manual focusing and automatic focusing during the sequence run with TC being properly enabled and disabled. Moonlight prevented an extensive test but it looks like the only TC issue still remaining is the disabling of TC on connect.

I will see if I can research that remaining issue a little further.

Charlie

@Ken

More testing with .446 last night and the only temperature compensation issue I am still seeing is that TC is being disabled when I connect to the focuser from the Sequence window. I have tested this with a couple of other imaging apps and do not see the TC being disabled on connect. This is not a huge problem, as I know it just needs to be re-enabled after I connect the gear.

Charlie

Were you ever able to enable the driver access logs for your focuser? I am 100% positive that SGPro does not send a command to the focuser to disable onboard temp comp on connect… there is just no code to do it. All code for that is executed during sequence or manual runs of auto focus only.

My working theory is that, upon connect, SGPro tells the focuser to “Halt” (as per the ASCOM spec):

Recommendation: Host software should call this method upon initialization and, if it fails, disable the Halt button in the user interface.

I am betting that your driver literally stops movement and any state which could cause movement (like temp comp). Maybe? I guess this is just up to how the driver’s author interprets the command… 1.) Stop the immediate movement or 2.) Stop all movement for anything, forever, until some other thing happens.

Anyhow, despite the ASCOM recommendation to do this, I think it’s fine if we skip it. That change will be in 3.1.0.447.

As far as I can determine, the Gemini focuser does not produce any logs and I see no option in the Gemini Commander software to enable logging. The ASCOM logs don’t show any Gemini focuser related entries.

The Gemini Commander software (ASCOM interface) does have a “Halt” button but it is only enabled while the focuser is actually moving to a commanded position. You can only command a move when TC is disabled so it is not possible to click the Halt button when TC is enabled.

I must agree with you in that the “ASCOM recommendation” doesn’t seem to make any sense; at least the way it is worded. It does make sense, however, that programatically issuing a Halt command while TC is enabled would disable TC, since that would be the only way to stop all focuser movement.

Charlie