Alintak Flat Man Null Port

The Alnitak controller works as it should controlling the Flat Man. I connected it to SGP and all was well last week. I started a session the other night and I was getting an error SGP that it could not connect to Alnitak Flat Fielding Device.

“An unhandled exception has occurred in your application…”
“Value cannot be null”
“Parameter name: value”

I attempt to set the port in SGP and I get the error dialog stating that port number cannot be null.

Not sure how to get SGP to see the Optec option box again to set port number. I’ve tried uninstalling and reinstalling the Alnitak controller but as expected no no avail. Port shows correctly in the Device Manager. I’ve deleted the port and tried a new port. Unplugged the USB device.

This doesn’t sound exactly like my issue, so this is FWIW. My Alnitak never connects on the first try. I have to attempt to connect it, let it tell me that it cannot connect, then go and physically disconnect it, wait a few seconds, and then plug it back in. At that point it always connects (to SGP). Since my flats capture is always segregated from imaging runs, the extra trip out to the scope hasn’t been too costly, and I haven’t worried too much about sorting out what is up.

Best regards,
Craig

Thanks for your time, Craig. I will try unplugging when it is giving me the error and see what happens, though this would not be an ideal solution for me as I’d like to do flats unattended.

There should be a way to force SGP to see the port number…

Matthew

I’ve addressed the double connect issue as well as the Null port. The Null port will just pop up an error message stating that you need to select the COM port in your settings. This probably happened as your saved COM port is no longer in the list of the available com ports. Com ports can jump around if you plug the device into a different USB port.

Thanks,
Jared

Thank you for taking the time to reply, my apologies nor not being clear.

  1. I did not change port until after I received error message
  2. When I try to use the configuration in the equipment profile manager to select a port, I get a similar error with null port.

There is no way for me to get around the error so select the port.

Matthew

Ah, yes. I ran into this issue and addressed it as well. It will be out in the next beta which will be out soon.

Jared

OK. I will wait for the beta, Generally I do not like to use beta versions as they can sometimes can have unintended bugs (that’s of course a generalization and not directed at SGP or the developers of SGP). It seems odd that this just came up - working one week and not the next. I’m running Windows7 so there are no OS updates to complicate matters.

Nothing I can do in the mean time?

Thank you again for your support.

Matthew

You can create a new profile which shouldn’t have a missing port set. Or you can try to get the Flip Flat to use the previous port (if you can figure out what that was).

Thanks,
Jared

www.mainsequencesoftware.com