Ansvr 0.15 aborts with blind solve in SGP 2.4.2.11


#1

I have installed SGP on a Win7 64bit PC, and installed the astrometry.net local plate solver using ansvr-setup 0.15.3.exe.
On a reboot everything starts up OK, and I have set up SGP to point to my local http://127.0.0.1:8080/api.
TCP view confirms that perl.exe is listening on post 8080 correctly.
When I perform a blind solve on an image it fails and perl.exe is no longer in the TCP view list, and ansvr settings does not work.
The watch ansvr log is as follows:
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
[2015-09-27 15:48:15] ansvr 0.15 start
[2015-09-27 15:48:15] loading config from /var/tmp/platesolve/config
[2015-09-27 15:48:15] read port 8080 from reg
[2015-09-27 15:48:15] using scale error override value 5 percent
[2015-09-27 15:48:15] using downsample 2
[2015-09-27 15:48:15] solution coordinates will use epoch J2000
[2015-09-27 15:48:15] saving config to /var/tmp/platesolve/config
[2015-09-27 15:48:15] [Server /opt/ansvr/ansvr accepting clients on port 8080]
[2015-09-27 15:50:26] [Connect from 127.0.0.1]
[2015-09-27 15:50:26] POST /api/login HTTP/1.1
1 [main] perl 4488 C:\Users\Astro\AppData\Local\cygwin_ansvr\bin\perl.exe:
*** fatal error - NtCreateEvent(lock): 0xC0000058
Waiting for data… (interrupt to abort)

I have tried disabling the Windows Firewall but it doesn’t help.
I must have done something wrong, so any help would be apprciated.
Thanks.


Problem with Local Astrometry
#2

@Southcoaster
I have never seen this error before. Please contact me at andy.galasso@gmail.com. We’ll try to figure out what is causing the error and post back here when we have the solution.
Andy


#3

In case anyone was wondering what came of this, it turned out to be caused by the anti-virus program (AVG) on the machine.

Has anyone else successfully used AVG antivirus without it interfering with ansvr? If so did you have to add any particular exceptions to AVG to make it work? We tried adding an exception for perl.exe but that did not work.

Andy


#4

Andy, I have used AVG for years without issues. I currently have AVG on
both my OBS computer and my laptop. Solves work just fine without any
manual exceptions.


#5

Andy, the exception for
C:\Users\Astro\AppData\Local\cygwin_ansvr\bin\perl.exe you added to my AVG Antivirus Free did work.
AVG was complaining that it found IDP.Generic.9BA97F03 present.
Joel, perhaps I have a different version to your AVG, mine is AVGfree 2016.0.7134?
Andy, many thanks for all your help.


#6

I guess AVG hasn’t updated for me yet. I’m on 2015.0.6140.

It looks like in the past I did have an exception for
C:\cygwin\bin\perl.exe. That was back in 2014 before Andy created the
installer package. That exception is no longer applicable as cygwin no
longer exists on the root of my C: drive. I’ve been using local
Astrometry.net on multiple machines with AVG without any exceptions.


www.mainsequencesoftware.com