ASCOM and the LX850


#1

As much as I love SGP, I’m finding it more and more difficult to continue to use it. The problem is not in SGP but within the Meade Universal ASCOM driver. I am a coder and I have done the Meade drivers for the LX200 series forLinux programs such as XEphem, Kstars, etc (all INDI now) but I have no Windows experience and no Windows developer’s tool chain. I’m posting this in hope there is an ASCOM developer that is interested in correcting this situation.

Primary problems:

  1. The Meade LX200GPS driver doesn’t accept the LX850 as a mount it can connect to because the firmware has a different name and version due to the addition of the StarLock.

  2. No focuser control for the Meade microfocuser which is an absolute focuser. All Meade focusers use the same interface but the Universal driver doesn’t support a focuser and without LX200gps driver I can’t even use my focuser except manually and even the LX200gps driver uses it like a relative focuser.

  3. The LX850 has it’s own auto-centering routine and guider. With the proper settings in place it is very accurate and the mount does all guiding on it’s own. For resume a sequence it is still best to use SGPro to plate solve but the scope needs a command to disable it’s own auto center mode for this to work (StarLock HPP needs to be turn on for slew, off for center).

  4. The scope will report it’s distance to the meridian. The software can just use this value to know when to pause, issue the object slew and the scope will realign on the of the side of the meridian. The software just needs to wait for the “Slew Complete” before resuming the sequence. This is unsupported by any driver.

  5. The LX850 has an onboard temperature that will return the OTA temp to assist with auto focus. No ASCOM driver supports this.

  6. The rotator is not supported at all.

  7. The scope can be auto-aligned using an onboard drift alignment method. This is great for remote observatories. Again no support.

This is not a complaint. Currently I use SGPro with “No Telescope” (although for some reason it still wants to median flip sometimes). If anybody out there has the proper dev tool chain and is willing to work with me on this, I’d love to solve this problem.


#2

Mick,
You may want to post this on the ASCOM group and on any Meade forums as well (if you haven’t already). Sounds like the problem extends well beyond SGP’s “scope.”

Good luck!
Jared


#3

Definitely ask on ASCOM-talk, there may be some drivers in development.

Visual Studio Express is a free IDE that’s fine for developing ASCOM drivers.


#4

LOL. I already have. No takers…yet.


#5

Mick,

Complain to Meade. They’re a large (sort of) company who has a vested interest in pleasing their customers. If the LX850 doesn’t support imaging through the standard path (ASCOM), it’s a negative since every other mount does.

Just tell them if they can’t get this fixed, you’re going to return the mount.


www.mainsequencesoftware.com