ASI 294 MC Pro cooling in SGP

I had this a while back. I didn’t think to try another program. (thinking the program only tells it where to go to). but maybe it was SGP. I sold the camera as it was a year old and replaced it with same but newer PRO model.
temps are much cooler now outside so I’ve not seen it since new camera arrived last fall.

It continues to be an issue in SGP. It cooled below -15 two times out of the dozens I’ve tried and my settings remained the same. It’s like the cooler just refuses to go beyond a certain point. I don’t see this in SharpCap or Asicap. This was after 15 minutes.

Regards,
Randy

From that screenshot it appears that the 10 minute cool down is running and has been running for about 6-7 minutes (based on the progress bar for the cooler). What happens if you abort the cool down, set -20 in the Set temperature to box and click Set?

Thanks,
Jared

Yes in this case the progress bar just stopped at that point like the program had frozen. I left it for several more minutes and it appeared stalled. I have tried the abort option in the past and set a new temperature but usually get a “not responding” error once I start trying to make changes midstream. I will try it again today.

Thanks
Randy

Definitely an issue cooling 294MC Pro in SGP. Tried everything in equipment manager. It stops at different points. %50 percent of the time when I disconnect I get “not responding”. Seems to cool to -20 with no issues using ZWO software and Sharpcap.

Regards,
Randy

If you can attach a log I can see if there is anything there. I don’t have a 294MC but everything seems fine with my 1600CC, which should be using the same drivers (as far as SGP is concerned at least).

Thanks,
Jared

This is the part that happens to me often. However, when it does this part and I get the “not responding” then SGP has locked up totally and I have to close and restart the whole program to get anything to work again. I thought it was just my laptop or something because it happens to me occasionally while doing frame and focus also. The frame will get stuck on downloading image forever and I can’t do anything. If I try anything else it says not responding at the top.

Thanks,
Charles

Exactly the same symptoms here cthomp97. Unfortunately I am down for a bit due to scope issues. Looks like it may be going back to Explore Scientific for cleaning and collimation before I can test again. Noticed some pretty bad smudging inside when I was attempting to take flats. Figures, new camera and its either clouds or the scope is down.

Regards,
Randy

I’m up and should have some clear sky time Saturday night if I’m lucky. I’ll let you know how it goes. I can’t decide on a target!

Thanks,
Charles

I’ve reached out to ZWO to see if we can borrow a camera to track down the issue. As I can’t replicate this with my 1600 I don’t think I’ll get very far just guessing for a fix.

In the mean time if someone can upload a SGP log I can take a look.

Thanks,
Jared

I finally had a clear night last night. I don’t know if it was a coincidence or not but I downloaded the new SGP release before starting and my camera stayed at- 20 for the whole evening (7 hours). I doubt it has anything to do with the release but that was the only thing I changed. It was slightly warmer last night in the 40sF. The past 4 sessions where it was having problems the temps were in the high to mid 30s. However, I have images in the past without issues below freezing. Hope that helps.

PS in the last image of the night my Auto focus had kicked off and SGP locked up on one of the image downloads and I didn’t feel like restarting everything so that is why I didn’t image longer. Probably good for my marriage though :slight_smile:

Thanks,
Charles

I noticed a similar thing this week when I was getting darks at -10C. The ASI294 got stuck at -1.6 and wouldn’t go colder. I ended up disconnecting the camera from sgp and then unplugging/replugging the camera into the PC’s USB port and then it cooled fine.

I had been running at 0C in the warmer weather but moved down to -10 now that the cold weather has arrived so this was my first chance to see it happen. This really smells like a camera or driver issue more than an sgp problem to me.

I heard back from ZWO about this. Sounds like an incompatible combination of how their drivers handle temperature changes and how the Cool Down works in SGP. Essentially, I believe that you’ll need to disable the cool down option in SGP or have the time set to be 0 minutes.

When using the SDK the driver will not increase the power to the cooler if the new set temperature is very close to the existing temperature (I’m not sure what “close” actually means…but likely a couple of degrees to prevent wild spikes in power while attempting to stabilize the camera).

I have not seen this with my ASI1600 but they mentioned that they did replicate the same behavior with the 1600, so I’ll give that a shot again. Maybe because mine is the older “non-Pro”?

Thanks,
Jared

This is good news, thank you for looking into it. I have only seen this a couple of times with my 1600. It is also the non pro version. I chalked it up to finicky usb as it is pretty rare. The 294 on the other hand is basically every time. I’ll try the workaround when my scope is back in service.

Thanks,
Randy

Jared, Just wondering if this is on a bug list? I’m planning to buy the 294mc pro and just wondering if this is something that should be corrected or just control temp outside of SGP. Is there a recommendation on Ascom driver versus zwo driver?

I wouldn’t worry about it ehorton. I have used the 294MC Pro for months and it works fine as long as I set the camera to cool down when connected and set it to cool down in 0 minutes. That’s how I got around it anyway.

Now if I could just get my dither seeing to save instead of reverting to small dither each time that would be fantastic :slight_smile:

Thanks. So i assume the 0 time is not causing it to cool too fast and freeze. I got the impression from jareds post the camera logic is controlling that and he is just sending an on or off

It causes no issue at all. I rarely see the TEC % go above 50% utilization. I just checked my settings and the one I have been using recently is set to -20 in 10 minutes. I guess it hasn’t been a problem over the past couple months on my configuration.

Thanks,
Charles

Thank you. I appreciate the info

Same issue with my ASI071 Pro… just say’n

www.mainsequencesoftware.com