ASI1600 camera add gain to file name


#1

As I understand it Gain can be added to the file name using “%cg” ? I have added this but in the file name of the images it comes up as “NAcg”

As gain for the ASI1600 camera is set in the ASCOM driver and not in SGPro will it not appear in the file name?

Thanks for any feedback


#2

I have the same problem with both ASI071 or QHY247C
In both cases, the gain is not displayed in the filename but I get as you NAcg

I raised the problem to Jared, who told me he was going to look into it on 14 Jan; however seems that it is not yet fixed


#3

Hi Aster

See a similar thread running on this %cg in file name not working for ZWO


#4

Hello,
same issue here with a QHY163M.
Thanks.


#5

and also QHY247C. I guess same ASCOM and same handling of the parameter. Did anyone get an aknowledgement from Jared or others? To understand if is a general problem for all such camera users, or something depending on configuration that can be resolved by changing something.


#6

Noticed last night that the gain figure does appear in the FITS header when opened, but is only represented by NAcg in the file name


#7

Any ideas anyone? All quiet on this.


#8

Should be working with the latest 3.0 release for ZWO. I can’t recall if the gain is accessible in the QHY ASCOM driver but if it is then it should also be working there.

Thanks,
Jared


#9

Will check again next time the sky is clear. As I said, last time (April) the gain setting appears in the FITS header when opened but not as part of the file name.


#10

This was fixed in early May.

Thanks,
Jared


#11

Actually this may not be in this release. I believe I fixed it shortly after making the current release. I’ll try and get a new one out in the next couple of days.

Thanks,
Jared


#12

thanks Jared, i will watch out for it.
regards
Alec


#13

Hi Jared
All seems to be working well now, very many thanks.
regards Alec


#14

Has any progress been made on this?

I seem to be having the same issue with the ASI1600mc pro.

I have the keywords %cg _%co and all the subframes are tagged GAIN_NA_Offset_NA

Running version 3.0.3.91


#15

You have to use the “ZWO Camera” not the ASCOM cameras.

Thanks,
Jared


#16

Thanks again :slight_smile:


#17

I just switched to the native driver and will see next time out. I got the same thing as far as I had the driver gain set to “X” and got the “NA” in the file. The only way I could get the right file name gain setting was to set it in the per event gain but the issue there was that the “driver” setting over ruled the "event"setting and even though the file said the gain I wanted it was actually the driver gain that was recorded.


#18

@jared Hi
Further to the above, how do you know for certain what Gain and Offset was used? Presumably the numbers that appear in the Fits header are the actual settings for the image - no question?

One further question. When using the Flats Calibration Wizard where are Gain and Offset settings set?

Thanks


#19

If you are using the ZWO drivers (not the atik) the gain and offset are selected on a per event basis. This information can be embedded into the filenames with the %cg & %co keywords.

For the flats calibration it will use whatever you have set the ‘default’ settings for your camera. If you want to use a different gain/offset for now you need to change the default settings prior to running the calibrator. At least that is what I have found.


#20

Thanks UM

That’s what I thought was the case, I was seeking confirmation


www.mainsequencesoftware.com