Astrobin Links not working for Plate Solving


#21

Hi Ken, thanks for the update. This morning I tried using urls from solved images at Flickr and DSO Browser as well as Astrobin, but other than the logo presented in the web link box in SGP changing to reflect the source (Astrobin, Flickr, DSO Browser) I get the same failed to solve message. Did anything change in SGP v2.6.0.24 as based on my attempts it doesn’t appear to be just an Astrobin url problem? Could you check the other url sources and let us know whether they work for you please?
Regards, Geof


#22

Good Morning,

Is there any update on restoring functionality on this please?

Best Regards
Aidan


#23

Hi. From DSO-Browser work ok,
This is link to M 31, loaded in SGPro 3.0.0.3 and work ok.


Problem in from Astrobin with last forum update. Before update all was ok.
Here is an image with.

DSO-_SGPro_target_setting


#24

Hi Iosif, I just tried the same link using SGP v2.6.0.24 and it did not solve.

Unfortunately I upgraded SGP the same days that Sal upgraded Astrobin, so I do not know if the issue is with SGP v2.6.0.24, or Astrobin, or both. I previouly solved ok with SGP v2.6.0.23, but when I roll back to that version it still does not solve.I do not want to upgrade to SGP 3.0.0.3 yet as I’m new to SGP and prefer not to try beta versions.
Regards, Geof


#25

I have tested with all version SGPro and work. You must to be very careful when you load the link image.
Try this, copy and paste. #https://dso-browser.com/picture/view/22619/triangulum-galaxy/M/33/galaxy/by-terrance_henderson?from=dso&dso_id=1490# copy without #

Here is an image with test again.


#26

Thanks Iosif, I tried that, but it still did not work…


I was very careful to copy exactly from between the two #s in your message. It’s very strange indeed that it works for you, but not for me
To check I copied the same to my browser and it took me directly to the M33 image in DSO Browser…
Geof


#27

I have just tried the link which you post Iosif in my SGP 2.0.6.24 and it solved successfully. I have had some success with images from DSO Browser, but many are not plate solved to start with which makes it limited.

Tried an Astrobin link and still get the error. Not sure why this would work for me Geoff and not you… thats a bit strange.


#28

I have just tried to import a target from DSO-Browser.
Importing via Framing & Mosaic Wizard it works.
Importing the same target via Import Targets DSO-Browser fails.
I am using Version 3.0.0.3

Nigel


#29

Thanks Aidan,
Its good that you got it working with same version as me, but now I’m even more confused…!! I had no issues with 2.6.0.23, but now can’t get either to work with anything. There must be some setting that got changed or something, but I have no clue where to look… :disappointed:
Geof


#30

I guess the more feedback we give, the better understanding will be gleaned to getting a solution.


#31

I found a similar thread about this in the past


the OP said that he solved the problem by checking ‘firewall inbound rules’, so I’m wondering if something happened there. I’m way out of my comfort zone there, but maybe Ken could offer some advice. This is what the advanced setting for my firewall inbound rules looks like…

… but it means nothing to me…
Regards, Geof


#32

Just throwing my name into the hat here. Happened to me me last night on a new target. No matter what Astrobin target I chose it failed. I ended up using the framing and mosaic to search for the target and then create the sequence from there.

That’s not a solution though for the people that have not purchased frame and mosaic.

This has got to be something astrobin did not Sgpro.


#33

Hi. It is another way to import target, from Astroplaner, it is not free, you must to buy it. Astroplaner is an verry good planer, and you can export an object, or all object who is visible in one night.
Astroplaner is like in image.

From SGPro you can import the target like in example.

I have imported 44 visible target in my location.

And i have selected Crab Nebula from target list verry well.

Please escuse my bad English, and i think that help evrybody, who love like me SGPro.
Clear sky Iosif.


#34

This thread seems to have deviated from the original intent. With respect to broken Astrobin links, a bit of bad news. After some discussion with Astrobin, it seems like it might be too difficult to make Astrobin interface with SGPro like it used to. Because of this, all previous builds of SGPro will never again be able to communicate with AstroBin. Going forward, all new versions of SGPro will be restored to the expected functionality.


#35

Ken, thanks for the update. I don’t think that the thread really deviated, rather we were trying to understand whether this was just an SGPro/Astrobin issue, or whether it was something more than that, e.g. I do not seem able to use links from any of Astrobin, Flickr, DSO Browser with v2.6.0.24, but others do have functionality with other urls albeit not Astrobin. As you say its a bit of bad news about current versions of SGPro no longer ever working with Astrobin, so please could you clarify what you mean by, ‘going forward all new versions will be restored to the expected functionality’, e.g. if I upgrade to the latest beta 3.0.0.3 now, will that work, or will it only be when you release the next full release of SGPro 3.x.x.x? Many thanks Geof


#36

Well poo… it wasen’t broken so why did they go and fix it?


#37

I guess AB is just moving with the times - updating for continued and probably increased users.

I’m more than likely going to try the Astoplanner. At the moment i log my sessions in a notebook, so it will kind of double hat to both log my sessions and provide targets.

Fingers crossed 3.xxxx fixes it natively and harmony is restored to the galaxy.


#38

Can’t really comment here except to say whatever broke it was part of a major site upgrade for AstroBin.

The next 3.X beta will have this repaired. In addition to this, we will also release a version of 2.6 that repairs this issue.[quote=“geoflewis, post:35, topic:6511”]
I do not seem able to use links from any of Astrobin, Flickr, DSO Browser with v2.6.0.24
[/quote]

Not sure here. I used the DSO-Browser link you provided with no issues. Would need to see logs.


#39

Thanks Ken,
Its good to know that there will also be a new release of 2,6, but in any case I will probably upgrade to v3 once that is a full release. I tried to solve from DSO Browser again this morning checking the log as I made changes, but I did not see anything added to the log to show that I did that.
sg_logfile_20171118090849.txt (24.8 KB)
For example I tried the target url from DSO Browser at about 09:18, but there is nothing in the log for that time. I then reloaded an existing sequence for M77, then replaced that with a new sequence with profile “QSI583+C14+Optec” and tried the url again, but I don’t see any record of that. Perhaps I’m reading the log incorrectly, so I’ll be interested to learn from you. BTW I do see several 'error loading…- lines at the start of the log, so what do they mean please? Are they significant or should they be ignored.
This was all done with my laptop not connected to any equipment.
Regards,

Geof


#40

@geoflewis

Sorry, you are right. There are two parts of code for DSO Browser. One to import your list and the other to import a single target. The one for lists has pretty good logging. I have added logging to the target import code for the next beta.

That said, if you were game to try and import a target list from DSO, it would probably fail in the same way (and has better logging).


www.mainsequencesoftware.com