Astrometry.net local server not working but Astrometry.net online does - SOLVED


#1

Hi

I’m having an issue with Astrometry.net local server. I installed it as explained in the instructions here ( http://adgsoftware.com/ansvr/ ) but when I try to blind solve an image it ends with a message “Failed to plate solve image!”. I’m using the suggested endpoint http://127.0.0.1:8080/api

Nevertheless, if I use the online version of astrometry.net with endpoint http://nova.astrometry.net/api exactly the same frame is solved within seconds. That has happened with every frame captured from sequences of SGP in the last couple of days.

Since not always there’s an internet connection when imaging, I would appreciate your help for solving this.

Thank you in advance,

Alfredo


#2

If you run the “Watch ANSVR Log” program what do you see when SGP attempts to solve an image?

Also I believe ANSVR defaults to an error percentage of 5% which will actually remove the true “blind solve” from SGP at the moment. You’ll actually need to know your scale (or within 5% of it) for the blind solve to work unless you change the error percentage in ANSVR to be blank.

Thanks,
Jared


#3

Hi Jared

This is what the Ansvr log shows, even after giving the right image scale, and the RA and Dec coordinates, which were taken for the previous solve with the Astrometry.net online server:



I also tried leaving blank the error percentage and the process was much longer, but at the end the result was the same: the image wasn’t solved.

Regards,

Alfredo


#4

Alfredo,

Could you post a sub that failed to solve so some of us can give it a try.

What is your exact image scale as reported by the online astrometry.net? Which indexes do you have installed? (you can open the index downloader to see)

Andy


#5

Something is horribly wrong with the scale there.

Can you post the image some place like dropbox so we can take a look? Also maybe try manually entering the scale just to see if that fixes is. You can see the scale there in your first image. It’s after the “scale_est” and the value is 715760929612550.38. So you either have the widest angle camera ever created (which is so wide it wraps 360 degrees over 1.5 million times!) or something got messed up with the scale somewhere along the line.

Thanks
Jared


#6

Thank you Andy and Jared

Indeed something was wrong with the scale, so I checked the regional preferences and changed the decimal and thousand separators. Thank you for the tip! That seemed to work, But now it takes almost 6 min to solve the image. In the log shows that the Ansvr goes through each of the index files and at the end it founds the solution. Is there a way to make this time shorter?

I use a Canon T1i DSLR on a Celestron C925 Edge HD Hyperstar. The hyperstar gives 1,8 arcseconds per pixel resolution. I’m introducing that value manually prior to begin the blind solve. The FOV is 2,36° x 1,58°

If I use the same camera at the native focal length of f10 of the telescope, the scale is 0,413 and the FOV is 32,6’ x 21,4’

I downloaded index 4202 for the 20% of the narrowest FOV (4,28’) 4 to 5,6 arcmin since it corresponds. For the widest I downloaded Index 4212 since it gives 2 to 2.83 deg and matches the widest FOV.

Regards,

Alfredo


#7

You can find two fit images here:

Regards,

Alfredo


#8

You can set the error back to 5 in ansvr. That should speed it up provided you always supply it with the correct scale.

Thanks
Jared


#9

Well, thank you very much for your support Jared!

Now the local server of Astrometry.net is working with no issues at all and every frame is solved in around 30 seconds. I’d never guessed that the decimal separator was the cause (if was “,” for me but worked when I chenged it to “.”).

And the tip to speed up also worked. Hopefully this information will be useful for other users. The narrowest still take a couple of 6 minutes, but I guess it is because the solver has to go through every file of the indexes and are almost 180 files. Since I use a DSLR, I use also a Noise Level of 90 as suggested here:

You guys have a very good support for SGP!

I have one more question: if by any reason the local Astrometry.net server fails to solve an image, then is the online Astrometry.net server still invoqued if the option “Use blind solve failover” of the Plate Solve tab in the Control Panel is checked?

Regards,

Alfredo


www.mainsequencesoftware.com