Astrometry.net local solver


#1

The astrometry.net local solver is a way to run the astrometry.net plate solver locally on your machine, without requiring an internet connection for plate solves.

The installer for the astrometry.net local plate solver for SGP can be found at

http://adgsoftware.com/ansvr/

There you will find instructions for downloading and running the windows installer, downloading astrometric indexes, and configuring SGP to use the local instance of the astrometry.net plate solver.

Andy


Failure with Local Plate Solve (ANSVR)
Plate solving with SkyX
Can I delete ELBRUS and cygwin files?
#2

#3

Andy,

I had a computer crash and tried out your setup. Kudos, it’s super easy.

Thank you!


#4

This topic is now a banner topic. It will appear at the top of every page until it is dismissed by the user.


#5

This topic is not a banner topic anymore. It will no longer appear at the top of every page.


#6

I ran the installer on my machine. The install seems to have completed successfully and all necessary data files were downloaded as well (I can find them now on my hard drive).
However the server isn’t starting.
The log reports:

[2014-11-08 16:24:52] ansvr 0.15 start
[2014-11-08 16:24:52] loading config from /var/tmp/platesolve/config
[2014-11-08 16:24:52] read port 8080 from reg
[2014-11-08 16:24:52] using scale error override value 5 percent
[2014-11-08 16:24:52] using downsample 2
[2014-11-08 16:24:52] solution coordinates will use epoch J2000
[2014-11-08 16:24:52] saving config to /var/tmp/platesolve/config
can’t setup server: Address already in use at /opt/ansvr/ansvr line 1038.
Waiting for data… (interrupt to abort)

Not sure what to do at this point… suggestions?


#7

Daniel,

That means another program is already using port 8080. You have two options:

  1. find the program and configure it to use another port. you can run netstat -n -a -b from a command prompt to see which program it is.

  2. Run the ansvr installer again and choose a different port, like 8081 for example. In SGP, update the astrometry.net endpoint to use the new port number, for example use http://127.0.0.1:8081/api for port 8081. No need to re-download index files, they will still be there.

Andy


#8

Thanks Andy.
There was indeed a service that was using 8080, but even after stopping it, and with netstat reporting nothing else on it I’m still getting the same error from ansvr.
I’ll try to re-install and set it to use port 8081 instead
Thanks,
Daniele


#9

Sometimes Windows will hold on to a port for a while even after the application is terminated. If you wait a while (a few minutes) you will be able to use it. Restarting the machine after disabling the other service would also do the trick.
Andy


#10

this is a very useful enhancement Andy, thanks very much. I have tried it and it works fine.
Paul


#11

I ran into a real curiosity last night when I tried to execute the Framing and Mosaic Wizard in my observatory. As I selected M82, SGPro failed to fetch and complained about “SIMBAD” with Object selected, and “dss.mtk.nao.ac.jp” with coordinates selected.

I found that my Observatory computer (while presently off the internet) must have been previously using the internet to solve this exercise. I also found that my home computer was doing the same, because when I disconnected its internet, it also failed to fetch. I had thought that I was using the local solver all of this time.

This looks like the same issue Daniel brought up earlier in this thread. It looks like my server also could not start because address 8080 was already in use.

What now seems strange to me is that my observatory system has been able to do plate solving successfully during the night (i.e. moving from one target to the next) without an internet connection.

Does this make sense?

Appreciate your help,

Mark


#12

Mark,
If I’m not mistaken the Framing and Mosaic Wizard needs an internet connection to download (fetch) the images that are displayed in the wizard. That is totally separate from plate solving, which you can do without an internet connection if you have ansvr local astrometry on your machine.


#13

You’re rght. Framing and Mosaic Tool requires internet… plate solving with a local astrometry.net server does not.


#14

Hi. I get the same message about the address alreay being in use. Nothing seems to be using it but I tried 1081 instead and got the same error. What other port values can be chosen? I have no idea whether 1082 etc is a good place to start. Also always seem to have to start ansvr manually. Any help much appreciated.


#15

Honestly, any number just about. Try like 8085 or 4037.


#16

Could it be that it is already running when you start it manually? (that would explain the port number being in use)
Did you try Start => Astrometry.net Local Solver => Ansvr Settings to see if it is already running?
Do you see the ansvr shortcut in Start => Startup ?

Regarding the port number: as mentioned in another thread, run netstat -n -a -b from a command prompt to identify the program using the port, or run TCPView.

I would go up one number at a time (8080, 8081, 8082 …) until you find one available.

Andy


Installation of ansvr local problem on Windows 7 system
#17

Ansvr settings results in a blank page noypt found unless I start Ansvr from the shortcut. After this I get the correct settings page. An Ansvr icon briefly appears in the task bar as my machine boots then disappears. I’ll check the the startup folder and try some other addresses. I’ve already run net stat and nothing seems to be using 8080 but I’ll try it again after starting Ansvr to see if it shows up. I presume it should if it’s running and the setting page is opening ok, thanks


#18

yes, that is the ordinary, expected behavior. After that, ansvr should be running.

You could take a look at the log file to see if it reported an error and exited, or if it is still running. (Start => Astrometry.net Local Solver => Watch Ansvr Log) We would want to see the log file before you manually start ansvr, since at that point we would be looking at the new log file when it is the first log file we are interested in.

Andy


#19

Hi Andy. Thanks for the support. Booted machine this morning and ansvr stated ok. I tried blind solving an M33 fits image which I know solves when done through the internet. This is my log file:

~
~
[2014-11-23 10:49:51] ansvr 0.15 start
[2014-11-23 10:49:51] loading config from /var/tmp/platesolve/config
[2014-11-23 10:49:51] read port 8080 from reg
[2014-11-23 10:49:51] using scale error override value percent
[2014-11-23 10:49:51] using downsample
[2014-11-23 10:49:51] solution coordinates will use epoch J2000
[2014-11-23 10:49:51] saving config to /var/tmp/platesolve/config
[2014-11-23 10:49:51] [Server /opt/ansvr/ansvr accepting clients on port 8080]
[2014-11-23 10:52:59] [Connect from 127.0.0.1]
[2014-11-23 10:52:59] GET /api/config HTTP/1.1
[2014-11-23 10:52:59] [Connect from 127.0.0.1]
[2014-11-23 10:53:11]
[2014-11-23 10:53:11] serve notfound uri =
[2014-11-23 10:53:11] [Connect from 127.0.0.1]
[2014-11-23 10:53:11] GET /favicon.ico HTTP/1.1
[2014-11-23 10:53:11] serve notfound uri = /favicon.ico
[2014-11-23 10:53:11] [Connect from 127.0.0.1]
[2014-11-23 10:53:30]
[2014-11-23 10:53:30] serve notfound uri =
[2014-11-23 10:57:00] [Connect from 127.0.0.1]
[2014-11-23 10:57:00] POST /api/config/login HTTP/1.1
[2014-11-23 10:57:00] saving config to /var/tmp/platesolve/config
Waiting for data… (interrupt to abort)

Running netstat gives this:

Active Connections

Proto Local Address Foreign Address State
TCP 127.0.0.1:5354 Chris-PC:49160 ESTABLISHED
TCP 127.0.0.1:5354 Chris-PC:49161 ESTABLISHED
TCP 127.0.0.1:19872 Chris-PC:49182 ESTABLISHED
TCP 127.0.0.1:27015 Chris-PC:49173 ESTABLISHED
TCP 127.0.0.1:49160 Chris-PC:5354 ESTABLISHED
TCP 127.0.0.1:49161 Chris-PC:5354 ESTABLISHED
TCP 127.0.0.1:49173 Chris-PC:27015 ESTABLISHED
TCP 127.0.0.1:49182 Chris-PC:19872 ESTABLISHED
TCP 192.168.1.83:49178 157.55.235.176:40026 ESTABLISHED
TCP 192.168.1.83:49180 db3msgr6011009:https ESTABLISHED
TCP 192.168.1.83:49181 91.190.218.56:12350 ESTABLISHED
TCP 192.168.1.83:49219 snt-re3-8c:http ESTABLISHED
TCP 192.168.1.83:49258 143.127.93.107:http ESTABLISHED
TCP 192.168.1.83:49487 213.120.163.232:http TIME_WAIT
TCP 192.168.1.83:49500 191.234.52.100:http TIME_WAIT
There was 1 more entry I think but the window closed before I could copy it. It definitely wasn’t the 8080 port though.

Do you think I need to reinstall ansvr with a different port? Tried 8081 last night but no luck. Help is much appreciated. Thank you


#20

Okay, seem to have this working now but not sure what is different. It seems fine on 8080! Only issue now seems to be it timed out trying to solve an image of M33 which took only 18 seconds via the net. Maybe I have downloaded too many index files. I downloaded just about all of them. Should I remove some of them and if so which ones, the wide or very smallest fields? Or am I barking up the wrong tree here?
Thanks again


www.mainsequencesoftware.com