Astrometry.net local solver


#42

I just remembered I tweeked my drift alignment the other day without re-mapping my pointing software-
This could be the cause?


#43

I was initially able to access ansvr settings when it was first installed. I haven’t really used it much since I first installed it several months ago. Well this morning I tried to access the ansvr settings webpage and it would not open. The ansvr log says the server was uable to start… the address was already in use; similar to what other posters here were getting. Thanks to this thread I was able to get some good pointers. I’ll try disabling the firewall and changing the default port. But I’m concerned about why it initially worked and now it doesn’t. It seems that Windows is claiming the 8080 port which interferes with the ansvr functionality. Does anyone know if this is the case? Is there a best practice for setting up/starting up the ports and ansvr service?

Thanks.

Ciao,
Mel


#44

Hmmm, maybe but I doubt it. I don’t even bother to make a pointing model at all with my G11 mount. Plate solving should get the mount there on its own. Do you have a “settle time” defined for your mount? I have found it necessary to have a settle time of 20sec so that after a slew the mount stabilizes before the next plate solve frame is taken. Also, I would increase your attempts to 10 or so. See if that gets you closer.

Also, do you know what epoch your equipment is using J2000 or Jnow? They should all be the same, and preferably J2000. But that’s getting a bit beyond my expertise.


#45

Just to update, I was able to get ansvr to work by changing the port to 8081. Thanks for the suggestions on this site!

Ciao,
Mel


#46

Everytime I’ve had that problem it was related to having something set to Jnow when it should’ve been j2000. Go back through and make sure your mount is set to J2000 and that everything else that has a epoch option is set to the same.


#47

Hi, new to the forum and SGP.

I am trying to get ansvr up and running and ran into the same problem that Daniel had (8080port in use). I changed the port to 8082 and can now access the Ansvr Settings on line but not in SGP.

Andy outlined that the astrometry.net endpoint has to be changed in SGP to use the new port number (makes sense) and provided the following entry http://127.0.0.1:8082/api for port 8082 (port number changed to reflect my set up). I’m stuck on exactly how to do this. Where and how do I make this entry?

Thanks for any help,
bach


#48

In the equipment profile manager, under plate solve: Interface astrometry.net click settings.

You can type over the entries in the dropbox to enter what you need.

After you update the equipment profile save it and create a new sequence.


#49

That works great…I didn’t realize that you could type over an entry.

Thanks for your help it’s very much appreciated


#50

I had ansvr running just fine. But then my virus software (Bitdefender) forced an update to 2018. Now it doesn’t work. It keeps blocking and deleting files from \AppData\Local\cygwin_ansvr. I have contacted Bitdefender already but after two weeks they haven’t been able to fix it. They seem to be at a loss.
Does anybody have a similar experience?


#51

I have the same experience with Bitdefender and have contacted them. But I managed to get the local server working and this is how I did it. Please bear with me a bit as I’m not in front of my PC with the server.

In Bitdefender, open it and go to the options page. I think in the upper left, you can list all the “threat” that were blocked by BD. It thinks there is malware in all the unix commands and won’t let them run. Note which ones were run and blocked (like bash, python, etc). My list had something like 33 blocks (including the ANSVR install…I reinstalled it) and quite a few are the same so you should have about a dozen programs.

In the BD setup screen in the upper right you’ll see the advanced threats box…click on the settings gear for that box and under the exceptions, you’ll have to set one for each command run that BD does not like…a bit tedious, but it gets the job done. I did this for the setup program and all of the blocked unix commands and now it works fine. I uninstalled the local server and reinstalled as BD may have made some of the commands “safe.” Fortunately all my catalog files are kept in another drive, so are not bothered by the uninstall and I just point to the directory for ANSR to find those files.

If this doesn’t help, I can get more info when I get back to my PC.

Frank Z…


#52

Thank you very much! I’ll give it a try. even though it’s like more than 800 files.
If you manage to find a shorter list I’d really appreciate it.


#53

You don’t need to exclude all 800 files. There are only about a dozen or so that BD flags. I can post a list of what I set in a few hours.

Frank Z…


#54

OK, here are the files you need to exclude…

Start Bitdefender and go to protection features (“view features” center right of the main panel).

Click on “threat defense” in the upper right “Advanced Threat Panel” This will bring up blocked threats and you’ll find that ANSVR gives about 31 or so.

You need to put all those apps in the Whitelist. Click on the gear on the “Advanced Threat Panel” and it will bring up the Whitelist. Click on the “add application to the whitelist” and you’ll get a file dialog box to add a file to the list. You need to do this for each file…no directories allowed. These are what I placed on the Whitelist and the local server now runs fine…

These files are in the c:\users"USERNAME"\appdata\local\cygwin_ansvr\bin (under win 7)

bash.exe
cygwin-console-helper.exe
env.exe
file.exe
grep.exe
locale.exe
perl.exe
python2.7.exe
sh.exe

under c:\users"USERNAME"\appdata\local\cygwin_ansvr\lib\astrometry\bin

solve-field.exe

under c:\program files (x86)\astrometry.net local solver

indexmanager.exe

and I also placed a copy of the install file in the whitelist. The latest is:

ansver-setup-0.19.exe

As mentioned earlier, I uninstalled and reinstalled the local server just in case BD did something to the installed files when it quarantined them.

Hope this helps.

Frank Z…


#55

@acab

For what its worth – my install of SGP uses ANSVR and my system is running Bitdefender 2018 and it has not blocked nor complained about ANSVR at all. Clearly others have had a problem, so it would be interesting to know why the variation.

Charlie


#56

Charlie,

It could be due to how we have set up Bitdefender. If you disable the advanced threat option, then all may go away. I don’t know since I haven’t tried it (and it’s working now…). My local ANSVR is installed on another PC than my imaging PC. It’s the fastest PC in my network, hence ANSVR won’t tax its resources. But, unlike my imaging PC (a notebook PC), it is used by all family members, hence I don’t really have control on what is run on it, so I leave BD set for full protection. My imaging pc is used just my me, has no virus protection installed (I do run periodic root scans though) and I control what is installed and where I browse, hence I’ve been able to get away with no virus checker to gum things up.

Frank Z…


#57

The statistic used to be that a Windows XP machine connected to the internet without a hardware firewall, and without antivirus software running, would be owned by some Belarusian teenager, on average, in about 10 minutes. I believe Windows 7 boosted that time to about 15 minutes… I haven’t heard where Windows 10 is on that statistic, but simply connecting to the internet puts your PC at risk, you need not browse anywhere at all, and once they’ve installed themselves, many worms are very difficult to detect. You can run a PC without A-V software, but you should not, if you connect it to the internet. I just don’t think there’s any way that that counts as prudent.

Karl


#58

Charlie,
I have the problem in two computers. A new one that had Bitdefender from the start and ansvr never worked. The older one had Bitdefender 2017 and ansvr worked fine. Then a forced update to 2028 came along and it has not workde since.
By the way both computer have Windows 10. Which windows version do you have?


#59

@acab

I have SGP, ANSVR and Bitdefender 2018 on my home PC (Windows 7) and on my observatory PC (Windows 10 Pro) and neither have reported an issue. AFAIK, I don’t have any special setup of Bitdefender and I have never white listed anything. Both these computers had Bitdefender 2017 and ANSVR installed when the auto update to Bitdefender 2018 occurred.

Charlie


#60

Worked like a charm!
You were right. In fact after closely looking at the list of Blocked Applications I realized that it kept repeating them.
And yes I had to reinstall first because Bitdefender had already deleted the blocked files. I then added your list to the whitelist before trying to run ansvr.
Thank you very much! I’m sure several people will benefit from this.


www.mainsequencesoftware.com