Atik Camera Freezes on Image Downloading


#1

Hi guys,

Having some reliablity issues with my Atik One 6.0. On occasion during frame and focus or during image capture, my download bar hangs and SGP freezes forcing me to quit SGP. I have checked the SGP log during a frame and focus crash and an ASCOM camera error is reported.

Readout speed set to NORMAL…
[25/11/2016 8:26:11 PM] [DEBUG] [Camera Thread] ASCOM Camera Error : CheckDotNetExceptions ASCOM.Atik.Camera StartExposure System.ApplicationException: StartExposure - Camera not idle (See Inner Exception for details) (System.ApplicationException: StartExposure - Camera not idle)
at ASCOM.DriverAccess.MemberFactory.CheckDotNetExceptions(String memberName, Exception e) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 630
at ASCOM.DriverAccess.MemberFactory.MethodTargetInvocationExceptionHandler(String memberName, Exception e) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 678
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 487
at ASCOM.DriverAccess.Camera.StartExposure(Double Duration, Boolean Light) in c:\ASCOM Build\Export\ASCOM.DriverAccess\Camera.cs:line 594
at qo.h6(oz A_0, qy& A_1)
[25/11/2016 8:26:11 PM] [DEBUG] [Camera Thread] ASCOM Camera: Attempting to abort exposure…
[25/11/2016 8:26:11 PM] [DEBUG] [Camera Thread] ASCOM Camera: Exposure aborted…
[25/11/2016 8:26:11 PM] [DEBUG] [Camera Thread] ASCOM Camera: Blocking until image is aborted…

From another SGP forum post “Center object hang due to camera timeout”, it looks to be a some what similar problem.

For reference, SGP version is 2.5.2.5 and Atik driver version is the latest at 4.1.0.9. The Atik One 6.0 camera is connected directly to my PC (Microsoft Surface running Windows 10 x64) via USB 3.

Thanks,

Adrian

sg_logfile_20161127200404.txt (27.4 KB)


#2

Hi Adrian

I’ve had numerous issues when connecting my Atik one 6.0 to a USB3 port. Sometimes works but majority of the time my downloads hang or I get a complete drop out and the camera disconnects.

Have you got another PC/laptop that has USB2 ports. Just to rule out the USB version being the issue.

Cheers

Mark


#3

Hi Mark,

Thanks for the response. I do have another laptop that has a combination of USB3 and USB2 ports, so could give that a try. It will take a few days to allow me to reformat it, the windows 10 upgrade from windows 7 turned it into the slowest machine on earth.

It does sound like I’m getting similar behaviour to you though when using USB3.0. So just to confirm, all your issues disappeared when you switched back to USB2.0?

Regards,

Adrian


#4

Hi Adrian

That’s correct, I am busy imaging at the moment, since 18:00, and it’s now going on midnight and not one issue.
I have found that despite USB3 supposedly being backwards compatible, I could just never get it to hold a stable connection. All my Equipment, CCD, Guide Cam, motor focus and mount are all going through USB2 now and going well.

Let us know how you get on…

Cheers

Mark


#5

Hi Mark,

Had a chance to reformat my other laptop with a fresh windows 10 install which has 2 x USB2.0 and 2 x USB3.0 ports present on it. Installed the latest release of SGP and Atik Divers and tested it with both port versions.

Unfortunately the same result in the SGP log is reported resulting in SGP not responding. I have managed to replicate the problem quite consistently-ish through the frame and focus window but using the following, round about, method.

  1. Start by running a frame and focus using 1x1 binning @ 1 sec. Let that run a few times (4-5) successfully and then during the downloading stage press ‘stop’.

  2. Following this keeping the 1x1 binning @ 1 sec, run a ‘take One’ option.

Now this is where it gets interesting. At this stage I have had the downloading progress bar continually spin. If this occurs, checking the log will result in the log ASCOM camera issue posted above. Selecting ‘Stop’ will then make SGP stop responding.

Perform this test 5 times, including some with PC reboot, SGP produced this error all 5 times.

Following on from this, normally I would perform a continuous Frame and Focus using 4x4 binning followed by a ‘Take One’ afterwards just to confirm accurate focusing. Performing the above test using 4x4 binning at step 1 resulted in no problems during pre-testing. Nontheless, I suspect that stopping the 4x4 Frame and Focus at the ‘right time’ would produce the same result. The probability of this happening though I believe is reduced due to the faster download times.

As for the download freeze occurring during my sequence run, this happens a lot less but still on the odd occasion. I will have to double check that it is the same ASCOM issue in the log file next time this occurs.

Mark, next time you are out imaging or have some free time, I would greatly appreciate if you could test out the two step method above to see if you can replicate the issue for curiosity sake. In the meantime I will still try to search for a solution.

Thanks and regards,

Adrian


#6

Hi Adrian

Ok, so that is interesting.
As I don’t usually perform continuous Frame and Focus, I let the motor focuser take care of that, I will try to replicate your steps this afternoon to check if I can reproduce the issue.

The below camera settings in SGPro are what work for me, others may have differing views/settings:

  1. “Use high speed download” is disabled in Equipment Profile (EP) and/or Control Panel (CP) under the camera tab (caused me issues in the past when downloading Frame and Focus and Take One frames).
  2. “Preview Mode” is disabled (with the camera connected to SGPro goto CP then click the setting button on the camera tab)

A quick rundown of the SW versions I am using are as follows:
SGPro -
Beta v2.5.2.7

Atik One -

  1. According to the Device manager driver details under USB controllers - Atik One
    Driver provider: libusb1.0
    Driver Version: 0.0.0.0
    Digital Signer: Artemis CCD Ltd

  2. According to the camera settings on the EP, CP camera tab (with camera connected)
    Ascom Driver Version: 7.0.4.18147

I downloaded and installed the Atik One files from Atik Core Software then navigated to the “Program Files (x86)\Atik Cameras\Drivers\64Bit\New” folder and installed the “Atik_LibUSB_Drivers” from there.

Will get back to you later in the day after testing to let you know if I could reproduce the issue.

Cheers for now

Mark


#7

Hi Adrian

So I put my Atik one 6.0 and SGPro through a series of tests and nothing I did could replicate your particular issue. I even tried enabling the high speed download and priority setting in different sequences but that made no difference. I then tried running it all in my usual setup with everything loaded into a 4 port USB2 powered adapter running through a single 15m USB2 extension cable to the PC in the house and no matter what I tried I could not get the download to hang.

The only thing I didn’t try was plugging into a USB3 port on the PC as I know from past experience that doing that gave me issue and fixes (uninstalling drivers and reinstalling) that I would rather not have to repeat.

The only thing I can now suggest is first trying another good quality USB2 specific cable and if that still fails then try the latest versions of SGPro and the Atik driver, if you haven’t already.

Sorry I can’t be of any further help but do keep us posted on how you get on.
If I think of anything else I’ll be in touch

Regards

Mark


#8

Hi Mark,

Thank you for having a go at trying to replicate the issue for me, much appreciated. You have some good suggestions so I will run through them all hopefully today. I will also try and get all software/driver version as per your setup.

Once again thank you for testing this out and I will let you know how I go.

Regards,

Adrian


#9

@AdrianD

Have you had a look at the ASCOM logs for the camera to see what state it’s in when things go south on you?


#10

Hi Ken,

Apologies for the delayed reply. Unfortunately I do not have any ASCOM log information as yet. I will look up a procedure for setting up ASCOM logging during camera operation. I can see where the ASCOM log files get saved to however I’ve only managed to generate log reports running an ASCOM debug routine.

On a side note I have figured out my camera will freeze from SGP when accidentally double clicking either the ‘Take One’ or ‘Start’ buttons (forces the camera to begin an exposure and quickly dump it) followed by a very soon click of one of those buttons again. Within a second or so. This can occur without knowing due to the sensitive touch screen computer. Must be a delay in the ASCOM driver?

A freeze can be prevented by waiting for a period of time (5-10 seconds) before selecting the exposure button again.

Thanks and kind regards,

Adrian


#11

Not sure I follow this 100%. When you click those buttons, they turn into a “Stop” button. Are you saying that attempting to stop the exposure before it’s begun creates the problem? Is that what you mean by “quickly dump”? That could be a problem I suppose… ASCOM camera logs would confirm that.


www.mainsequencesoftware.com