Auto Center fails the validation step


#1

I have a Paramount MYT, just started using SGPro V2.6.0.23
I am able to use all the basic functions (including platesolving) to run a sequence, but having trouble with auto centering at the start of a sequence. I am using the PlaneWave plate solver
The camera takes the initial short exposure and plate solves it in a few seconds.
SGP then moves the mount to approximately the correct center position and takes a second picture.
That picture gets fed to the plate solver a second time, and the solve fails after a few seconds. So the validation step of centering fails, and the sequence won’t run.
I have seen others mention this, but have not seen a solution. My mount driver is set to J2000 epoch if that makes a difference.
It’s probably some setting I missed; I’d be grateful if somebody could point it out.

Thanks, Steve


#2

Are you using a pointing model?
If you haven’t already, you should set up ANSVR as a blind solve failover.
That way, if PS2 fails, the blind solver will kick in and attempt to solve
and sync the mount. I have seen many instances where PS2 will fail in
certain parts of the sky, but then ANSVR kicks in and successfully solves
the image and the sequence continues.


#3

Thanks for the comments. Yes, I have a decent pointing model; my mount can get the intended object within about 3 arc minutes of center on its own without any help from SGP.
I need to explain more about the failure mechanism. If i invoke the plate solver manually, it works every time. I have the failover setup, but it’s never had to fail over so far. It solves images in seconds. But when I use Auto Center, it quits before it gets that far. Here’s my example:
Last night I chose an easy target, M31.
In the target list I selected Auto Center and started the sequence
As expected, my mount got pretty close (3 arcminutes) on the first try.
SGP took a picture, plate solved it in 1 or 2 seconds
SGP then moved the mount slightly to correct the 3 arcminute positioning error.
SGP then took a second picture, downloaded it, and launched the plate solver again, to verify the new position.
The plate solver failed within 1 second, on a picture it had just successfully solved about 20 seconds earlier.
So the problem is not with the plate solver itself; it acts like there is missing information that just aborts the task as soon as it starts. I’m speculating perhaps something is missing from the FITS header?
I say this because when I try to do the manual centering technique, it works whenever I try it on an image that I retrieved from the HDD, but it fails whenever I try it on the same exact image that was put up by SGP automatically. Those two images are different somehow, I just don’t know how.
Hoping You do.

Thanks, Steve


#4

A little bit of progress. I find that if I plate solve at least one image manually, then the plate solver works on both the first and third step for center and autocenter. Apparently it is picking up the plate scale from the Hint form instead of from the plate solver form in the profile. In any case it finds the center of the plate in one or two iterations, very quickly on both passes. But still the validation step fails, and the action will not complete because of it.
Looking for any ideas…


#5

A further update. Reading the logs, the issue is not really about plate solving per se. The plate solver is working. What is failing is the synch at the end of the plate solve.
There is another whole long thread about how this used to work with SkyX 10.3, but was blocked in SkyX10.5
The ultimate conclusion in that thread was that the SGP team decided to implement Synchless Centering, but with no promised delivery date. That post entry was made in Aug 2016, so I guess it still hasn’t happened yet.

This thread can be closed.


#6

Let me way in just a little bit. My solve and sync works just fine, using the latest version 2 of SGP on two other mounts. I know the SkyX people removed the sync command from SkyX so that you use Tpoint to build your pointing model. This may have an affect, I will ask Richard Week next week when I see him from Software Bisque. … Bruce


#7

Thank you Bruce. I agree SGP solve and sync works fine on many mounts, just not Paramounts (unless you kept an old version of TheSkyX. I have looked repeatedly for updates from either company since my original post, but found nothing that mentions this issue. It would be interesting to hear what Richard Wright has to say.
Pretty soon I will download a daily build of TSX and test it again to see if anything has changed.

Once again thanks for your interest.

Steve.


www.mainsequencesoftware.com