Auto centering


#1

Hi all

I’m having difficulty with auto-centering, basically the mount is not moving sufficiently to center the object as per reference frame. A typical example would be: slew to object, either to start or after a flip and I am around 100 pixels off and I set the tolerance to 50 pixels. SGP then struts its stuff, takes frames and only moves the mount by 2-3 pixels, so it fails after 20 attempts (which I set in the parameters). I have set the image scale when I did a plate solve (1.4 arc secs/pixel for me) and I also have the pixel scale and focal length set up in the equipment manager. Perhaps the only difference for me is that I am not using an autoguider and image unguided, so use direct mount guide.

I am using the latest version relesed a couple of days ago, although have had the same issue with previous versions. Any idea’s?
Adrian


#2

One more bit of info, I have telescope nudge set to 1.0 degrees for high speed and 0.2 degrees for low speed, but not sure of its relevance?


#3

I have this problem too. Since at least 2.5.2.0.

Mount: Celestron Cgem with latest firmware and it uses JNOW.
Camera Resolution, Px scale, rotation, focal length all set and correct.
2x2 binning and 5 sec plate solve exposures.

Before it used to center perfectly within 25px with one or two attempts. Now it gets to about 120 px rms and stays around there (maybe getting as low as 95px after the 5th or 6th attempt).

I tried different plate solvers (Elbrus, ansvr local (sending JNOW and J2000 epcochs), ansvr remote, plate solve 2) which offered no improvement. I tried ansvr local Jnow to see if SGP had and error in its calculations, but this wasn’t the case.

I also tried setting binning on plate solve exposures to 1x1 to see if the error returned when using 2x2 binning was at 1x1 px scale, and this was also not the case.

The whole time, the default Sync Behavior has been used (not sure what it was back in 2.5.1.17, but it is set to Sync now).

Glad to see that it’s not just me who’s seen a decrease in centering performance. It used to center and frame so well, so quickly… And now it is not the case :frowning:


#4

One more thought, I recently bought a new camera, the ASI 1600mm and I hadn’t put the camera chip size in pixels in the camera tab settings (it was set to 0x0). Although I had put the pixel scale in, could this be the reason?


#5

Homer, to me it sounds like the mount nudging calibration is not set correctly and same for you. I doubt the plate solving software is to blame though. Double check that everything in the camera menu is filled in correctly.
Adrian


#6

I think mount nudging settings are for moving the telescope manually, and not used by SGP to “drive” goto slews and centering platesolve slews. I believe SGP sends J2000 (or J2000 converted to JNOW) RA and Dec positions to the mount via ascom, which then tells the mount to go to said coordinates.

My nudge settings are 1 for high and 0.5 for low. The default values I believe as I do not use nudging in SGP (even a low nudge would move my FOV way off target lol). And my camera settings are all filled out 100% correct.


#7

You did not provide any logs so my guess is that SGPro is fighting with your mount’s modeling software (this is what we usually see when there is a request to move and no convergence).


#8

Hi Ken,

Could it be more beneficial to run with a simple quick align (mount knows position and time) and let sgp do the rest? Instead of a 2 alignment stars + 4 calibration stars model?


#9

Hi Ken
I’m using a 10u GM2000 mount which without any model gives tracking errors of around 2-3 arc secs over 10 minutes, so any corrections are of this order of a magnitude. When I tried to re-center with SGP, it was 100 pixels off equating to 140 arc secs or over 2 arc mins out and the corrections issued by SGP were over a time period of less than one minute, so I would find it surprising if the model was fighting SGP for the “nudging” of the telescope.
Can you tell me what functions/parameters SGP is using to move the telescope to recenter objects?

After entering ALL the data in the camera settings, I re-ran the auto center and deliberately made an offset of about 1 arc minute and it then re-centered properly, so this would suggest SGP needs all the data, even if the pixel scale is already set. Am I right?


#10

Homer, a good point about the nudging, its too much. I use the sky which you can set to “jog” a certain distance as low as a few arc secs, a request for future updates?


#11

What method are you using for centering - Sync or Offset? If using the Sync method with TSX, it won’t converge when centering. Also, if using SGP 2.6.0.8, it likely won’t work either because the Offset2 method was put in as Offset and again, won’t converge to center with TSX. I would recommend using SGP version 2.6.0.7 or below and use the Offset method for telescope centering until Ken and Jared put the original offset method back in (which is planned). I use TSX with my Paramount and can center to less than 10 pixels, usually it’s only 3-5 pixels off after centering.

Chris


#12

With an AP Mach1 I do not do any initial star alignment. Just turn on the mount, take and solve a framee and then Solve and Sync For me it works all the time.
Renan.


#13

Hi Chris

I’m actually using SKY6 because it uses J2000, same as Pers Model Maker and I’m using SGP 2.6.0.6. Is the offset you are referring to a parameter in SKYX? I basically bypass SKY6 and use my mount, the 10u GM2000 directly for slewing and SGP takes over for auto-centering. So the SKY6 is just there and being updated, but not intervening.


#14

I’m talking about the telescope centering method in SGP. Look in the telescope tab of the control panel. I only use TSX as an interface to the mount because the Paramount requires it. If your mount does not require using TheSky, just let SGP handle everything through an ASCOM driver.

Chris


#15

Any time the centering routine gets stuck at some value and doesn’t improve - that is an indication that the offset2 method would work well once it is implemented to take care of that remaining error. My mount and others has no problem with its internal model of the sky - but it has other errors that prevent centering from working well - even though it should center very accurately and quickly once that residual is accounted for in each move.

Frank


#16

Is the mount/driver set to “syncs align model” or “syncs append to refine model”?
For centering to work it has to be set to align.

Could you tell a little more about your setup? Scope? amount of model points?


#17

Chris - sync behaviour is set to sync and I just have the SKY running to give me some indication of where my scope is pointing as I am cozy in the study :slight_smile:

Xplode - I am using an FSQ at prime focus, a new ASI1600mm cool camera ontop of a 10u GM2000HPS. I never guide, no need and use Pers Model Maker, weather stick, 10u remote keypad.

Im running the setup again tonight, yep another clear night in the UK and my autocentering has worked fine, but I did increase the centering tolerance to 100 pixels…

Adrian


#18

With a good model you should be well within 100 pixels at that focal length.
How many model points do you have and what is the RMS?

Is your time accurate? Do you use a GPS to keep it accurate over time?


www.mainsequencesoftware.com