Auto guiding with SX AO

I have a Starlight Xpress usb AO and I use it with PHD2 with no issues. The problem I have is when I use a SGP sequence it starts up PHD2, connects my gear and starts guiding but the message in SGP is “starting guider…please wait” I’ve waited for 5 minutes with this message and of course my sequence won’t start. Anything I am missing with my settings?

I use the same SX AO (USB) unit and have not seen that. OTOH, I do not let SGP start PhD. I always start PhD and SGP separately, connect stuff in PhD, cycle and locate the guide star in PhD, stop cycling in PhD and then start the sequence in SGP. Always works fine.

Probably a different mount (paramount) but am not sure if that matters.

Hello,

That procedure definitely works with me as well, in fact I was doing just that last night. Problem is without SGP connected to PHD2 (It wasn’t) I would have to stop every two frames and manually dither and that sucks. Can you start up PHD2 and SGP separately, then after you start guiding, connect to SGP and start your sequence?
I have a CEM120, I also have the Theskyx pro, just like you. I really wish that Theskyx would implement the SX AO as I love that piece of kit.

Maybe your saying start the guiding in PHD2, then go through the sequence in SGP, let it connect to the already guiding PHD2 and the sequence will continue on as normal? Correct?

If you are able to provide logs, there will likely be more detailed information present.

Hi Ken,

sg_logfile_20190807212708.txt (442.7 KB)

Here are my latest logs.

Mike

The problem is at the very end of the log files.

Not quite. I start guiding in PhD, then stop the guiding in PhD, then start the SGP sequence.

It looks like we requested to flip the calibration data, that failed and things went off the rails from there.

It also looks like the equipment was disconnected or couldn’t connect in PHD2. Are you using the option in SGP to automatically connect gear in PHD2?

[08/07/19 22:02:37.798][DEBUG] [Sequence Thread] PHD2: Attempting to start guiding, waiting for PHD2 settle done message...
[08/07/19 22:02:37.873][DEBUG] [PHD2 Listener Thread] Error received from RPC: all equipment must be connected first

Thanks,
Jared

I’ve tried this method recently, my problem was using dither, after dithering the RA and Dec would oscillate wildly back and forth and never settle down.

Yes Jared, I have everything set up to auto connect in PHD2.

www.mainsequencesoftware.com