Autocenter fails after EQMOD meridian flip


#1

I’m unable to autocenter after performing a meridian flip.
I’ve followed all of the instructions for SGP EQMOD flips.

In EQMOD I have:
SideOf Pier set to Pointing(ASCOM)
Allow Auto Meridian Flip set to OFF
The Point Count is zero
DxSA and DxSB are both zero
User Interface is Dialog Based

And in SGP I have Minutes Past Meridian Flip set to 1.

The Flip works fine, but the autocenter validate shows an RA Error of 917242 pixels and a DEC error of -1572 pixels.
The autocenter routine keeps retrying but always comes up with the same result.

Anyone got any suggestions?


#2

Need logs. Please post them!


#3

This might help:

Peter


#4

here’s the link to the log file. The flip occurred at 23:07


#5

I had lots of trouble also…setting the Past Meridian Flip as far as possible past 1 is one idea , mine is 8, that might get you closer to start with after the Flip ( do this only if safe !!!. NO CRASHES !!!). Also, the centering routine I set VERY high , like 20 (I know , that is a pain). It will show the same result a few times then suddenly “SNAP” to a much closer result and go from there. Also, download the very latest version of SGP, it seems more able to center successfully after the Flip with less tries . I have a portable setup on a Tripod. According to others , it is the backlash that is causing the problem.

Hope this helps


#6

http://mainsequencesoftware.com/Content/SGPHelp/SequenceGeneratorPro.html?UsingEQMODwithSGPro.html

Did you follow this checklist? Are you using an EQDIR module? I tried helping someone with EQMOD and the end result was it doesn’t work correctly unless you have the EQDIR module.

Meridian flips are something you can practice during the day. Just turn off guiding/centering, slew to a star near the meridian and command meridian flips manually using the button the ‘telescope’ tab.


#7

Have you checked for cone error?
If your scope is not parallel to the mount axis, a meridian flip will double any error.


#8

Yes I followed the checklist and yes I am using EQDIR.
The flip works perfectly, and I can see from Cartes du Ciel that the scope was pointing correctly at the target after the flip. The issue is only with the autocenter failing.


#9

What were you using for plate solving?


#10

Astrometry.net


#11

are you using the latest version of SGP ?? I think they improved the centering routine.


#12

I’m on 2.15.1.17 which the version check says is the latest


#13

These logs are from April 23, 2016.


#14

Oops - yes!
Try this:


#15

@PeterGoodhew

It’s hard for me to be precise with an issue like this. All I can say with any amount of confidence is that something went very wrong.

Your mount is tracking and then SGPro identifies the need for a meridian flip. This is executed and requires a slew back to the current position from the other side of the mount:

[17/10/2016 23:05:08] [DEBUG] [Telescope Thread] ASCOM Telescope: Pier side is West
[17/10/2016 23:05:08] [DEBUG] [Telescope Thread] ASCOM Telescope: attempting pier flip using slew
[17/10/2016 23:05:08] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 23.8141949455969 (23h48m51.10s) Dec: 62.2020703125 (62°12’07.45")

Everything seems fine so far… Then precision centering takes over. After the flip, your mount is found to be here:

[17/10/2016 23:06:32] [DEBUG] [Telescope Thread] Solve appears to be good…
[17/10/2016 23:06:32] [DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 0.0715178975133333 Dec: 62.8038669924

SGPro issues the command to go here:

[17/10/2016 23:06:32] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 23.7871344925333 (23h47m13.68s) Dec: 61.4545485955 (61°27’16.37")

After this command, it is validated here though:

[17/10/2016 23:07:10] [DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 0.0773569682053333 Dec: 62.064135391

This is a significant error and with a scale of 5.5"/px results in a large pixel error:

[17/10/2016 23:07:10] [DEBUG] [Center Scope Thread] Retrying auto center. Total Error > Allowable error: 917243.4 > 50.0

After issuing another request to move to that location, the solve suceeds and places your scope here:

[17/10/2016 23:07:50] [DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 0.077390306294 Dec: 62.0646297281

You are not converging. You indicated that you followed the EQMOD setup guide with exactness, but this really looks like the dozens and dozens of logs I have seen that are fighting with the mount’s modeling system. We ask it to go somewhere… that request is modified in order to conform to various modeling errors and no convergence is seen.


#16

Thanks Ken. As per the instructions I cleared out the model from EQMOD beforehand, sync data (DxSA and DxSB are zero)
After the flip the sync corrections are active again because SGP performed a plate solve and sync just before the slew. Could this explain what happens? If so, is there anyway of stopping SGP from syncing before the slew - but still have it autocenter after the slew?

I should add that the EQMOD points model remains empty.


#17

I never touch “(DxSA and DxSB)” once the telescope is in sync. In fact - I think I set them to zero once, long time ago. Still It works perfectly!


#18

You can tell it to slew first then center the target.


#19

FThat would be great, but I can’t see any way of doing that automatically. The Meridian Flip Options panel just offers “Auto Center After Meridian Flip”. Ami missing something, or does this have to be done manually (which isn’t the idea of an automated flip)?


#20

Hi Peter,

Quoting Ken’s answer:

[Quote]
SGPro issues the command to go here:

[17/10/2016 23:06:32] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 23.7871344925333 (23h47m13.68s) Dec: 61.4545485955 (61°27’16.37")

After this command, it is validated here though:

[17/10/2016 23:07:10] [DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 0.0773569682053333 Dec: 62.064135391

[/Quote]

Given the difference between the slew RA (that is where the mount thinks it is pointing) and the solved RA, EQMOD will silently drop the sync command (unfortunately w/o throwing an error). There is a self-protect limit built into EQMOD to reject suspect Syncs, if I remember right, hard coded at 5°.

How come, that you have that difference? Is the scope position after the flip looking right?

Regards,
Horia


www.mainsequencesoftware.com