Autofocus Delay between Data Points


#1

I’ve used the SGPro Beta v2.4.0 2618 since the beginning of the trial period. Tonight the autofocus was noticeably slow. If memory serves, 5 seconds has been the time delay displayed from one autofocus data point to the next. Tonight the delay display (and actual time) was 30 seconds. A roughly 45 second autofocus action had increased to 4 1/2 minutes.

The one difference from the night before was a newly created Sequence. However it used the standard profile from which all sequences have been built.

I’m not aware of there being an adjustment for the individual time delay. Can you help me on this? Any suggestions would be appreciated.

Thanks,

Mark


#2

Are you using any options like having the auto guider settle between focus points? Can you attach a log?

Thanks,
Jared


#3

Jared made a good point. Same thing happened to me and I changed the auto guider settling (larger number) and that helped speed up the AF process.

Peter


#4

HI Jared and Peter, don’t you guys ever sleep?

But thanks for the quick follow-up.

I did change the settle at pixel value from 0.7 to 1.0 a little over a week ago. This really eazed things up on the start of the next image. At 0.7, it often took a couple of minutes, or failed outright. Now, no time to start the next image.

I stand corrected. The delay time between AF data points is now 35 seconds. See Images 1 and 2.

Images 3 and 4 show the setup for the focusing. Image 5 shows the setup for the guiding.

Mark


#5

Sleep? What is sleep? :sleeping:

Peter


#6

Mark,

We will still need to see the log file to be of any assistance.

Ken


#7

Jared,

Yep, sorry. Memory is the first thing to go, and I can’t remember the rest of the joke.

The Drop Box now includes the log file.

The larger (and latter) of the two files should have one of the AF events right at its tail end.

And to answer your question about options to settle between focus points … I was not aware that there was such a feature.

Mark


#8

Hi Jared,

Just checking to see if any new has been determined on this.

Thanks,
Mark


#9

Mark,

A quick look at your logs shows that you are using 35 second exposure times. This would certainly explain the time difference you are seeing.

[1/6/2015 8:53:30 PM] [DEBUG] [Camera Thread] Taking auto focus frame(s)...
[1/6/2015 8:53:30 PM] [DEBUG] [Camera Thread] ASCOM camera: Capturing auto focus frame...
[1/6/2015 8:53:30 PM] [DEBUG] [Camera Thread] ASCOM: AF Binning: 2x2...
[1/6/2015 8:53:30 PM] [DEBUG] [Camera Thread] ASCOM: AF Exposure length: 35 seconds...

Furthermore, if you intended to override your AF filter in order to achieve faster focus with narrowband filters, you have that option turned off:

[1/6/2015 8:10:59 PM] [DEBUG] [Sequence Thread] bUseAutoFocusFilter: False
[1/6/2015 8:10:59 PM] [DEBUG] [Sequence Thread] sAutoFocusFilter: Filter 1 LUM

#10

Thanks Ken,

You are correct. In fact, if you look at the Drop Boxed screen shot in my second post, you can see (and I should have) that the Auto Focus with Filter was unchecked. This explains that I was using my NB filter during focus, and that filter uses a 35sec exposure. My apologies for overlooking that.

Now the concerning thing about this is that the Auto Focus with Filter had previously been checked. I always A/F with the LUM filter, even though I will be shooting with NB. But I’ve noticed a tendency for SGPro to “uncheck”, or drop, some of the functions over time. Primarily “dither” and now this feature.

While I was prepared to blame my old Dell MSVista desktop, I have found the same problem on my home MSWindows 7 computer. With the Beta 2618 release, each time I check the Auto Focus with Filter box in the Equipment profile Manager, it fails to save.

The same action on the Control Panel does save. However, until we get clear skies, I won’t know if that command will work.

Sorry for the hassle,

Mark


#11

One more.

The following is true for both computers previously mentioned.

The Auto Focus with Filter feature in the Equipment Profile Mgr can be checked and saved in all revisions up to and including v2.3 2568.

The same feature in the Equipment Profile Mgr will not save after being checked saved in all v2.4 (2607*, 2618 and 2629).
*Could not get 2607 to operate when I re-installed it.

Mark


#12

I can’t duplicate this. Have you tried creating the profile from scratch? We try to preserve profiles between minor versions but occasionally things go wrong. I would try creating the profile from scratch.

Thanks,
Jared


#13

The following is for SGPro v2.4 (all builds)

  1. Open SGPro. Use default sequence.
  2. Select “Filter Wheel Simulator NET” for filter wheel. Connect filter.
  3. Select “Simulator” for focuser. Connect focuser.
  4. With default sequence displayed, hit CTL P to open Equipment Profile Mgr.
  5. Create new Profile, and go to Filter, select Similator, and populate at least no.1 location with “Lum”. OK.
  6. Go to Focus and enter only Focus selections: “Auto Adjust per Filter”, “Use Autofocus”, hit SET, “Auto Focus with Filter” and “LUM” and OK.
  7. Select “Use profile as default for new sequence”, “Save” and OK. This returns you to sequence.
  8. With this sequence displayed, hit CTL P to reopen Equipment Profile Mgr.
  9. Select newly defined Profile and open Focus, then adjacent to “Use Autofocus”, hit SET.
  10. All settings done previously in the new Profile will be on the previous page and here, EXCEPT for “Auto Focus with Filter”.

This is 100% consistent on my MS Windows 7 home computer. From what I’ve seen, I believe it to be true on the OBS computer also.

If I do all above and restart SGPro, the Control Panel will usually show “Auto Focus with Filter” checked. However, I have seen it go uncheck upon occassion.

If I revert to v2.3 2568, and go through the above exercise, the “Auto Focus with Filter” remains checked in Equipment Profile Mgr.

As mentioned earlier, as soon as there is a sky, I will watch the focus behavior and report back. At present this is at least a quirky behavior by the v2.4 software.

Mark


#14

Ah, I see the difference. I was opening up the sequence and verifying that a sequence made with that profile has the the “Auto focus with filter” set (it does). However the profile that created that sequence does not have the box checked.

We’ll address this in the next 2.4 release, thanks for the report!

Thanks,
Jared


www.mainsequencesoftware.com