Autofocus not happening on filter change

Hi,Not sure if I have a setting incorrectly set, with the issue being that autofocus on filter change isn’t being kicked off in a specific situation.

I have the following focus options set (the others are unchecked):

  1. Autofocus every 1 degree
  2. Autofocus on filter change
  3. Autofocus before sequent start
  4. Autofocus after automatic centering option

When going through a list of events normally, that is in order, autofocus seems to be kicked off with filter changes as it should.

But sometimes, I’ll pause and then uncheck the run box of an event (maybe too much moon light) and check the run box of an event that was unfinished but prior to the paused event in the list. I use the run box to force the order of events sometimes (and keep all others unchecked. In one case, too much moonlight and I wanted to force it to start running my narrowband captures which was previous on the list.

When I resumed, it changed the filter, in this case from luminosity to Ha, and started capturing without focusing. I had to pause and abort, and do force auto focus from the autofocus button.

So that’s one case. In another case I am taking a large number of images, and have to pause in the middle because it’s the end of the night or whatever. And the next day I resume, restart the sequence, and it doesn’t start with an autofocus. I thought, previously it would always autofocus at the beginning of a new session, when it’s a new night, and of course temperature will be different, etc… This seems to be a recent change because I haven’t changed my settings. So I had to force another focus from the focus button.

I do not have autofocus on resume set, but don’t recall that needing to be set to force an autofocus of a continued imaging session on a totally different day. There are many reasons I might pause a session, and don’t check the autofocus on resume because I don’t want to add autofocus in all situations when I pause.

Thanks,
Terri

Most of the time if you are interrupting the sequence you are sort of manually overriding what is happening. This is probably due to the autofocus setting “[x] Auto focus before sequence start (not on resume)”

It’s handy though as to not get a re-autofocus when not necessary. It’s confusing sometimes I agree.

Thanks for the reply, but I’ve never had it not autofocus on filter change. Regardless of how the filter change comes about because I do this all the time. Also, the sequence started without autofocus, just because it was a continuation of prior nights session. I am pretty sure that i’ve never started a whole new imaging session (continuation of prior or not) that didn’t go through autofocus to start.

When you say that you changes it, I assume you mean the SGPro sequence changed it right? Making sure it was not manually changed via the ASCOM driver.

In either case we would need logs to investigate further. The cases you describe, one is easy to try and I was unable to produce it and the other seems like there is very little chance I can reproduce our conditions exactly. Details here:

Hi Ken, I should have posted the log…sorry, Links are below after my answer to your question.

My sequence of events was tainted by poor memory. The first focus on the night did occur as normal. It was the next two that did not (I read the log…) Below is sequence with a couple of time stamps and the log file link below this.

I have a sequence that has the following events (filters change):
1 - Lum filter, 2 -Ha filter
I started the night with event 1 checked, Lum, and let it take a few frames and then paused.
After evaluating the frames I decided to run narrowband instead (moon out)
I aborted the event.
My last Lum frame early in the night is stored at 10:20pm 6/8
I unchecked the run box for Lum event, and then checked (or left it checked) the run box for Ha event.
The filter changed to Ha
I resumed the sequence (don’t recall whether the button said resume or run sequence)
The image started integrating an Ha event frame immediately without autofocus.
I paused and aborted the current image.
I forced autofocus using the focus control button and hitting the run command.
I ran the number of frames for Ha until I decided sky was dark to start Lum event again.
My last Ha frame is stored at: 12:33am 6/9
I paused and then aborted the event with Ha filter.
I then checked the run event box for the lum event and unchecked the run box for Ha filter event.
I then hit resume or run sequence (not sure what button was named at the time)
The filter changed to Lum.
SGP immediately started integrated an image instead of autofocusing.
I again paused and then aborted the image.
I forced autofocus with the lum filter via the focus control button and hitting run again.
After autofocus completed successfully
I ran more images to the end of the night successfully.

I control the sequence to be out-of-order all the time because of end of night, or moon is out our whatever to force the right filter event at the right time. I don’t recall it ever not autofocusing when a filter changed. So I did not change the filter manually, SGP did the filter change per the selected event.

The log file is here:
https://drive.google.com/open?id=1H1fACHNYkSdCKt1B36y62UkSCWyGix9m

I hope this helps the debug process.

Terri

I will try to take a look shortly

www.mainsequencesoftware.com