Autofocus problems with Edge


#1

Hi guys,

Sorry to say I am having no luck at all getting auto focus working with my Edge and Micro Touch. It worked great with the older version of auto focus. Here are the auto focus packs.

Even starting from perfect focus achieved with a Bahtinov mask, I get nonsensical curves. Downloading ends and then it sometimes sits there for a long while before populating the graph. Or sometimes it just doesn’t sample any of hundreds of available stars. I spent a long time on this the last few nights, and have given up for now. Is there a way to go back to an earlier version of SGP without losing my settings?

edit: I just found your link Ken explaining what to expect with this new version. I may have better luck next time as I did not turn on smart focus and did not go far into donut land. Hopefully my auto focus packs will still be helpful to you.

Dean


#2

I looked through almost all of your AF packs and I guess I only see 1 problem… specifically that your step size is too small. Your min HFR seems to vary (probably by altitude) from 2.6 - 3.0. Your max HFR is only about 4.4 (or less) in less than ideal graphs (graphs 2-4)… notice that the graphs are better when you have a higher max HFR (like the one directly below), where I would expect a healthy data set to report HFRs above 6.0 at the outer ends. These are graphs from the AFPacks you sent and they don’t look bad at all… I really think step size would help these runs even more…

Is it possible you still have your step size set to avoid donut starts?

Ideal:

Needs higher step size:


#3

Hi Ken,
Yes that is the biggest step size I could use with the older auto focus routine that would not get me deep into donuts. And while those v curves don’t look too bad, the problem with them is that they were not consistent with each other. I would get a good v curve, and then run it again to confirm, and it would shift me out of focus on the next run, yet show me a good v curve. I would run it again and it would again end me up in yet another position, still with a decent v curve.

I’ll try again tonight with bigger steps and see how it does.

Dean


#4

That’s fair, but sounds like less of a problem with the routine and possibly more related with returning to the actual point of focus… Then again, a large step size may help to correct that also.


#5

Hi Ken,

Here are tonight’s auto focus packs. I am still not getting any kind of good v curve as you will see. I enabled smart focus, and increased step size from my usual 90 to 120 to 140 to get me up to around 6 HFR, but the results were really inconsistent, sometimes putting the first focus point around 6 or 7, sometimes 4.5. After seeing what looked like backlash wings on the included curves, I increased my auto focus backlash setting which did seem to help a bit. I thought the star size was disabled so I didn’t play with it until the last few auto focus runs. Doing so showed me how many of what I assume are hot pixels are being read and confusing things. There are a huge number of samples with a white number (?) that is very similar - around 1.8 to 1.9. When I set a higher star size rejection value, it uses a lot less of these as samples, but still uses enough that it seems to confuse the routine, and I still can’t get a good curve or consistent results. The running time is also really slow, taking up to about 15 minutes to give me a 9 point graph. If you have any suggestions I can try them tonight as it is too bright with the moon for imaging.

edit: I just downloaded 2.5.1.4. All the above were with 2.5.1.3.

Dean


#6

Minimum star size is a new feature and not disabled. You are probably thinking of the older sample size slider. Minimum star size is extremely important. You want to set it by taking a FF shot equal to your AF frame exposure (5s is probably too short). Then click the star icon. Move the min star size slider as high as you can without sacrificing a decent sample size while you are in focus. This should leave you in pretty good shape for AF runs (for this target… hopefully most others too).

Not sure about this… Not really seeing any super slow behavior running your AFPacks on my machines (one of which is a Microsoft Surface Pro Tablet). What kind of machine are you running on? If this is a big problem for people, we can look at image reduction before we perform analysis.


#7

Hi Ken,

Huge improvement with latest version. I am now getting consistent and beautiful v curves, and the speed of an auto focus run is back to normal. Autofocus packs to come soon.


#8

Hi Ken,

Here are the latest auto focus packs. The last ones are the best. I’m imaging an open cluster now and focus is sharp as a tack.

Dean


#9

Ken, this is an excellent protocol to follow and had not occurred to me. I suggest you post this prominently for all of us.


#10

Ken, here is another suggestion for the AF logic: if the routine detects that there may be serious problems with the run when there is a low min star size setting and lots of stars detected, just start over with a larger min star size setting until the count of found stars comes down to a reasonable value? Seems to me there is nothing to lose by increasing the min star size value as long as it is finding a reasonable number of stars.

You could even have a check box for “auto adjust min star size” and just always do this. Not sure what good a value of 2 or 3 is anyway. This may be a good way to make this fully automatic, as you mentioned at the early stage of this development.


www.mainsequencesoftware.com