Bug: "Copy Events from..." not copying events gain


#1

Ccopying events from one target to another one through “Copy Events from…” function does not copy the Event Gain value of copied events (this is not what reported in Bug: Gain and Offset are not copied when event is copied) Example:

has Event Gain = 100, but when copying it to another target you get:

i.e. Event Gain is Not Set as usual for newly created events.

To reproduce the bug:

  1. Open a new sequence.
  2. Setup the first event and set its Event Gain (e.g. to 100)
  3. Add a second blank target to the sequence
  4. In the second target select Copy Events from … and use the first target as the source
  5. The first event of the second target has Event Gain = Not Set

Using SGP 3.0.2.94 under Windows 10. Log file for the above procedure is attached.

Overall a minor bug, perhaps the code that copies events is overlooking this parameter, which was added in the latest releases of SGP. Just to let you know.

Thanks - Alessio

sg_logfile_20180814201604.txt (20.5 KB)


#2

Hi there,

I found this bug too and having a target in a sequence with 12 events for my LRGB sequence plus calibration files and using different gains and offsets for each filter, makes duplicating the target laborious to enter gains and offsets for each event again in the new targets.

I see this post is a few months old, are there plans to address this bug anytime soon?

As Alessio said, its overall a minor bug, but nevertheless frustrating when creating new targets with these many events.

Many thanks
Minos


#3

This seems to have been fixed when updating to version 3.0.3.151, as now copying events from one target to another in the same sequence also includes previously defined gain and offset values from each event setting.

Thank you.

Best
Minos


#4

I’m confounded, this is no longer working when copying events from a previous target in the sequence to a new one…


#5

I am also running version 3.0.3.151 but cannot get the gain setting to copy as part of the copy events from one target to another in the same sequence. I use a range of gains within a target sequence. The description given as the bug report is exactly what I encounter in the current release. With no workaround setting up a sequence for the evening is a real chore.


#6

Any eta on a fix for this?


#7

It is fixed…waiting on our signing cert to get updated to release it.

Thank you,
Jared


#8

Thanks for update…165

I can confirm gain values in individual events copy from and to other events, but not offset values.

Many thanks
Minos


#9

Yes, noticed that this evening…not sure how I missed it :man_facepalming: I’ll release another update here in a day or two.

Thank you
Jared


www.mainsequencesoftware.com