Camera cooling issues

Hi,
please be patient about my “not fluent” english, i do my best.
My issue is that, each time i open a sequence, or change something or, for exemple launch the flat calibration wizard the cooling of my camera is stoped. Even if i say “don’t stop cooler”. So it creates thermal cocks (warming is very quick when no coling on the asi 1600) and after that i have to wait again for the camera to cool down again.
Is there a way to make camera cooling independant of other actions in the log ?
Thank’s for infos about .
Jean-Marc (France).

Yup!.. I’ve found the same thing with my rig (ASI071mcPro)

We need to be clearer about this message. When you say don’t shut off the cooler it means that SGPro will not send messages to warm up or turn the TEC off. We cannot control if ASI turns the cooler off when you disconnect from SGPro. I would contact ASI and ask if they can add an option to control this in the driver settings.

The challenge is to explain how ASI can tell the difference between a temporary disconnect that will be followed by a reconnect, where you don’t want the cooler to be stopped, and a final disconnect where the next action will be to turn the power off where you do want the cooler to be stopped so the camera can warm up in a controlled manner before the power is lost…

This has never been a problem in the past with the cooler being turned off,
where all the equipment remained active. You could reload a new sequence for your next target or up date the Equipment Profile into the sequence, there was never an issue.
What SGPro is doing on either of the above is shutting the camera off, All other equipment stays connected. If the camera is shut off, the cooler shuts down as well. Don’t turn the camera off will solve the problem like it did before.

Hi,
thank’s for responses

@ Ken and Chris:
for me the question is: why does SGP disconnect the camera when only changig from one sequence to another?
i thought that when i connect the camera it will stay connected as long as i don’t ask for disconnect it.
Could have an option for a post event script asking to disconnect, but it’s not really a problem letting connection active waiting for the morning IF the cooler stay active too.

To be clearer:
even when SGP ask me if i want or not to turn off the cooler, if i say yes or not, it turns it off so i was disapointed.
So you say it does’nt stop the cooler but disconnect the camera: is it possible to ask the log “not to disconnect” ?
sorry it’s hard for me to write in english precisely… but is it clear for you?

I was hoping in the last Beta 226 this problem would have been solved.
It is not a big issue to fix, just don’t disconnect the camera when one changes a sequence or adds a profile to a sequence also disconnects the ZWO camera. If the camera is disconnected the cooler will shut off.
Ever since this was added to disconnect,it has caused me problems with icing on the sensor as the camera starts to re-cool down.
Don’t turn the camera off.

2 Likes

@RobinBrown

We must be doing different things. When I open a sequence, connect the camera, then open another sequence that uses the same camera, there is no attempt to disconnect. When do you see this happen?

Idem. Each sequence change disconnect camera. Same when i use flat calibration wizard. Each time thermal stress for the cam… why can t we have a separate control of cam connection and cooler ? Option: a warming and disconect sequence post action. It is really an issue, waisting long time an bad for the camera !

Hi Ken,
I will try an explain each process for a better understanding.
All Sequences have the same profile.
I have the cooler disconnected as is not required for the example.
*It is the Camera disconnection that is the main problem. *
SGPro v3.1.0.226

  • --------------------*
    Start SGPro
    Open a Sequence ‘M8 Lagoon Nebula’ Profile ‘120Esprit’
    Connect Camera (and other devices necessary)
    Open another Sequence ‘NGC7293’ Profile ‘120Esprit’
    On opening the Sequence the Camera will disconnect, all other devices stay connected.
    (If the Camera disconnects the Cooler will Disconnect as well.)
    ---------------------
    The Camera will also disconnect if the same Profile ‘120Esprit’ is reloaded back into the loaded Sequence.
    Also it does not matter if I load from the directory as in the examples or load from the ‘File Menu’ Recent options.
    This does not happen when my Canon DLSR camera is connected, only the ZWO.
    I have also uploaded a test run of the LOG file if it helps.


sg_logfile_20190908101017.txt (19.8 KB)strong text

This is why I can’t see the issue… It seems this bug exists only here. I’ll take a look.

Alright… I found this issue, it is corrected and will be in the next beta.

1 Like

Fantastic
Thank you Ken

Yes !
Fantastic ! Thank’s

Hi Ken,

Downloaded the latest Beta 232 an run some tests.
---------------------------
Start SGPro
Open a Sequence ‘M8 Lagoon Nebula’ Profile ‘120Esprit’
Connect Camera, Cooler working.

Open another Sequence ‘NGC7293’ Profile ‘120Esprit’
Camera stayed connected Cooler still working.

Create a new Sequence while all devices are connected with the same profile ‘120Esprit’
Camera stayed connected, Cooler still working.

*Apply updated ‘120Esprit’ Profile to loaded Sequence ( Sequence not running) *
Camera stayed connected, Cooler still working.

Applied a different profile 'RC8’to the loaded sequence which uses the same ZWO camera
Camera stayed connected, Cooler still working.

*Even thought ‘Cool Down when Camera Connects’ is disabled when I loaded a new profile *
Camera stayed connected, Cooler still working.

All above works perfectly an as one would expect it to be.
So everything is working great.
----------------------------
However, there is one option that was disabled, when all this problem with the cooling started.
an now the cooling is working as expected is it possible to have the following re-instated.
‘Apply profile to Sequence’ ,while the Sequence was running.

This was a handy feature to say the least.
*If I was making some ‘Control Panel’ changes to improve the over performance. *
*I would update these changes to the ‘Equipment Profile Manger’, then add the 'Profile to the *
*running sequence. Then save the Sequence, while everything is still running, which was very convenient. *

Even though this information had been changed in the ‘Control Panel’, and when the sequence was saved
it would retain that information as well, but it would not be in the loaded Sequence’s Profile.

As for a matter of interest, how come the loaded Sequence retains it’s original ‘Profile’ and not load the
new updated one, is there an option that enables or disable this.
-----------------------------

Thanks again for the fast update on the cooler.

I understand the workflow, but due to some complications internal to SGPro we no longer support it. Instead, you should reverse your thinking here and go the other way. Make the necessary changes to the sequence you are on and then save your sequence as a profile. This should yield the same results.

Ken
I must admit I had trouble getting my head around that option ‘Save Sequence as a Profile’.
Now, it makes so much sense. This is the perfect solution and works.
Thank you once again.

www.mainsequencesoftware.com