Camera has stopped cooling


#1

I had SGP set up so that when I connected the camera it began cooling down to -20 degrees immediately. This worked fine until I updated the software recently. I have an Atik 383L. Now I have to connect to the camera and then click the “Cool Down” button. It is a very minor inconvenience. Nevertheless, it would be interesting to find out if I have inadvertently changed something I shouldn’t have.

I have attached two logs from yesterday. Can anyone see what is wrong?

Log 1

Log 2


#2

I honestly don’t know. When you camera connects. We give it 5 seconds to initialize and then call the ASCOM method to start changing CCD temp. At this point your camera fails and indicates that it is not implemented. This is not ideal as we only call this method if the camera reports that it actually has a controllable cooler.

[02/01/2016 15:03:03] [DEBUG] [TEC Thread] ASCOM Camera: Failed to set CCD Temperature! : Property write ASCOM.Atik.Camera SetCCDTemperature is not implemented in this driver. (System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.Runtime.InteropServices.COMException: Property write SetCCDTemperature is not implemented in this driver.

Then… later, you call the same method and the same driver is OK with this method. We cannot tell what is going on in the camera software that would produce this behavior. I would recommend:

  • Asking the the camera driver author about this (using this thread as reference if you like)
  • Creating camera trace logs showing the behavior (somebody will likely want to take a look)

#3

Thank you for taking the time to look at this. I can ask Atik about it and see what, if anything, they say. I am an end-user of PC software and don’t really know much about what goes on under the hood. I am happy to have a go at producing a camera log, but would need some guidance as to how I go about doing this.

One thing I have noticed is that in my camera temperature window in SGP, after a few seconds, I see the word ‘Power’ appearing. Maybe this was there before, but I don’t remember it.

The other odd thing is that the camera and the driver worked as it was supposed to in earlier versions.


#4

Contact ATIK and they should be able to walk you through the process. It sounds like a ASCOM issue though.

You said you updated your software, did you update to ASCOM 6.2 too? New driver from them? Just a new copy of SGP?


#5

Do you know what SGP version it was when it worked? My guess is that it was probably OK until SGP put the temperature management in a separate thread.

Chris


#6

Temperature management has not changed in a long time and has always been in a separate thread. There has never been a version of SGPro that attempted to manage temperature in the sequence thread.


#7

Perhaps @gnomus meant the ATIK software.

There was a change to the ASCOM driver in October 2012 that may have made a difference. If that’s it I’m surprised that it’s taken so long to emerge.

Best to take this to the ATIK forum. I’ll need camera logs, ideally covering the same time as a SGP log.

Chris


#8

I updated to Ascom 6.2 because one of the recent SGP updates said that I needed to have 6.2. There was an update to the Atik software back in November I think.

The weather in the UK has been so poor in recent weeks that there have been limited opportunities for imaging. It is difficult for me to remember with any certainty when I noticed the problem.


#9

Chris

Is it obvious where I will find these camera logs? Apologies for being so computer-illiterate.

Steve


#10

Hi Steve,

Just tonight, noted your post…and I saw the same thing on ATIK 460 EX.
My situation: The camera worked fine before - cooling came on automatically on connecting the camera in SGP. I had a different problem with the camera and sent it off for repair. I connected it a couple of nights ago and noted the same thing you are seeing - had to start the cooler manually after connecting the camera in SGP. That is about all I can say at the moment.
I can try it indoors tomorrow if that is a help - see if anything different on this (house) computer…and even change out SGP to earlier version to see if anything spotted. ( Actually, I’ll do that…and get back here in about 24 hours).
For info…I have updated SGP each build…so am using the latest. I have not changed any Atik driver on the computers here. Everything should be the same on that side…unless there was a firmware update put in while away for repair.
Steve - was there any firmware update done on your camera recently? I don’t even know if there has been one (or indeed if that would affect anything) …just eliminating all possibilities.

Kinch


#11
  • Check the “Trace On” checkbox on the Atik driver setup dialog.
  • The log files are in My Documents\ASCOM\Logs with a name
    starting with ASCOM.Atik.

The change to ASCOM 6.2 makes no difference, it’s the version of the Atik driver that might.

What I’m wondering is if the CCD temperature thread is trying to set the temperature before the set Connected call has finished. Get Connected could return true before set Connected has totally finished.
This seems pretty unlikely, there seems to be a 5 second delay in the temperature thread and I’d expect that to be plenty.

The Atik log should help because it should give an idea of what is going on from the driver’s perspective.

There should be no need to wait for a good night to try this.

I’ve just found an ATIK log from the 20th December that appears to be running properly.
Connected takes about 2 seconds from start to finish and updates what is needed to operate the cooler.
There is a CoolerOn = True command 5 seconds later, then a series of SetCCDTemperature commands with a decreasing set point to do the slow cool that’s specified.
I’m not sure what SGP version this is and I don’t think the logs will be retained that far back.
Could there have been a change in SGP where the camera.CoolerOn = true call isn’t being made now?

Chris


#12

OK - I just downloaded the Atik camera drive to this desktop computer -and tried the camera connected here.

I have SGP 243 25 loaded and although I set up the camera to cool on connection…it did not. (The cooler instruction was entered via the equipment profile manager…and SGP was restarted as one would do in normal circumstances). I could manually start the cooler after that and set it as desired.

I loaded SGP 243 21 and tried the same thing. When SGP connected tothe camera the cooler started automatically as set.
I loaded SGP 243 22 and again the cooler started automatically when the camera was connected.

I don’t have 23 or 24 …but loaded 243 25 and as before…the cooler DID NOT start automatically.

A screen shot here of the control panel that has the numbers filled in automatically from the Equipment Profile Manager but as you can see on the docking module - it had no effect…but looking back at the screen shot (just before I press the send button here)…it does appear to have brought the cooler on …but the set point is way wrong!

No logs…if you want I can do again tomorrow but looks like a problem has crept in between 243 22 and 243 25.

Hope that helps…if you want me to do more tomorrow…let me know.

Brendan Kinch.


#13

Brendan, thanks for checking on that. Here is the problem though… I cannot find any code between 23 and 25 that I can see having any effect on this. Furthermore, Atik seems to be the only ASCOM camera reporting this issue. So, regardless of what used to happen, maybe a more important question is “why does the camera, after a good connection, waiting 5 seconds, report that SetCCDTemperature is not supported, then later report that it is supported an cool with no problem”? Maybe the camera trace logs will help here. I don’t know what to do on the SGPro side. I spent about 2 hours looking through changes, but I can’t devote any more time to an issue that seems to be presented only by one camera type.

Don’t worry about that. The set point is set to the current temp when an error occurs.


#14

I did a small test again this morning using SGP 243 25 at 1001hrs and
with SGP 243 22 at 1023hrs. They would have been closer together but for
the fact that I was fighting with Norton re whether or not these .exe
files should be allowed :slight_smile:

Auto cool down on camera connect went OK with SGP 243 22. As before, in the
latest SGP, the cooler was turned on but the set point was not brought
into the equation…thus one would manually have to set the temp after
the camera connected. Obviously no good for an auto start.

I thought last night that something changed between the two versions of
SGP. Ken saw nothing after two hours of searching and looking at the
logs this morning, it seems to me that SGP requested the cool down but
did not get it in 243 25. (I’ll let the experts say that definitively,
yeah or nay). The logs are attached.

For further info: This is a Win 10 machine and Ascom 6.2 loaded. (Just
remembered, that Ken pointed out in another thread that 243 25 is the
first version of SGP that requires Ascom 6.2. Perhaps this is where the
problem is…Atik and Ascom 6.2) I will copy this to ATIK tech support
also.

The logs are short - just a quick test.

Brendan Kinch.

sg_logfile_20160104102237.txt (19.7 KB)
sg_logfile_20160104095849.txt (21.9 KB)
ASCOM.Atik.1023.110500.txt (13.4 KB)
ASCOM.Atik.1000.596830.txt (21.6 KB)


#15

I could equally well say that SGP is the only application reporting this issue and it only does it on some versions.

But I think it would be better to work together to solve the problem rather than blame each other.

I need more information.

Can everyone please enable logging in the driver, reproduce this and post the driver logs and the SGP logs covering the same tests. Ideally do this for the earlier SGP version that works and the later SGP version that doesn’t. There may be some difference in the calls or the call sequence that triggers some latent problem.

@Ken if there’s anything more you can say about the sequence of calls around this area, probably in the TEC thread it would help. I’m not expecting a solution but it would be nice to have an idea of what changed between versions 22 and 25.

Chris


#16

I’ve managed to get some Atik ASCOM files. I noticed that when I connect to my camera, before the button goes green the camera ‘clicks’ twice (as it always does). A dialogue then appears in the SGP Temperature module that says “Waiting”. After a time this changes to “Power On”. The module also shows that the Cooler is on, but instead of having the normal target temperature of -20 it seems to be showing the ambient temperature.

The time between clicking the button and the “Power On” message is around 6-7 seconds.

When I disconnect the camera SGP asks if I want to turn the cooler off. I include 3 x Atik ASCOM files and the SGP Logfile that goes with them:

Atik 1
Atik 2
Atik 3

SGP Logfile

I hope this helps.


#17

Hi gnomus,

I got the same issue with my Atik One in the SGP log after I upgraded SGP to a release later than 2.4.3.22, now at 2.4.3.25. It looks this issue is not only happening to me after I saw this thread.

Besides, I encounter filter wheel hanging and cooler readout issue after doing a few minutes of bin 2 looping of frame and focus.

Not sure whether it is an Atik driver issue, hardware issue, or an integration matter with SGP.

I reported the issue to Atik with ASCOM logs, and waiting for their investigation.

Let’s keep the fingers crossed.

Regards,
David


#18

I have a different but potentially related issue similar to what’s going on in this thread, and I’d like to do some investigating on this myself. My issue involves the Atik EFW2 filter wheel and I’ve noticed some strange behavior over the last several SGP builds. Is there a log file or trace for the Atik Ascom filter wheel? I couldn’t find a log or way to enable log creation anywhere. I only have the Atik EFW2 drivers and EFW2 ascom driver installed, no camera drivers.


#19

Thanks for the log files. I’ve got some pretty major distractions at the moment so it may be a while before I can look at this in detail.

@joelshort the Atik filter wheel is nothing to do with me so I can’t help with that.

Chris


#20

@Chris No worries, the filter wheel thing probably has nothing to do with
it anyway but I don’t know. I’ll start a new thread if I find out anything
or if the problem I’m experiencing persists. Basically, the FW shows it’s
connected but reports it is constantly “moving”. If I unplug the power and
turn it back on all is well. This is repeatable and started with the last
few SGP builds (but again probably that probably is just a coincidence).


www.mainsequencesoftware.com