Can not move the telescope


#1

Can not move the telescope with the arrows of the Skysafari Pro 6 cursor after the connection …? The goto works very well.


#2

You are not giving us much to go on. The same is true of the Paramount MX, but it is not an SGP issue. Not all telescope drivers support these commands.


#3

Hello and thank you for your answer. I would like to be able to give you more to continue if it could work. I read that it worked with other LX200 classics. I used the Ascom Advanced LX driver The mount works well in GOTO with 2 version of SS PRO (5 and 6). Thanks for your help.
Stef


#4

Stef - I think this 4-way control panel uses the ASCOM MoveAxis methods, rather than SlewToCoordinates methods. Not all ASCOM drivers (or in some cases the mount driver API) supports moveaxis commands.

Many methods have an associated ‘can you do it’ method, which return true if the driver supports the method. It is possible to write a small script that checks the value of the CanMoveAxis to confirm if the driver supports the feature.


#5

Ok thanks for the information. Should I try to find an old ASCOM LX200 classic driver?


#6

I don’t know - it might just help to ask if anyone with the same mount as yours sees the same limitation. What is your mount?


#7

Not all mounts support “Nudge” which is how those buttons are generally implemented. I can’t recall if WiFi Scope logs if that’s supported or not. If you can provide us with a log (located in your documents folder) we can look.

Thanks,
Jared


#8

Hello Jared

Thank you a thousand times for your help.
Yes I will send you the log file.

cordially
Stefwifiscope_log_07-09.txt (24.6 KB)


#9

My mount is a Meade LX200 classic
cordially
Stef


#10

thanks Stef - that was my first ever scope, bought it used from a friend and sold it when I got a hernia. I’ll see if there are any web resources that indicate if it implements the move command.
… well the serial protocol allows for slew commands:

just need to find out if the ASCOM driver uses it …

the Advanced LX ASCOM driver page says it uses a subset…
https://www.ascom-standards.org/Downloads/ScopeDrivers.htm


#11

Thank you for the document. I do not know if the order is accepted. Maybe I do not know how to read it. It seems to me that it is indicated by the letter “P” and that it is only a subset that is accepted. I do not know how to interpret this information.

Stef


#12

It’s interesting…it seems like POTH supports it but it’s throwing an exception when we attempt to use it:

[09/07/2018 16:14:37] [DEBUG] [ListenThread] Probing for MoveAxis...
[09/07/2018 16:14:37] [DEBUG] [ListenThread] Telescope implements MoveAxis
[09/07/2018 16:14:38] [DEBUG] [ListenThread] Listening started on 192.168.1.11:4030
[09/07/2018 16:16:04] [DEBUG] [Unknown] Setting rate Slew
[09/07/2018 16:16:04] [DEBUG] [Unknown] Setting rate Slew
[09/07/2018 16:16:20] [DEBUG] [Unknown] Caught exception in StopDec: Method POTH.Telescope MoveAxis is not implemented in this driver.
[09/07/2018 16:16:24] [DEBUG] [Unknown] Caught exception in StopDec: Method POTH.Telescope MoveAxis is not implemented in this driver.

Not really sure what to make of that. Can you connect directly without POTH?

Thanks,
Jared


#13

Ok I will try, but I have another problem when I execute Wifiscope it remains stuck in the windows 10 taskbar and I can not use it anymore. I think I have a WIN10 bug but I have not found anything yet.

Stef


#14

Ok I solved my problem that came from a W10 bug with WifiScope. I will be able to try an old Ascom lx200 classic version. and I’ll keep you informed.

Stef


www.mainsequencesoftware.com