Cannot bring up Control Panel .405 and now .415

I am sitting here running a sequence and I cannot bring up the Control Panel. Clicking on the icon does nothing.

Second time I’ve had this issue. Any other way to bring it up?

Seems to be the only feature that will not come up/display UI

1 Like

This doesn’t help you directly, but I’m not seeing this issue on any beta over the last 6 months. Can you give some more details of your setup?

buzz, thanks, but I don’t see how my setup would affect the ability of SGP to show the Control Panel. More importantly, never saw this issue in prev versions of 3.0.

Well, since all the beta versions worked correctly in this regard on my machines, it has to be something more complicated at a system level.

I also had this problem occur on two occasions now with one of the recent stable releases (after .400). Only the control panel was affected. Trying to open it via the menus also failed.

It suddenly showed after I swapped back and forth between Chrome remote desktop and Win10 remote desktop.

I’m running three instances of SPG simultaneously on three separate computers (three scopes) and I didn’t bother to take specific notes as to which was acting up, so I’m sorry I can’t provide more detailed info, but the next time it occurs I’ll take more attention and upload the log files.

Perhaps unrelated, but another time (recently) I could not open the image history window, or so I thought. Later when I remoted in via a computer using a much larger display, I found the window way over to the right of the screen. It would have been off-screen on the notebook I was using. Perhaps this is also happening to the control panel window?

I found the same last night while running a sequence, I was unable to open the control panel. However, when not running a sequence, there was no problem and it opened perfectly normally. I put it down to it being sensible to not be able to change settings while actually running a sequence…?

Looking for a common thread here…

Is everyone using some kind of remote desktop here? Anyone else notice different behavior when sequence is running vs not running?

As a note, SGPro will have a bit of “test code” in it to see if the location of the control panel is the culprit here. Using the icon in the main window (keyboard shortcuts dont work here):

  • A left click of the CP icon will toggle visibility as normal
  • Now, when you RIGHT click the CP icon, it will reset the location to the upper left corner and then force it to be visible.

Please let us know if this corrects the issue and we will make a fix that is less cryptic.

1 Like

Yes, I use remote desktop to get to imaging laptop.

I am also having the same issue tonight with the Control Panel not showing up. I am running and access the observatory imaging computer via TeamViewer. Since I am imaging currently, I cannot test the new test code in .423, but will tomorrow.

Want to report back that will doing my imaging run last night and calibration frame run this morning with version that the control panels appears as expected with both right/left clicks on the button.

Ken. When doing the videos, I have noticed they can be a lag of a couple of seconds before the Control Panel pops up. I’m using, as always, Microsoft Remote Desktop. This has only occurred in the last handful of betas.
Thinking I hadn’t pressed it, I clicked again and of course nothing appeared. I’ll investigate further without the Mac video capture on.

OK. Don’t forget about the right click to reset position. If there is a delay, it doesn’t sound like it’s a position thing, but all of this is still unclear.

Have .428 now. It seems to work while running a seq. The only possible difference is that I brought it up after just starting SGP. The previously times, I only tried after starting a sequence.

Between the holidays and the weather I’ve had few nights to test (or revert to 3.0) thus I’ve stayed with 3.1 and most recently tested for this issue again with .432 and the issue did not occur. So since the changes made to help reset/fix the issue - it has not occurred for me again.

Thanks for the report. Fwiw, I have not made any changes here (the only change was to right click the toolbar button in order to reset the position of the control panel).

I did the right click once to test it; but prior to that test it had came up ok. Just checked it again and it’s working.