Canon EOS 6D only takes 1 second exposures


#1

I just purchased a new Canon 6D full spectrum modified by Hap Griffen. Lovely camera. I have it set on Bulb, no mirror lockup. SGP version 2.4.1.4.
SGP correctly uses the ISO I have set, anything from 100 to 25000.
However, no matter what interval I choose, 1 sec to 120 sec, it takes every image with a length of approximately 1 second. The timer bar advances at the correct rate, even though the shutter closed after 1 sec, after which it downloads the image. SGP appears to think everything is going according to plan.
Exposure stats are consistent with a 1 sec exposure.
Is there some other camera setting I am not aware of that needs a change, or is this a bug.
The Canon EOS Utility program does all bulb exposures perfectly, so the camera is working fine.


#2

Make sure you do not have “mirror settle” selected. I had that same problem

Peter


#3

That did the trick. Thanks Peter. Looks like using the “mirror settle” parameter with Canons is a bug.


#4

So just to confirm, you had mirror settle in SGP set to something non zero? Did you have mirror lock enabled or disabled in the camera?

Thanks
Jared


#5

Mirror Lock was disabled in camera. “mirror settle” was set to 1 sec. The actual exposure was about 1 sec. Seems to be a correlation there. When I set it to 0, works perfectly.


#6

There is indeed. If the mirror settle time is non zero the mirror lockup must be enabled on camera. Otherwise you’ll get the exact behavior you describe.

Thanks
Jared


Question about EOS file saving setting

www.mainsequencesoftware.com