Canon Mirror Settle not working


#1

See logs and other files here:

http://glenn.ws/web/images/Mirror%20Settle.zip

Problem: Can’t get “Take One” or sequence to function properly with non zero value for “mirror settle” despite having “mirror lock” enabled in the camera’s menues.

Canon T3i (tried two different cameras)

Windows 7 Enterprise SP1 64 bits

SGP 2.4.0.2756 (Beta 15)

Searched SGP Help file

Searched SGP forum

  1. Load Default Profile
  2. Set “Mirror Lockup” in camera menu’s to “enable”
  3. Connect Camera to Computer
  4. Start SGP
  5. Click on Camera Settings in the Sequencer dialog and set “mirror settle time” to 5 and seconds and press OK
  6. Click the red button to connect the camera
  7. Click “Take one” in “Frame and Focus” Shutter fires without locking up the mirror first for 5 seconds.
  8. Set up sequence of one 10 seconds exposure and run it. Shutter fires without locking up the mirror first for 5 seconds.
  9. Checking the log file:

[2/28/2015 12:45:13 PM] [DEBUG] [Main Thread] * SETTING: settingCanonMirrorSettle = 0

We see that the setting for CanonBirrorSettle is not at 5, despite what it says in the GUI.


#2

I think that is somewhat of a red herring. I’m seeing the same behavior but the actual setting is getting populated correctly and mirror settle is working with my 60D. I’ve verified with it > 0 as well as setting it to 0 turns it off. I’ll look into why this isn’t displaying this (and other settings) correctly.

From the description it sounds like mirror lockup is not enabled in the camera even though I know you said it is. Mirror lockup requires 2 shutter “presses”. The first to raise the mirror and the second to fire the shutter. If mirror lockup is not enabled in the camera the first “press” will open the shutter and the second “press” after the delay will close it which is the behavior you’re seeing.

Thanks,
Jared


#3

OK but if I “take one” or run a sequence of 1 sub, shouldn’t I get three clicks from the camera? Mirror lock enabled or not?

I’m only getting two, 10 seconds apart (10 second exposure, 5 second mirror lock).

Camera menu definitely says mirror lock enable. I’ve tried setting it with buttons and also with EOS utility, no difference in SGP.


#4

Trying RC1, still no luck.

2 clicks per exposure, further more, the exif data is telling me I’m getting 1 second exposures, when I asked for 60 seconds. So it seems like the camera is out of sync as to shutter releases for mirror lock and shutter releases for exposures.

Disabling mirror lock and setting settle time to zero everything is correct. 60 sec exposures in SGP give exif data of 60 seconds (and pictures are better exposed).


#5

RC2, same results.

Asked for 60 second exposures, with mirror settle set to 5 seconds and mirror lock enabled in the camera, got 1 seconds exposures (according to exif data).


#6

RC2 made no attempt to correct this behavior. Still investigating.


#7

My Canon T2i and T3i cameras also experience this behavior with mirror lock up option. Just takes 1 second exposures. Using latest SGP version 2.4.3.25

Dan


#8

Make sure you have “Mirror Lockup” enabled in your camera settings on your camera. SGP does NOT turn this on for you. If this is disabled you’ll get the behavior you describe (assuming your settle time is set at 1 second)

Thanks,
Jared


#10

Yes the option is enabled inside the camera itself. I can hear the mirror flip and then the shutter open but it only stays open for a second instead of the time in SGP. When doing it without SGP for say a 30 second exposure, it stays open the correct amount of time.

It does appear the time entered in ‘mirror settle’ locks up the mirror for the correct amount of time, just when the actual exposure starts SGP only holds the shutter open for one second and SGP keeps counting down like the exposure is still happening.

It also appears the ‘mirror settle’ time doesn’t show up in the status bar and counts the settle time as part of the exposure time.

Thanks

Dan


#11

Dan,
Did some testing and found the issue. Turns out that if mirror lock was on that all your exposures would just be 0 for time. I’ve addressed this and it will come out with the 2.5 beta. For now I’d recommend not using mirror lock in 2.4 (unless you want REALLY short exposures.)

Thanks,
Jared


#12

That’s great, I look forward to the fix.

Is there a way to separate the ‘mirror lock’ time from exposure time. That way for a hypothetical 5 second ML time and exposure time of 300 seconds the total exposure is actually 300 seconds not 295.

Thanks again

Dan


#13

They are currently separate. So in your example the total time would be 305 seconds (5 for mirror lock and 300 for exposure).

Also the status bar does not differentiate between exposure and settle…but they are indeed separate.

Thanks,
Jared


#14

Thanks for clearing that up Jared. Is the fix going to address the same problem with the 6D in this thread?


#15

Didn’t test this with my 6D. I had the 60D connected when I was looking into it. I’ll attach the 6D this evening and see if this also happens to resolve that issue.

Thanks,
Jared


#16

Tried my 2 Canon cameras (550d, 300d) after beta update, and all is working. Just the status bar says downloading when still exposing for the extra mirror lock time. Not a big deal. I cannot confirm it works with a 6d, as I don’t have one yet. Thanks for the fix.

Dan


www.mainsequencesoftware.com