Can't connect with Nikon D4 or D3S cameras


#1

I have tried to connect a Nikon D4 and Nikon D3S camera. Sometimes SGP just crashes when I select Nikon in the camera dropdown menu and try and connect. "SequenceGenerator has stopped working"
Other times I can get a “Cannot Connect to Nikon message” but no crash. Once (in a 100 attempts) it actually connected warning me it can’t go past 30seconds. When I started the sequence with a 10sec exposure it then promptly crashed.

So I have tried two cameras, two laptops two USB cables and haven’t had success. I read that you need a $100 cable to get it to do exposures over 30 seconds but I am not going to bother with that if the cameras won’t actually connect to SGP. I haven’t read anything saying you need that special cable just to connect. Can someone tell me what I am doing wrong? I am using a 2.3 and most recent build 2.4 build of SGP (two laptops)

Is anyone using a D4 or D3S and got connected to SGP? I tried to search the forum but the search field doesn’t seem to work correctly. How do you actually make it search, you type a string in and hit enter it does nothing, you tick the box it does nothing hmmmm.


#2

Anybody???


#3

Hey Brett,

Can you post your log files? It’ll help figure out what’s going on when you’re connecting to your cameras.

Chris


#4

How do I post the log file? It appears to be about 4 times the maximum size that I am allowed to post in this field. I can’t see where I can upload it?


#5

Hi Brett,
You’ll need to use a file sharing service like Dropbox, then post the link here to download the log.


#6

Okay, try this one.

Brett


#7

Try this


#8

Have you removed the SD card from the camera? If not try that. It looks like SGP is taking a long time to connect which is almost always caused by the SD card being present.

You should be receiving an error message stating to remove the SD card as well.

Thanks,
Jared


#9

Yes Jared, I read the cards can cause an issue so I removed them, still no go.


#10

I have tried everything again and still get the crashes. Can connect but when I launch a sequence with a 10sec sub it just crashes SGP.

Anyone out there got a nikon d4 working with SGP?
If so are you using a shoe string adapter.

I have used other basic software for nikon that you can use to control a D4 without the adapter so it can be done.

I am very happy with SGP with my CCD so it would be a pity if I couldn’t use it with the DSLR as well.


#11

Just confirmed the camera is working okay, can control it in Digicam control including doing greater than 30sec exposures with no special cable. So I am thinking it is something in SGP causing the crash.


#12

Can you take a screenshot of the crash error you’re seeing? Looks like connecting to the camera is working just fine. Do you have a lens on the camera or are you using a telescope?

Thanks,
Jared


#13

Hi,

Was there a workaround to this issue? I think I am experiencing a similar issue connecting a Nikon D5200 camera. However, I can connect a Canon Rebel but I’d prefer to connect the Nikon.

Best

Darryn


#14

ok, how do I take a screen shot?


#15

Alt+PrtScr will copy the selected window do your clip board for pasting or you can use something like TinyTake

Thanks,
Jared


#16

Hey some progress to report. I tried removing the lens as well as the memory cards and got it to image without the crash but it will only do a 30 second exposure. I know earlier Nikons like the D3S need the dsusb cable to go past 30seconds but I know the D4 does not because I have been using a freeware program to control it call Digicamcontrol and can control the D4 fine with that including long exposures without the use of the Dsusb cable. This software is not as good as SGP and I use SGP for CCD cameras so would rather just keep using SGP, so it would great if you could enable the D4 in SGP without the 30 second limit because I know the camera can do it.

thanks

Brett


#17

We can add the D4 to the list of cameras that don’t require a DSUSB.

Thanks,
Jared


#18

Thanks Jared, if you could look at this issue and enable it that would be great, look forward to the next release.

Brett


#19

Hi,

I’m still having the issue connecting a Nikon camera I’ve tried a Nikon 5200 and D810. Here is the screenshot (video) and error log. This repos on a Window 7 and Windows 10 box.

Video: http://1drv.ms/1HlqnqD

Log file: http://1drv.ms/1HlqmD6

I’ve tried removing the memory card but no luck. Removing the lens is not an option as I plan to shoot with a lens.

Best

Darryn


#20

Unfortunately I don’t have an answer for either of you at the moment I don’t have any of the cameras you’re using to test, only a D5100 which is working fine on windows 8.1.

I’ll do some digging and see if any libraries have been updated but I’m not sure what to make of this at the moment.

The SD card absolutely needs to be removed from the camera but that shouldn’t cause SGP to crash just that it will likely fail to connect.

Also if you only have a single nikon connected you should just leave “Auto Connect” turned on:

Thanks,
Jared


www.mainsequencesoftware.com