Celestron Electronic Focuser Error - Com port blank

Hello, I am attempting to select my Celestron electronic focuser in SGP and am not able to connect, the Com port shows blank. I can use the Celestron Focuser Utility and have run through the calibration successfully. I read about the Celestron Unified Ascom drivers which include both the telescope and focuser drivers, installed it. Sequence Generator Pro gives the following error when attempting to choose the Celestron focuser:

SGP%20Celestron%20Focuser%20Error

Any idea how to tell SGP the proper Com port to recognize the focuser? Celestron Focuser Utility identifies the focuser on Com 8. I am connecting directly to the focuser using a USB and my laptop. Thank you!

The Unified driver needs a connection through the HC, not directly. For the connection method you describe you need to select the Celestron USB focuser driver.

Thanks for your quick response, Chris. The Celestron USB focuser driver you reference, is that a Celestron driver or an ASCOM driver? It appears the ASCOM is the Unified driver, I have the Celestron Focuser Utility installed which works well by itself. Where might I find the Celestron USB focuser driver and how do I designate it within SGP? Thank you!

It’s both Celestron and ASCOM. I think it’s installed as part of the Celestron focuser driver install. Select the Celestron USB Focuser.

Thanks Chris. I had to uninstall the Unified driver which removed it from the drop down list on Focuser list. I went back to the actual product page on the Celestron site https://www.celestron.com/products/focus-motor, clicked on the Support & Download tab and installed the Focuser Ascom Driver. That put the proper Celestron USB Focuser driver in the list and it loaded properly through SGP.