Celestron motorized auto focuser issues


#1

It seems a few people are having a few issues with setup as I am. Here is my problem:

  1. I installed the Celstron autofocuser on my EDGE HD 8 as per the instructions and several videos. This was quite simple.

  2. Installed the driver on SGPro as well as the Celestron Utility program.

  3. Ran calibration on Celestron Utility with 0-28000 steps identified.

  4. Closed the Utility and opened SGPro. Setting any number of steps in other course or fine, IN or OUT causes the focuser to go to zero. Once there, none of the fine or course buttons work.

  5. Disconnected Celestron mount and focuser and used utility with SGPro’s Frame and Focus. Was able to get focus as ~20000 with a Bahtinov mask. Closed Utility and connected mount (CGEM) and focuser in SGPro. Course and Fine don’t work and Go To doesn’t either. The Position number is the same as for the Celestron Utility and the HFR is about 2.5. Again, the focuser dials down to zero and on the odd occasion will dial back up and reverse on its on. Hitting STOP, shuts down the motor for a second or so and then it continues dialling down to zero, stops and no buttons will then work.

  6. Exited SGPro and rebooted computer and went into SGPro only.
    No luck with getting the to change the fine or course settings. The focuser dials down to zero, then stops and no further buttons can be activated.

Three nights later and still no progress in getting the focuser to work.
Very frustrating and perhaps a call to Celestron tech people is needed.

Any ideas?

Thanks!


#2

Ths behaviour is typical of what will happen if the Celestron Calibration is NOT completed.
I know that you said that you had just ran the caibration but the way the calibration routine works is that if you cancel it at any stage before it has completely finished and the focuser has returned to close to the original position it will not save the new calibration.

The very latest version of the Celestron combined mount and focuser driver has had an update where instead of trying to drive to zero with an uncalibrated focuser it will not move and issue an error message saying why. It should be available on the ASCOM downloads site.

I’ve done this because running the focuser into the hard stops at full speed has the potential to damage things. The calibration runs at reduced power to avoid this.

Hope this helps. If you need more help then a log from the driver is essential.

Chris


#3

Thanks for your suggestions Chris and will give this a try!

Much appreciated - David


#4

Hello Chris,

I used the Celestron USB Focuser driver in SGpro this evening and activated the Celestron motorized focuser Utility within SGPro. I did the calibration which indicated completed.
I then connected Focuser and then the Mount, but the there was an error in connection.

If I use the Celestron Focuser Driver instead, then both the focuser and driver connect, but in SGpro, the current position says Unknown.

I tried several combinations of connecting the mount before the focuser but an error message indicates that the focuser can’t be found.

Attached is the log this evening. Perhaps this might shed some light on the problem?

With thanks, Davidsg_logfile_20190515200029.txt (26.4 KB)


#5

The log shows that you are using the Celestron USB focuser, not the combined telescope and focuser driver. That is provided and supported by celestron, not me. Select the “Celestron Focuser Driver”, not the “Celestron USB Focuser”.

I don’t know why you are getting the errors you mention but it’s possible that the USB focuser has connected through the mount port. and is blocking the telescope from connecting.

And as I said before, if you are using the Celestron Focuser Driver I need logs from the driver.


#6

Thanks Chris,

Where do I find the Celestron Focuser Driver logs?

I have selected Celestron Focuser Driver before, but there’s no access to the Celestron Focuser Ultility program in SGPro. I only can access the Utility (in SGPro) when I select Celestron USB focuser.

I switch to Celestron Focuser and if you can point me to the driver log, then I’ll try again.

Much appreciate all your assistance! David


#7

Open the focuser setup dialog window.
Click on the ‘Help’ button. this will show the help pdf file for the driver
Read the support section, it describes how to enable logging and where the log files are.


#8

Hello Chris,

I switched to Celestron Focuser driver. I had to use the Celestron focuser Utility outside SGPro since clicking on the wrench button in the sequence equipment section only opens up the ASCOM port information. In HELP (Celestron Focus driver), I took a screen capture to obtain the log (attached).

Both the focuserASCOM.Celestron.1853.523170.txt (51.4 KB)
Celestron%20Focuser%20driver%20log%2020190516A and the mount connected, but the focuser position is UNKNOWN.
Clicking on Fine or Course IN or OUT starts the motor, but it won’t stop. After I manually stop it, all buttons fail.

Attached is the SGPro log too.

Thanks for all your assistance,

David


#9

Thank you for the log file. It shows that communication with both the scope and the focuser is working correctly so I can see exactly what is happening. It’s what I suggested in my first reply.

  • The Celestron driver is out of date. You need version 6.1.7059, described as 6.1.70594 on the ASCON downloads. It won’t fix the problem but you won’t get slews to zero.
  • The focuser is not calibrated. You need to calibrate it. I know you said that you have but whatever you are doing isn’t working. A good way to get this is to cancel a calibration before it has completed.

There is nothing more I can do. It won’t work until it has been calibrated.


#10

Thanks for your succinct advice Chris,

I’ll update the driver and see if that works.
When I go through calibration and I did it a few times, the calibration box comes up with “Calibration completed” It doesn’t prompt me for any other instruction, so I just close the box.

Failing your instructions, I think a call to Celestron might be in order.


#11

David,
I ran into the same problem (as did others) when I installed my new Celestron focus motor on my 8" SCT. After looking for help on various forums I found someone who suggested installing the Celestron driver on the Celestron focus motor webpage and calibrating the focus motor with the Hand Controller, NOT the Celestron Focuser Utility. That did the trick. Try it out.
Bob


#12

Thanks For your suggestion Bob!

That would mean buying a new H/C with the focused buttons but if nothing else works , then I’m prepared to try that.

David


#13

Hello Chris,

Under ASCOM Chooser, I reinstalled the Celestron Driver 6.1.7059.13738
dated May 17th. That was the latest version from the ASCOM site.

Again, the calibration through the Celestron Focuser Utility worked but the when connected the mount and focuser in SGPro, the Current position of the focuser says UNKNOWN.

I guess I’ll have to contact Celestron and/or try calibrating through the newer NexStar H/C as Bob had done.

David


#14

Yes, contact Celestron, make sure that they know you are using one of the legacy HCs

I don’t know if the older version 4.21 HC will make a difference, I’ll try this when I get the chance but if it doesn’t wouldn’t expect it to fail in the manner it does…


#15

Thanks for all your help Chris - you’ve been very helpful.
I’ll let you know how it all turns out!

Clear Skies - David


www.mainsequencesoftware.com