Centering occasionally freezes with 2.5.1.17


#1

Since upgrading to 2.5.1.17, centering often freezes during Step 3 and Step 4. Never seen that happen before. Using G11 with ASCOM v 1.0.56.0. Log below when freeze during Step 3 and Step 4 and then I abort after a minute or so. Text at bottom of window says “Image preview opened” when frozen.

STEP 3 FREEZE…

[11/1/2016 8:10:59 PM] [DEBUG] [PHD2 Listener Thread] PHD2 GetPhdStatus - Post-Wait: Stopped
[11/1/2016 8:11:08 PM] [DEBUG] [Main Thread] Slewing to target…
[11/1/2016 8:11:08 PM] [DEBUG] [Telescope Thread] Slew telescope message received…
[11/1/2016 8:11:08 PM] [DEBUG] [Slew Monitor] Waiting for slew to complete…
[11/1/2016 8:11:08 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 1.91055555555556 (01h54m38.00s) Dec: 20.8075 (20°48’27.00")
[11/1/2016 8:11:08 PM] [DEBUG] [Telescope Thread] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting…
[11/1/2016 8:11:08 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to JNOW RA: 1.92637053765131 Dec: 20.8898354598779
[11/1/2016 8:11:23 PM] [DEBUG] [Main Thread] Turning camera cooler on…
[11/1/2016 8:11:24 PM] [DEBUG] [Main Thread] Turning camera cooler on…
[11/1/2016 8:11:25 PM] [DEBUG] [TEC Thread] SGM_CHANGE_COOLER_TEMP message received…
[11/1/2016 8:11:25 PM] [DEBUG] [TEC Thread] TEC Change: Starting…
[11/1/2016 8:11:25 PM] [DEBUG] [TEC Thread] TEC Change: Changing temp from 15.80 to -10.00 in 300 seconds…
[11/1/2016 8:11:39 PM] [DEBUG] [Telescope Thread] Scope reports it is done with synchronous slew, verifying…
[11/1/2016 8:11:39 PM] [DEBUG] [Telescope Thread] Telescope: Slewing has completed
[11/1/2016 8:11:39 PM] [DEBUG] [Telescope Thread] Telescope: Settling for 5 seconds
[11/1/2016 8:11:44 PM] [DEBUG] [Telescope Thread] Telescope: Settling has completed
[11/1/2016 8:11:44 PM] [DEBUG] [Telescope Thread] Slew complete…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Center telescope message received…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Solving with Plate Solver Pinpoint…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Setting filter for auto center…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Setting filter position 1…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Filter position 1 is already set. Skipping…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Performing auto center step 1…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Skipping step 1…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Auto center reference frame solved successfully…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Performing auto center step 2…
[11/1/2016 8:11:49 PM] [DEBUG] [Telescope Thread] Created full file name: C:\Users\Astro\AppData\Local\SequenceGenerator\Temp\plate_solve_image-6.fit
[11/1/2016 8:11:49 PM] [DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE message received…
[11/1/2016 8:11:49 PM] [DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame…
[11/1/2016 8:11:49 PM] [DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame…
[11/1/2016 8:11:49 PM] [DEBUG] [Camera Thread] ASCOM (QSI) Camera: setting gain to LOW…
[11/1/2016 8:11:49 PM] [DEBUG] [Camera Thread] ASCOM (QSI) camera: setting normal speed readout…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] QSI expose and download: 24.7264142s
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] Created full file name: C:\Users\Astro\AppData\Local\SequenceGenerator\Temp\plate_solve_image-6.fit
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Locking bitmap for disk write…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Opening file stream…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Writing FITS headers…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SaveFileBmp16: FITS block fill…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Unlocking bitmap…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Closing file stream
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] Internal Interface: Set Preview…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] Display image preview using asynch task…
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] =========== Save file took 122 ms
[11/1/2016 8:12:14 PM] [DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE complete…
[11/1/2016 8:12:38 PM] [DEBUG] [Main Thread] Centering: User abort…
[11/1/2016 8:12:40 PM] [DEBUG] [Auto Center Closing Thread] Aborting auto center, waiting for centering routine to terminate…
[11/1/2016 8:12:40 PM] [DEBUG] [Telescope Thread] Aborting auto center…
[11/1/2016 8:12:40 PM] [DEBUG] [Telescope Thread] Auto center aborted, closing centering dialog…
[11/1/2016 8:12:40 PM] [DEBUG] [Auto Center Closing Thread] Centering routine has terminated…

STEP 4 FREEZE…

[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Opening fits file…
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Successfully opened fits file…
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Writing fits headers…
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Closing fits file
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Failed to sync the rotator to 267.5801 degrees, not connected!
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Performing auto center step 3 (scope)…
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Auto center slewing scope to match reference…
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 1.61753055555556 (01h37m03.11s) Dec: 15.7818888888889 (15°46’54.80")
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting…
[11/1/2016 8:30:31 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to JNOW RA: 1.6329035268679 Dec: 15.867621094988
[11/1/2016 8:30:40 PM] [DEBUG] [Telescope Thread] Scope reports it is done with synchronous slew, verifying…
[11/1/2016 8:30:40 PM] [DEBUG] [Telescope Thread] Telescope: Slewing has completed
[11/1/2016 8:30:40 PM] [DEBUG] [Telescope Thread] Telescope: Settling for 5 seconds
[11/1/2016 8:30:45 PM] [DEBUG] [Telescope Thread] Telescope: Settling has completed
[11/1/2016 8:30:45 PM] [DEBUG] [Telescope Thread] Auto center slew complete…
[11/1/2016 8:30:45 PM] [DEBUG] [Telescope Thread] Performing auto center step 4…
[11/1/2016 8:30:45 PM] [DEBUG] [Telescope Thread] Created full file name: C:\Users\Astro\AppData\Local\SequenceGenerator\Temp\plate_solve_image-11.fit
[11/1/2016 8:30:45 PM] [DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE message received…
[11/1/2016 8:30:45 PM] [DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame…
[11/1/2016 8:30:45 PM] [DEBUG] [Camera Thread] Collecting FITs headers for plate solve frame…
[11/1/2016 8:30:46 PM] [DEBUG] [Camera Thread] ASCOM (QSI) Camera: setting gain to LOW…
[11/1/2016 8:30:46 PM] [DEBUG] [Camera Thread] ASCOM (QSI) camera: setting normal speed readout…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] QSI expose and download: 23.1363233s
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] Created full file name: C:\Users\Astro\AppData\Local\SequenceGenerator\Temp\plate_solve_image-11.fit
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Locking bitmap for disk write…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Opening file stream…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Writing FITS headers…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SaveFileBmp16: FITS block fill…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Unlocking bitmap…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SaveFileBmp16: Closing file stream
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] Internal Interface: Set Preview…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] Display image preview using asynch task…
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] =========== Save file took 104 ms
[11/1/2016 8:31:09 PM] [DEBUG] [Camera Thread] SGM_CAMERA_PLATE_SOLVER_CAPTURE complete…
[11/1/2016 8:31:18 PM] [DEBUG] [Main Thread] Centering: User abort…
[11/1/2016 8:31:19 PM] [DEBUG] [Auto Center Closing Thread] Aborting auto center, waiting for centering routine to terminate…
[11/1/2016 8:31:19 PM] [DEBUG] [Telescope Thread] Aborting auto center…
[11/1/2016 8:31:19 PM] [DEBUG] [Telescope Thread] Auto center aborted, closing centering dialog…
[11/1/2016 8:31:19 PM] [DEBUG] [Auto Center Closing Thread] Centering routine has terminated…
[11/1/2016 8:31:30 PM] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[11/1/2016 8:31:30 PM] [DEBUG] [MF Update Thread] Performing serialize…


#2

I have the exact same issue with my CEM60 and Trius 814. Any suggestions?


#3

Thanks Tim for confirming, This is definitely a bug that was introduced in one of the latest revisions. I’m hoping one of the developers acknowledges it. It’s been slowing me down considerably over the last few weeks. I need to repeat centering 3-4 times to get around this periodic “freeze” bug.


#4

Sorry, we have acknowledged this one many times… this thread just slipped through. The fix is in the 2.5 beta.


#5

Thanks Ken!


www.mainsequencesoftware.com