Checking auto guider status

I have PHD2 running as I just calibrated it and it is guiding.

I applied the profile with PHD2 and the correct “PHD2 profile” to the existing sequence.

I then told it to start the sequence. It says “checking auto guider status” until it times out and says it can’t start augo guider and connect to equipment aborting…"

So I disconnect all equipment using tools /disconnect all and then reconnect all.

Tried again and same error.

I am required to disconnect all and quit out of PHD2 completely and then start from scratch or it will not find PHD2.

This has been an ongoing issue for me for as long as I can remember.

I guess I don’t understand why SGP can not see or connect to PHD2 when it is already launched and guiding.sg_logfile_20191107202542.txt (14.4 KB) sg_logfile_20191107204207.txt (233.1 KB)

I’ve only seen this error when I’ve inadvertently stared PHD2 as ‘Administrator’, which means that SGPro doesn’t have the correct permissions to ‘talk’ to PHD2, so ensure that all the apps are running under the same user credentials.

I’ll take a look. I thought I might have seen that also, but haven’t tested it in a while.

Ok I will look there first and see if changing one or both applications into or out of Admin mode will resolve. Thank you.


I am unable to reproduce this behavior. In the latest beta, I tested the following scenarios and all of them went through “Checking autoguider status” and successfully resumed:

  • PHD2 not open :white_check_mark:
  • PHD2 open and no gear connected :white_check_mark:
  • PHD2 open gear connected, not guiding :white_check_mark:
  • PHD2 open, guiding :white_check_mark:

Ok, it could be what Dr_Ju_Ju said. I’ll work on it when it is dark.

What I did different though is I edited a SGP equip profile to include PHD2 guiding, then saved it as a new profile, then applied that profile to my current profile and then pressed the begin sequence button.

So it could also be something related to that … uh, trying not to say sequence of events but no way around it. :slight_smile: