Connecting to TheSkyX Pro


#1

I have just had the unenviable task of re-building my Win7 x64 OS and I am in the process of re-installing SGP Pro.
Prior to this I was happily using SGP/TSX with no problems on the same PC.
With TSX powered up and connected (and working independently) I choose ASCOM Driver for TSX in SGP and set the configuration parameters. I then click Connect in SGP and get the error: “TSX is either not installed or not configured for scripting”.
Please advise what I need to do to resolve this.
Jan Rek
Ravenshead, UK


#2

This worked for TheSky6. Open TSX with run as administrator (right mouse click selection). You only need to do this one time.
Fred Klein


#3

Fred
Thank you for your advice. It worked first time!
You are my Super Hero of the day :grin:!!!


#4

In fact, I would probably run SGP, TSX and PhD all at the same level.


#5

It is not necessary to run them at administrator level all the time, just once to register some values.

I am just passing on info I received from another user when I had a similar problem.
Fred Klein


#6

In order for COM to work they all need to be ran at the same level…whether that is elevated to Administrator or not is up to the user. SGP has no need to run as Admin but if you’re sharing ASCOM devices among applications then all applications need to run at the same level or the COM registration will fail. I believe this is what @CCDMan is referring to.

Thanks,
Jared


#7

Could this also be the current dreaded W 10 update issue?


#8

Not from my experience. I have never run any of my components at Administrator level, but the Win 10 security update crashed my Digital Domeworks dome control ASCOM driver, and screwed up my ASCOM driver for Gemini 2 running my Titan mount.
Uninstalling the Win 10 update fixed these issues.


www.mainsequencesoftware.com