Connectivity issues with SBIG camera


#1

Hello, still evaluating SGP, I’m having an unreliable connection to my SBIG STF-8300 camera I’m not able to fix:

  1. Freezes over apparent connection/driver issues
  2. Takes longer than expected to download frame/focus images

Posted some screenshots here:
https://drive.google.com/folderview?id=0B3gMYIXhCiM7R09jUmhKcWhBZG8&usp=sharing

SGP freezes over “SBIG Error while starting exposures: Driver not open”, and “SBIG Tx timeout”…these two errors happen at random while doing frame/focus runs. It does not matter if using “high speed download” or not. It can freeze at the first frame, or after a couple minutes. Error seems more prone to happen if you stop the frame and focus run then try to re-start it, it is failing with the “driver not open” usually at this point.

Wondering if anyone has experienced the same issues…or I’m missing a special camera setting. I’m sure I’m not the first person using SGP with an SBIG camera so I must be doing something wrong.

I’m leaving “download speed” at zero…but have also tried 1s with no changes.

With SGP the focusing frames seem to take about 2 seconds to download (I measured looking at a digital clock)…but with CCDOps download speed is completed “instantly”.

I’ve read the tutorials/help and I believe I followed the steps to configure the camera correctly.

I tested the same camera, over the same cable/port with CCDOps . Here I have no issues after running it over several minutes of a focusing routine, and was able to capture over 800 frames ( in both cases I tried 0.5s exposures, 1x1 bin).

In one test, after re-starting the PC, SGP froze at the first frame/focus frame, I aborted the action, unmanaged the camera from SGP and was able to launch and connect the camera to CCDOps and start a focusing run without touching anything else.

I have the camera updated to the latest firmware, also made sure SBIG drivers are the latest. I even bought two new good quality USB cables from different brands with gold plated connectors, etc to eliminate cable/connector issues.

I only have the SBIG camera connected while troubleshooting this, directly with the USB cable…no hub.

I’m using a fresh windows 10 pro install, my PC is a core i7 with SSD , 8 GB RAM, 64 bits. SGP 2.4.3.21.

Prior to trying SGP I used Maxim DL Ver 5 for several months with same SBIG camera and same computer, I’ve not seen issues either (although I was using a different cable and windows 7 back then). With MaximDL focusing frames also seemed to download much faster.


#2

When I had that camera there was a period of time where I would get the
tx errors. In my case it was definitely caused by a driver problem or
the physical connection to the computer (faulty cable or usb hub). I’m
not saying that is the problem in your case, but I would take a good
hard look at the driver and contact the SBIG driver author with a log
generated by the SBIG driver. He was very helpful in nailing this down
for me. After going through maybe 2-3 test builds of the driver he sent
me I finally found one that worked and gave me no more problems.


#3

It does not fail with CCDops or MaximDL


#4

Yes, I understand that, but the driver may interact differently with
SGP. That doesn’t mean SGP is at fault, or that the driver is at
fault. But in my case the driver author was able to identify the
problem based on the SBIG logs and come up with a solution. If I
remember correctly he also had me change a few settings in the driver
itself that were non-typical.

This is well out of my knowledge at this point and I only offer my own
experience as a data point for you. Sorry I can’t be more help.


#5

Everytime this crops up for me, it’s a bad USB cable or connection to the camera. Recently I had a power cable work itself apart somehow… and I started getting TX errors. All the other times, it has been a USB cable.

Replace your cables and see if it works then. It’s a figment of your imagination that your frames download faster… read speed is what it is and isn’t really dependent on the software you’re using.


#6

I very likely must be doing something wrong…

thanks for the reply


#7

I guess my put would be that the time frame doesn’t really matter. It takes about 2-3 seconds for an image to download from the camera with my STF8300 too. You can improve this by binning and taking shorter exposures.

Otherwise just deal with it, it doesn’t bother me enough to even think about it and I’ve been using SGP for years.


#8

It would not be a problem if I didn’t have the SW crash with driver errors…I’m trying with different COM ports now, maybe it is computer related.

I have also asked SBIG about an odd date mixup I have with the SBIG camera drivers…

Again thanks for the replies


#9

Different COM port, same “driver not open” error message when trying a new frame/focus sequence.


#10

OK, so I opened a thread with SBIG and talked to SBIG tech support, they helped me find where the SGP pro log files are and recommended SG developers take a look at them.

Enclosed are the logs I was able to collect.

Perhaps this will be more efficient if we users are left out of the troubleshooting when incompatibilities between manufacturers arise and talk directly. sg_logfile_20151209152841.txt (74.6 KB)sg_logfile_20151208175952.txt (292.9 KB)sg_logfile_20151208175459.txt (27.6 KB)sg_logfile_20151208175057.txt (19.0 KB)


#11

While I agree with this (and we have talked directly to SBIG in the past… we don’t have an issue doing this), we unfortunately have nothing to stand on here. SBIG is reporting “Read Timeouts” which are usually indicative of hardware issues (not necessarily the camera, but something between the camera and the computer). It seems like the problem may be isolated to your gear. I say this for two reasons primarily:

  • SBIG releases camera emulators. We have fully tested SGPro against the STF-8300 camera emulator without issue.
  • The STF-8300 is a very popular camera. We have lots of folks using SGPro with this camera and no issues.

I’m sorry, we can’t be of more assistance… I just don’t have any compelling evidence that either SGPro or the SBIG driver is acting up…

As @joelshort mentioned, SBIG just releases an a development kit for folks like us to use. I cannot speak for how these applications use or call it. All I know is, as stated above, we have plenty of STF-8300 users running SGPro.


#12

Appreciate the response…do not appreciate being “bounced around” between you and SBIG…it is a pity… I really liked SG, it is a great program.


#13

Well… I’m not sure what you want us to do. Can you clarify? We have a lot of folks using the STF-8300 with no issue, SGPro works fine with the STF-8300 emulator. I’m not even sure what I would say to SBIG. We cannot contact every manufacturer associated with individual issues that come into the forum. If we see a rash of them… that’s a different story. Not to be offensive in any way (emotions are hard to convey over written text)… but this stuff is not cheap… you should use whatever works for you. If that means using other applications than SGPro, that is what you should do.


#14

Have you tried a new USB cable/new USB port/a powered USB hub/new power supply? You’d be surprised how often it’s the ‘stuff’ between the camera and your computer that is causing the issues.

Every time I start see RX errors, it’s because of a cable.


#15

Turns out it was an incorrect setting in the SBIG driver installer application, so it was my fault ( with the help of not very clear instructions).

A kind SG user (Kirk, SBIG forum) looked through what I posted and found my mistake…

Ken you were right it was a problem between the camera and the driver.

In case useful for anyone details are here:
http://www.diffractionlimited.com/forum/index.php?threads/driver-issues-with-sequence-generator-pro.1730/#post-8957


#16

The solution for anyone else who reads this, is to make sure you don’t set the ‘Pro version with RGH’ and instead select the ‘Classic version’. Very interesting!

Chris


www.mainsequencesoftware.com