D7100 crahses sgp


#1

I just tried to connect my d7100 to SGP and it crashes the program.

Am i missing something?
I’m using a pc with the most recent version of windows.

Thanks


#2

The SD card should be removed from the camera. If that doesn’t work please supply a log. More info here:

Thanks,
Jared


#3

Thanks for the info. I tried taking the sd card out and the program still responded the same.
Where can i find the log file to send to you?

Thanks


#4

Info on where to find the logs can be found here:

Thanks,
Jared


#5

here is the log file.
thanks!

please let me know what i need to do to be able to use my d7100 with SGP.


#6

Odd, It seems to think the nikon libraries are corrupt. Attached is the set for the 7100. You can try these and see if they work. Just unzip the contents to C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0010

Also try the “Auto Connect” rather than singling out the camera. And if that fails try the other way :smiley: but I’m not really sure what’s causing this. I know we have other folks using the D7100.

Thanks,
Jared

7100.zip (272.7 KB)


#7

thank for getting back to me! i gave that a try, removed the sd card, camera in manual, and had my coma corrector attached to the camera. i tried both options, auto connect and selecting the camera model, and SGP still shut down.

here are the two log files of both attempts.
thanks!


#8

Is there simple a setting that i missed somewhere either within the camera or the software?
Thanks


#9

I don’t believe so. Unfortunately I don’t have a D7100 to test with. Maybe try 2.6 to see if that is working? We did update the nikon drivers in 3.0. Maybe the new drivers are causing issues?

Thanks,
Jared


#10

Did you ever find a cure for this? I’m having the same issue when attempting to my D7100 (using both auto connect and selecting D7100) with SGP 3.02.82


#11

FYI this continues to happen for me on 2.6.0.25 as well. Also deleted and used the Type0010 files.

I updated the camera firmware to 1.04 just in case that was an issue. It was running just fine on 1.03 with BYN.

I’m a Windows 10 Enterprise user on a brand new machine (got it just for SGP and my focuser). Happy to open up Teamviewer and my D7100 for debugging.


#12

Problem solved!!! Stumbled across a Nikon SDK forum where they had the same errors. Looks I needed the 32 bit 2013 Visual C++ redistribution package - vcredist_x86.exe


#13

Did it work??


#14

I haven’t been able to go out and image yet but the camera is taking single snapshots and downloading the image just fine. I have the camera model manually selected and RAW for now.


#15

FYI, this is the package I needed - https://www.microsoft.com/en-us/download/details.aspx?id=40784

Make sure you choose the x86 install.


www.mainsequencesoftware.com