Delay Centering/Plate Solving until dome has finished slewing


#1

Is there a way to delay the initiation of Centering/Plate Solving (or whatever is next in sequence after slewing the scope) until after the dome has finished slewing (my dome does not start slewing until after mount/scope has reached target). Perhaps it depends on if SGP is slaving the dome instead of external dome software slaving the dome? Right now, it starts the PlateSolving image capture before the dome opening is in alignment with the scope.

I’ve tried searching the forum and support documentation. Although maybe its an option hidden (to me) in plain sight? :=)

I’m using Foster Systems dome control (AstroMC) with an Exploradome.

DaveN


#2

Just put in a long settling delay. I don’t know if there is something specific for that in the ‘other’ panel for domes and my obs computer is off :).


#3

Thanks for the tip!

Dave


#4

I can’t find another way to do that. You’d think SGP would be waiting for a response back from the ASCOM driver for the dome saying ‘yes, I’m in position’. I’m not savvy enough to know that though. I only use ROR.


#5

Yes, if SGP is slaving the dome we will wait until the dome has finished slewing. If SGP is NOT slaving the dome, or doesn’t even have the dome connected which is likely the case, then we have no idea what it’s doing and the “long delay” that Chris mentioned is your only option. Or you may be able to connect both through an external slaving application that exposes your telescope differently to us and use that to handle when things are done (I don’t know if this exists. But there are a couple of 3rd party dome/scope slaving applications out there that export a ASCOM telescope)

Thanks,
Jared


#6

Thanks for all the suggestions.

I did have the Foster Systems/Exploradome selected under Extra-Dropdown/Observatory/“AstroMC Dome/Roof Driver” and connected. At least, it was indicating that it was connected. Perhaps the Foster System is not communicating out its status. I’ll follow up with the Foster Systems guys.

When I do connect to the “AstroMC Dome/Roof Driver” and then select Settings, I get an error box from the Foster System saying “No setting required”, so there seems to be some kind of communication between the two.

Maybe someone with a Foster Systems controlled dome will chip in.

In the meantime, will try the SGP Slaving option and report back.

Dave


#7

Yea, you have to have the dome slaved like Jared said. I use a Foster Systems roof controller. You might try the Foster forum. There is a few people who run the dome controller over there and respond.


#8

Hmmm, I can’t seem to find an option to force autoguiding before the Platesolving images are being taken (so I can set long settling time, to allow time for dome to catch up with scope).

Also, I’m not sure SGP is a supported option for external control of Dome slaving from within AstroMC/Foster Systems (not referenced in documentation). Hopefully someone in the Foster Sys Forums will respond (but its generally a pretty quiet place there).

Dave


#9

I’m having trouble with my controller after updating. You might call Stan. I had better luck that way. He never goes on the forum.


#10

I thought they just had an ascom driver for their dome? Thats all you’d need to do it with SGP.

We assume we have complete control of things. So we don’t check to see if something else is controlling your equipment. If we didn’t tell your dome to move we don’t expect it to be moving. You really only want one thing controlling your hardware anyways. Don’t want too many cooks in the kitchen :wink:

Jared


#11

I had to put a 30 second Mount settling time into the telescope tab to let my slaved Home Dome catch up to the telescope. Otherwise, it would look at the inside of the dome for the first plate solve. SGP does not seem to wait for the dome to complete the slew. I’m using the ASCOM dome driver which works fine otherwise.


#12

Check the logs and see when exactly the dome ASCOM driver is reporting complete to SGP versus when SGP starts imaging.

It’ll tell you if it’s SGP or the dome driver.


#13

SGP does wait provided the dome driver tells us it’s slewing and the dome is Slaved in SGP. If you’re having issues send us some logs and we can investigate.

Thanks,
Jared


#14

Here’s my log. Not sure how useful as I’m not even sure I got configuration (in both SGP and AstroMC) set correctly. For instance, if dome slaving is turned on in SGP, I assume I turn off slaving in AstroMC? And turn off “AstroMC Manages Dome AZ calculations”. But do I need to sync-to-dome somehow using SGP, or is this left to AstroMC? The log does seem to suggest there is communication from AstroMC to SGP (ie. “Telescope: Observatory is reporting slewing” etc.).

I’ll keep trying to get some support from AstroMC/Foster as well.

sg_logfile_20161005175133.zip (135.0 KB)

Dave


#15

Well, thanks Jared. As soon as I get some sky, I’ll set up a test case
and get the logs. It only happens if the slew is long.

Kent


#16

I’ll do that.

Thanks,
Kent


#17

I finally got some clear sky to try a test with the mount settling time set to 2 seconds instead of 30. In order to maximize the dome motion and time spent slewing, I slewed to an object in the north so that the dome went from az 180 to az 45. It worked fine. So my previous issue, which appeared to be fixed by putting in the large mount settling time, was probably due to some other cause. SGP does indeed appear to wait until the dome driver reports slew complete. I should have looked at the logs when I was having the problem, but just tried to work around it instead. Next time, if it occurs, I’ll check the logs.

Thanks,
Kent


www.mainsequencesoftware.com