Direct mount dithering during exposure


#1

I use a 10M1000hps mount unguided. For a year everything worked just fine. For a while now I have a problem which is dither-related.
When I unselect dithering everything is fine, but with dithering enabled on direct mount and at various settle times, what happens now is that the mount does a dither halfway an exposure. Or even during a automatic meridian flip the camera exposes. I see elongated stars or even double stars. The first image of a sequence shows long flare like trails.
I have SGP 3.0.3.169. I did not change any software, but the ASCOM driver from my QHY294C camera. Again when I do not dither the images are sharp.


#2

sg_logfile_20190314205405.zip (137.9 KB)

Here is the log.
Weird things happened @ 21:35


#3

m42_30sec_1rst_frame_dither_on_small
M42_30s_dither_on_small


#4

Hey Arie,

From the logs it looks like you had one sequence finish at 21:32:11
[03/14/19 21:32:11.721][DEBUG] [Sequence Thread] Sequence complete.

and a new sequence start at 21:34:36
[03/14/19 21:34:36.327][DEBUG] [Sequence Thread] Dispatch loop: Received SGM_RUN_SEQUENCE…

And the first frame of the new sequence started here:
[03/14/19 21:34:50.892][DEBUG] [Sequence Thread] ------------- Starting capture frame for event[0] -------------
[03/14/19 21:35:22.818][DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE complete…

Looking through the logs after that point it all looks normal:

  • Start capture sequence
  • Check for auto-focus
  • Dither and wait to settle
  • Capture the image
  • Repeat

Up until the sequence is paused at: 21:36:43
[03/14/19 21:36:43.488][DEBUG] [Sequence Thread] Sequence pause detected…
[03/14/19 21:36:43.488][DEBUG] [Sequence Thread] RunPostEvent requested sequence break…
[03/14/19 21:36:43.488][DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[03/14/19 21:36:43.498][DEBUG] [Sequence Thread] ********* Run post sequence *********

Can you clarify what “weird things” you are seeing at the 21:35 mark?

And what was the original time stamp for the image you attached above? It would be good to map them to specific sections of the log file.


#5

You should find all the original images from the session here in this dropbox folder.
Please let me know if you have access or not.

I did dismiss a few times the “end of sequence” to prevent the dome and mount going to park.
Then I reset the progress to 0, changed the dither dettings and reran the sequence.
At last I reran M42 only a few times. I had “slew to target” at the start of a sequence selected.
Hence the mount realigned witht the target coordinates when starting a sequence.

Arie


#6

Which driver for the mount do you use? I had the same problem once and fixed it by switching from Per’s driver to the newest official 10 Micron driver.


#7

Txs Explode.
But the problem occurs with all three divers I have.
The 10M one, the Baader and Per’s one too.
I tried them all. Behavior is the same.
My suspicion leans towards the QHY camera driver.
That’s the only thing that changed recently.


#8

Hey Arie,

I had a close look at your logs and there really doesn’t appear to be anything strange in what SGP is doing or reporting in the results it get’s from the guider or camera.

As an example, looking at m42_30sec_1x1__frame1-2.fit

It shows some clear movement of the stars in the captured image. Looking at the some of the key events in log file, all looks normal:

[03/14/19 21:29:22.166][DEBUG] [Sequence Thread] DoEventGroupChange: Slewing to target
[03/14/19 21:29:32.506][DEBUG] [Sequence Thread] Telescope: Slewing has completed
[03/14/19 21:29:32.506][DEBUG] [Sequence Thread] Telescope: Settling for 5 seconds
[03/14/19 21:29:37.507][DEBUG] [Sequence Thread] Telescope: Settling has completed
[03/14/19 21:29:38.654][DEBUG] [Sequence Thread] ------------- Starting capture frame for event[0] -------------
[03/14/19 21:29:38.718][DEBUG] [Camera Thread] SGM_FOCUSER_AUTO_FOCUS message received…
[03/14/19 21:29:38.720][DEBUG] [Camera Thread] Checking for auto focus…
[03/14/19 21:29:38.737][DEBUG] [Camera Thread] SGM_FOCUSER_AUTO_FOCUS complete…
[03/14/19 21:29:38.914][DEBUG] [Sequence Thread] Resuming auto guiding (settling)…
[03/14/19 21:29:38.915][DEBUG] [Sequence Thread] Waiting for Auto Guider distance to fall below 0.5
[03/14/19 21:29:38.924][DEBUG] [Sequence Thread] Distance is below 0.5, starting timer…
[03/14/19 21:29:44.064][DEBUG] [Sequence Thread] Distance stayed below 0.5 for 5 seconds, done settling…
[03/14/19 21:29:44.100][DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE message received…
[03/14/19 21:30:14.638][DEBUG] [Camera Thread] SGM_CAMERA_CAPTURE complete…
[03/14/19 21:30:15.291][DEBUG] [Sequence Thread] Created full file name: C:\Users\arie\Desktop\SharpCap Captures\test\Light\m42_30sec_1x1__frame1-2.fit

There was no dither for this image, but you still ended up with star trails.

Are you sure that there isn’t some slop somewhere in the imaging train: focuser, camera attachments, scope/mount attachment etc? And was it windy on the night you were imaging?

To me it really looks like some external factor (not the s/w or drivers) that is causing the issue.


#9

BTW: Later in the logs you reduced the guider settle time down to 1s and then 0s - not sure why you did that, but it is unlikely to help :). If anything, you may want to try increasing your settle times to see if it helps.


#10

Thank you Steve,
I have been looking back in older images taken with another camera.
Images taken with a ASI1600MM-C and a Canon7D do not show this behavior at all.
As from the very first image with the new QHY294 camera the problem arose.
Initial minor and hardly detectable. I had the dither at minimum amount. But when I zoom in on these images I see double spikes (newton) and oval stars. I now start to understand where the came from.
I have my set-up in a dome, so wind is not an issue.
About the settling times. I used to have the after slew and dither settling just at zero.
Increasing these values did not improve things so I set them back to what I was used to.
If it was mechanical slop, the split between the double stars should be random. But they are tiny at 0,1s and consistently bigger at 0,5s. I can’t understand how these dither settings (0,1s or 0,5s) can have this effect.
When I am back from my holliday (skiing) I will mount the ASI camera again and see what happens then.
Ofcourse I will keep you posted.


#11

Will be interesting to see if switching back to the old camera fixes the issue.

And just to clarify your setup:

  • Were you using your SW Esprit100ED or you Lacerta 10" f/4 newt for these images? (You mention your newt above, but not clear if that was for a previous imaging session or not)
  • For guiding, are you using an OAG or separate guidescope?
  • Do you have PHD2 logs for the same capture sessions and are you seeing movement in those logs that corresponds to the trailing seen in the images?

And to re-itterate: The star trails in m42_30sec_1x1__frame1-2.fit happened when there was no dither, so I think we can eliminate dithering as a possible cause.

Enjoy your ski trip! :slight_smile:


#12

I used my 10"f/4 Lacerta Newton on my 10micron1000hps mount.
Therefor I take all my images unguided.


#13

Confused - your logs show that SGP is connecting to and interacting with your guider (e.g. the “Waiting for Auto Guider distance to fall below 0.5” messages),


www.mainsequencesoftware.com