Disable "Analyzing Star Data?"


#1

I’ve read the available threads on Analyzing Star Data, and have tried to minimize its impact on my setup, but it is bogging my computer down like crazy. I’ve disabled Image History, but it’s still killing me. This is an older dual-core laptop, but I haven’t had any issues until I started seeing the Analyzing Star Data message. We are talking freezes of up to 30-45 seconds here.

Can this “feature” be disabled? I don’t care one iota about analyzing anything unless I’m focusing.


#2

What camera are you using?


#3

QHY9 Mono. But the camera hasn’t changed. The only thing that’s changed with this imaging setup in the last year is that the “Analyzing Star Data” message has become noticeable and I’ve kept up with the SGP builds by installing the latest beta as they’ve been available.

I can’t say for sure that there is causation from the Analyzing Star Data, but it’s the only noticeable change. Sure, it’s an old laptop, but it ran fine up until I started noticing that message.


#4

If you have image history disabled then it’s not actually “Analyzing Star Data”. It’s likely downloading the image and if you have a DSLR then it is converting the RAW into something we can display.

If I recall correctly, image download time on a Qhy9 at 1x1 is around 20ish seconds.

Thanks,
Jared


#5

Thanks guys. Something else must have changed in the system then, because it’s definitely hanging at that message. It’s absolutely not the image download. I’ve used the same computer and camera, so that variable wouldn’t have changed. It’s odd, because the image itself pops up in the tiny window on the frame and focus tab, but pauses during the “Analyzing Star Data” part for quite sometime before the image is visible on the main screen. Also, there have been anomalies where the ASD message remains at the bottom with a scrolling green bar and no camera functions available when I’m not even opening an image. I’ll get some screen grabs.


#6

Hmm… looking at the code for this something seems broken. Like broken in a way that will always analyze the image regardless of image history settings. I’m trying to track that particular change down and figure out why it was made. In the meantime, for the next beta, I will return it to a state where image analysis is only performed for auto focus frames and light frames when image history is active (and see if something breaks… can’t think of anything this would affect).


#7

Ken,

Thanks for validating that although I’m likely crazy, this isn’t one of the reasons. It doesn’t mention Analyzing Star Data in the log, but it clearly shows it onscreen. The dialog below shows “downloading” for about 16 seconds, which is normal, then shows “analyzing star data” for around 48 seconds. I had my stopwatch ready, so the actual times are accurate. The image popped up onscreen as soon as it was done downloading, but nothing proceeded for the entire time it pretended to analyze the star data. Here’s a snip from the log and my second image taken tonight.

[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] Clearing timed monitoring events…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] Created full file name (file does not exist): C:\Users\Austin\Desktop\Pelican\Light\pelican_600sec_1x1_Oiii_frame2.fit
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Start…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Checking image data…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Create normal preview bitmap…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Locking preview bits…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Validating file name…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Starting byte traversal…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Unlocking preview bits…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Saving preview bitmap to disk…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileBmp16: Locking bitmap for disk write…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileBmp16: Opening file stream…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileBmp16: Writing FITS headers…
[10/19/2016 8:03:30 PM] [DEBUG] [Sequence Thread] SaveFileBmp16: Traversing and persisting bitmap data…
[10/19/2016 8:03:31 PM] [DEBUG] [Sequence Thread] SaveFileBmp16: FITS block fill…
[10/19/2016 8:03:31 PM] [DEBUG] [Sequence Thread] SaveFileBmp16: Unlocking bitmap…
[10/19/2016 8:03:31 PM] [DEBUG] [Sequence Thread] SaveFileBmp16: Closing file stream
[10/19/2016 8:03:31 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Displaying image preview in UI…
[10/19/2016 8:03:31 PM] [DEBUG] [Sequence Thread] Internal Interface: Set Preview…
[10/19/2016 8:03:31 PM] [DEBUG] [Sequence Thread] Display image preview using asynch task…
[10/19/2016 8:04:24 PM] [DEBUG] [Sequence Thread] SaveFileAscom: Done
[10/19/2016 8:04:24 PM] [DEBUG] [Sequence Thread] =========== Save file took 53996 ms
[10/19/2016 8:04:24 PM] [DEBUG] [Sequence Thread] Resuming auto guiding (settling)…

So the Analyzing Star Data pops up, but there is no green bar moving across, it’s empty for the entire time (45-48 seconds consistently.)

I know you are way ahead of me in analyzing this, just sharing what I have. You guys rock!


#8

I’M having the same trouble. I’m using a 3.2 quad core laptop and SBIG 8300. My downloads are now taking 20-40 sec and laptop will even freeze at times during autofocus. Any fix


#9

In the 2.5.2.5 beta, but just to turn it off, not to make is faster.


#10

Hey guys, we are back to normal operation with the 2.5.2.5 beta. Thanks for the quick response!


www.mainsequencesoftware.com