Dome slewing by 45deg during 'Center Here' routine


#1

Hi Guys,

I have been working with another SGP user (GordonW) setting up his system, the equipment is a Mesu Mount with Sitech sofware v9.1 and 3M Scopedome using the latest Scopedome drivers.

We have some issues with dome wandering on step 3 of ‘Centre Here’, this is using SGP version v2.5.0.15, though this also happened on .14. I cannot be 100% sure this was not happening on the 2.4 stable release as were early days in setup when you started to release the 2.5 versions, has dome code changed at all?

During a ‘Centre here’ the dome moves by 45deg during the correction slew and slews back after the validation frame is taken and then tries to plate solve on an image of the inside of the dome. Just doing slew to targets results in correct dome operation, the issue only happens during ‘Centre Here’

Testing time has been limited but this issue is totally repeatable, I did not get the ASCOM logs for this run, can get them next time if would help.

Below are the steps, timings from the log along with my interpretation of what was happening.

Logfile: https://www.dropbox.com/s/ydolaqhi0za60ue/sg_logfile_20160227215510.txt?dl=0

Sequence of events

10:19:21 PM - Slew to RA:05:24:42 DEC:33:45:06

10:21:44 PM - Start centre here

	Steps 1 and 2 of centre routine complete ok

10:22:03 PM - Step 3
Correction slew to RA:05:24:42 DEC:33:45:06
Dome requested to move from 257deg to 300deg

	Step 4	
		Camera takes image if inside of te dome and attempts to plate solve
		Dome moves back to 257
		Manually abort centre here

We have checked that nothing else is connected to the dome software and all looks ok, as said above we are not sure if this happened with the last stable but thought we would ask if this looks like an issue with SGP before we start going backwards on software versions.

Thanks for your time

Trevor


#2

Hi Trevor,

Can I ask (if you are aware) - if this slew happens the instant the platsolve completes. (I may have a similar problem - just never got around to try solve it - I take 20second PS frames now (with PS2) so that the dome opening will be back & available (enough) for the next PS frame to be OK for a solve. My dome move could be anything from a few degrees to maybe 30 or 40 degrees…never really checked that part.
Obviously I am working around it - but can follow up more here if it is not just my set-up that is in error.
(Ken/Jared - this is a different dome excursion than that previously sorted by the updated Tak Temma driver).


#3

Hi Kinch,

This happens when the correction slew is issued, all happening within the same second - the extract of the log below is step 3, the correction slew is issued and it checks if dome needs to move and calculates the new position.

This is the section for step 3 extracted from the full log posted above.

[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Performing auto center step 3 (scope)…
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Auto center slewing scope to match reference…
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 5.41166666666667 (05:24:42) Dec: 33.7516666666667 (33° 45’ 06")
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting…
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Telescope: Slewing to JNOW RA: 5.42952663031117 Dec: 33.7639308669265
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Telescope: Calling Observatory Slave Slew
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Observatory: Checking to see if position needs updating
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Observatory: Telescope position not valid or sent, calculating new Alt/Az
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Observatory: Calculating new position using:
Azimuth: 257.196244737367
Altitude: 50.25026871652
Hour Angle: 287.244723482547
Pier Side: East
[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Observatory: Adjustment needed, slewing to Azimuth: 300.121822838202

In the about this line may indicate something amiss but Ken/Jared would need to confirm if this is an issue as not sure what this means.

[2/27/2016 10:22:03 PM] [DEBUG] [Telescope Thread] Observatory: Telescope position not valid or sent, calculating new Alt/Az

Trevor


Dome slewing not as expected - another angle (pun intended)!
#4

I’ll have to make a note of times tonight and do a test. Just tried looking through last night’s log - but it is humongous and I have no specific time noted to zoom in on…could not find what I was looking for.

My problem briefly: dome slews off momentarily as soon as a plate solve is done. (generally I see this behavior when going to a target - but guess I could get the exact same thing if it was ‘center here’…because It comes after a plate-solve). We have different equipment, which is why I am interested here i.e. it is perhaps not just something amiss with my set up that is causing my problem. I don’t remember seeing

in my logs - so it may in fact be a different mater. (The only thing I know that looks the same, is the need for Jnow/J2000 conversion). I’ll wait see if Ken/Jared have any comeback for you…and in the meantime I will see if I can get some logs together.


#6

@trevorn Just to be certain the slew to 300 degrees is the erroneous one correct?

If that’s the case it looks like something funny is happening with the hour angle calculation. There are 2 different types of dome slews:

  1. We read all info from the scope and calculate the dome Azimuth. This is the normal “slave” polling that happens and is all over the log.
  2. A slew is invoked. In this case we can’t get all the info from the scope (as the scope isn’t at the slew position). So we calculate it out.

It looks like something is getting wonky with the HA calculation. It typically works in most but not all cases. I’ll do some looking into this.

Thanks,
Jared


#7

So I think the first thing to check is to make sure the Lat/Long and LST that your scope is reporting is correct. We get all the values from there. These are only used when a slew is initiated, otherwise we use the HA as reported by your scope.

Jared


#8

Hi Jared,

Can confirm the 300 degrees slew is the erroneous one.

Will check LST this evening as need to power up and connect to the mount for that, pretty sure that is correct - if wrong would SGP also calculate the incorrect position for a slew ? This behavior is only apparent during step 3 of a center here routine.

Thanks


#9

What about during target changes? Target changes and “Step 3” use the exact same process to figure out where to rotate the dome.

I’ve made a minor adjustment that changes the provider of the HA (available in 2.5.0.17, which is not yet available). This could have been a casualty of some JNow/J2000 changes but I can’t see that making things THIS far off.

Thanks,
Jared


#10

Hi Jared,
Just to confirm that the lat/long and LST settings are all fine on the scope. I’ve never tried on multiple targets so can’t comment there.
Thanks,

Gordon


#11

Ok, let’s see how the 2.5.0.17 beta fares once it’s out. It’s likely that the change should address this issue.

Thanks,
Jared


#12

Sounds great- we got some more logs and detail from a test this morning tho just a repeat really- if you need them?

Gordon


#13

Updated to .17. Did 3 target slews followed by 3 x center here and not even a hint of dome wander- the world once again is a happy place!
Thanks,

Gordon


www.mainsequencesoftware.com