Downloading errors/aborts

Hi, I’m pretty new to this and am having a problem during the download process. Something hangs. I’ve attached some log files and wanted to get some guidance on next steps. I’m thinking of reinstalling Windows/Parallels on my MacBook Pro and before I do, I wanted some insights as to where start looking.

Nikon D810 DSLR
Windows 10 Parallels 14 for Mac
MacBook Pro Mojave 10.14.
PHD-2 2.6.6
ASCOM 6.4.1

The basic problem is I’ll take about 8 frames, then SGP is displaying downloading until some timer hits and the sequence aborts. Or I’ll abort the sequence, and have to re-start my windows instance and start all over. I switched from RAW+FIT to FIT only and that helped a bit, I could get to 14 frames.

I’ve read through the forums and I have replaced the cable from the DSLR to USB-C - NIGHT AND DAY DIFFERENCE!! Also, set the display to non Retina and turned off Windows power management of the USB ports.

Since then I switched to a Hyperstar and put all the cables in one split-tube. Last night (see attached logs around 20:18pm) many aborts… This morning I pulled the cables apart assuming some sort of interference. I shot 50 bias frames zero second easily, then had the issue when I went to 35 second darks. Does not make sense to see. Can you point me in the right direction with the logs? once I had an abort (either timer or my noticing the issue) I would shut down SGP and PHD2 abruptly, restart windows and power off/on the Nikon. (158.3 KB)


I am not great with Nikons, but whatever this is:

Caught exception in USB Bulb capture: [kNkMAIDResult_NotSupported] (kNkMAIDCommand_CapStart, 17, kNkMAIDDataType_Null, 0)

Is what is happening. I need to dig to find what that means.

Interesting. I came across the same line and have no idea what it means. I have removed the SD/CCF card from the camera and it’s running on AC. I’ve disconnected and reconnected the camera with SGP, and maybe I’ll get another frame or 2. If I just turn off the camera then there are hard errors. What’s happening when the exposure is 0 vs 60 seconds? Is there communication from the camera to a file on the laptop? Like constant communication on the USB line?

30 seconds is the magic barrier. Less than 30 sec, we use the native shutter speed and more than 30 seconds we use bulb exposures.

Yes. We pull directly from the camera and write directly to disk. Unpowered hubs (or sometimes hub in general), bad USB cable, low power AC adapters, etc can all cause problems that seem inconsistent in nature (like these).

So… Here are some recommendations if you are re-installing stuff:

Install Windows 10 on the MBP bootcamp partition. Then, install Parallels and tell it to use the bootcamp partition. This way, you can run from MacOS when everything is stable. Until then, you can do testing in native Windows without having to worry about resource contention (with the camera getting a dedicated USB port… no hubs for testing).

Got it, I saw the temp folder with a file sitting in it after the sequence aborted. So, I decided to run a few tests (and willing to be your Nikon tester :slight_smile:

<30 second exposure - no issues - tested 50 then 25 without a problem

30 seconds, times out after 4 frames (can’t load the screen shot)
When I start fresh with a sequence > 30 seconds, I got 10 frames.

I could even test this with my old cable (1 year old Tether Tool - good quality) if you would like.

I don’t believe the stability issues I’m having are coming from anything but the way the camera is accessed. Using Nikon’s native timer all is good, going into bulb mode is creating a timeout. Sooner when previous sequences are < 30 seconds.

Please let me know if I should download the beta version and test… Would this be considered for a future release? Also, the 320 ISO, exposure time and exposure count all change after a save and start up without a camera.

Archive (68.3 KB)

forgot this - no hubs - one cable, no connectors from camera to USB-C on MacBook Pro,

I’ll try and duplicate this with my Nikon, however it requires a bulb cable to go over 30 seconds so it may have issues duplicating in the same manner as the D810A.


Great! I saw a similar issue/error with Backyard Nikon. I had that originally then upgraded to SGP.

I’m going to take the advice and install bootcamp. But, I don’t understand one thing (lol); if I install bootcamp and rely on that windows partition for SGP, PHD and so on… Do I need to keep Parallels? The only reason I put Parallels on was to run the astronomy gadgets. Thoughts?

Only if you have need to run sequences whilst in MacOS. If you don’t need this, it’s better to run on the native partition.

Nope; windows will run the all the sequences! I really have no other need for Parallels; I think that simplifies things a bit…

BTW, Is there a workaround for the custom ISO? Like an .ini or config? Or I just need to live with it doing all the updates before each run for now?

I will add it to the “offline” ISO list… it will stop it from disappearing. Maybe a better solution later… Let me know if their are other ISOs you use

Nevermind… The permanent fix for this was easy enough.

wow! So is the fix in a future release or the beta? Sorry, first time at this. How do I get access to the fix?

The permanent fix for this will most likely be in the next Beta that follows the current 353. Just download and install the next Beta.

ok, getting the hang of this. Thanks for the very fast responses! much appreciated.

Just to be clear, I am referring to the ISO bug and not the other intermittent issue your have reported.

Yep! I got that… The ISO and keeping the saved setting even when the camera is not connected will rellly help out a lot!!

On the time out issue - I think there is a solution from the BYN folks - Eliminating MirrorUp and 2sec exposure delay worked!! 50 frames at 1sec, 50 frames at 35sec. At least that’s the testing that would normally fail at about 8-16 frames into the second sequence of 35 second frames. The next test will be in the field with PHD2 guiding and all, but I think this issue is resolved. I also went back to my original cable with the same testing - it was successfully as well. Thanks for all your help with this!!!

Man… we have got to get a Nikon FAQ together… in most cases, I think folks would have already given up (I’m glad you didn’t, but it’s like a complex puzzle).

The beta available now 358 has the new ISO code in it.

There are many things going on and it’s easy to go down the rat hole. I’d be more than happy to help even though I only tested one D810 - so i put together some items that may help others - feel free to put it into a FAQ.

I started with replacing the cable; and that worked. Why, cause I was lazy and just shot 50 or so 1 second frames. I think the best advice to give is the following and it can all be done during the day:

  1. Reproduce the issue - Fire off 50 shots below and above the camera’s native max timer. In my case that was 30 seconds. You’ll never solve an intermittent issue and change ONLY ONE thing at a time.

  2. Strip out all camera features - MirrorUp, Exposure Delay, Noise Reduction and remove all memory cards… Worst case reset the Camera to factory defaults (which I have not done) and update camera firmware to the latest.

  3. The cable - Start with the one in the box. Keep it separate from the rest until it’s working. Buy a new one (lots of info out there on this - I bough mine from Tether Pro - Call them and speak to someone knowledgeable.

  4. Windows - I do plan on testing this on a native windows machine within a week or so and will report back, my hunch is with my bad features set on the camera, it will fail. There are way too many configurations out there, however, I got it to work successfully with BootCamp and it probably would have worked with Parallels (I aint going back, the bootcamp appears much cleaner.) I installed bootcamp and loaded Windows 10, did all the updates then turned off updates for 30 days. I disabled all USB power management and set all sleep mode items to Never. Turned off all notifications. Loaded ASCOM, SGP and started the testing.