E-mail Notifications not working in 2.5.0.23?


#1

First of all, thank you for the amazing support put into updating SGP. I’ve been using all Beta versions of 2.5 and half-way through, I paid for the Notifications plugin. Last night I configured it to use my old Hotmail account, e-mailing itself, and it worked perfectly. I was getting status updates via e-mail after every 5 minute exposure.

Just today I upgraded from 2.5.0.20 Beta to the official 2.5.0.23 release. The configuration held and I’m running my sequence now, but there are no notification e-mails. I have checked the settings and they’re perfectly ok. I clicked “Test” and it reports success and an e-mail is received, but no actual notification e-mails are sent during the sequence.

Is this a bug, perhaps? Or something I’ve missed? Thank you! :smile:


#2

It’s always possible, but notifications and email have been verified as working in the 2.5 release. Logs might be helpful here.


#4

I found the log file for today’s session. It looks as if it’s recording events as if to e-mail them but it doesn’t physically achieve e-mailing the notifications. The “Test” works however so the settings are fine. This is a Dropbox link to the log file:

https://dl.dropboxusercontent.com/u/92999201/sg_logfile_20160329212009.txt


#5

Are you using the “send notifications individually” option?


#6

No I’m not, I never have.


#7

I don’t have any reasonable explanation. When I run the release, emails are sent with no issue. The only thing I can come up with is that it’s a hotmail issue. Try opening a free gmail account to use as your “sender” account. You can continue to send notifications to your hotmail account.


#8

No worries, thank you. I will try again tonight and see. Maybe it was a one-off.

Regarding using Gmail, I actually use Gmail all the time and hadn’t used Hotmail in over 7 years. I tried setting up my Gmail account using “smtp.gmail.com” as the server and using ports 587 and 465, with and without SSL. Nothing worked - the “Test” always failed. At one point it seemed to work but Gmail itself blocked the attempt.


#9

I don’t use gmail myself but I’ve found it to be one of the most difficult to use to send anything to other than simple email. Attachments, even if zipped, seem to cause a message to be discarded with no notice.

Chris


#10

Just to say that tonight it seems to work. Probably just a fluke last night. No problems tonight as far as I can tell!

If anyone has been able to use Gmail for this feature, please advise if you did anything in your Gmail account settings, and what settings you use in SGP. I’ve so far not got any Gmail account of mine to work. Hotmail is working fine on port 25 however.


#11

We test only with Gmail and it works fine. Some people find they need to go here and allow “less secure applications” access to their account. SGPro definitely falls in this category:

https://www.google.com/settings/security/lesssecureapps

I have added this to the help file.


www.mainsequencesoftware.com