Erroneous meridian flip with 10Micron mount


#1

If I slew to a target well past the meridian (like 3 hours past) SGP checks before starting to capture images with the mount and thinks it needs to do a flip (which it doesn’t). Naturally the flip then fails. It seems to be a side-of-pier issue?

SGP meridian flip settings are:
Minutes past meridian flip -5
Wait for meridian
Auto center after meridian

The 10Micron settings are:
Flip slew tol 03 degrees
Flip guide tol 05 degrees
Meridian side: BOTH


#2

If you want to be able to slew to a target 3 hours past meridian then shouldn’t that “Minutes past meridian” setting be set to something like 180 or 240 and not 5? (i.e. X hours past meridian * 60)

BTW: I’ve no idea what the correct 10Micron settings should be or whether it is advisable to go 3+ hours past the meridian with your set-up…


#3

My understanding that -5 minutes past the meridian is the setting for when the meridian flip should occur, i.e. the flip occurs 5 minutes before reaching the meridian. It has no bearing on when a slew can occur.


#4

Peter,

this is exactly right.

For that to work, the ASCOM driver for your mount must be able to set the SideOfPier property. This is an optional function; some drivers implement it, others do not.

This part of your post, I do not understand. Why do you think SGP thinks it needs to do a flip?

Kind regards,
Horia


#5

Hi Horia, it thinks it needs to do a flip because it attempts to do one!


#6

I’ve just done a test with an older version of the 10Micron driver and the problem seems to be fixed.


#7

Hi Peter,

There is no entry in the log file you uploaded showing the “urge” to do a meridian flip. Actually, in the setup of the sequence there is a line saying:

Was that the wrong log file?

Kind regards,
Horia


#8

I also used the ‘Minutes past meridian flip -5’ setting - which worked. This was with the ASCOM driver from Per Frejvall.

But as the official 10Micron driver is pretty much caught up, I wanted to switch to it.

Now, when I connect my mount I get a notification:

Your mount does not allow pier flips prior to crossing the
meridian and your "Degrees Past Meridian to Flip value has
automatically been set to 0.

And with this setting meridian flips fail.

Any idea?


#9

Here’s the settings i use with the 10Micron Driver, hope it helps :slight_smile:
Screenshot_6 Screenshot_5 Screenshot_3


#10

SGPro has detected that your mount does not support setting a property called “sideOfPier” we use to execute meridian flips. Because of this, we must wait until your mount crosses the meridian and then flip… meaning, this driver does not support early flips.


#11

Hi mstriebeck,

a similar question has just been asked on the 10Micron forum: https://www.10micron.eu/forum/viewtopic.php?f=2&t=1037
It appears that negative values for minutes past meridian are not possible.

About being able to meridian flip with SGP requires the latest 10Micron ASCOM driver to handle SideOfPier, see https://www.10micron.eu/forum/viewtopic.php?f=2&t=1003&p=8098&hilit=firmware+flip#p8098
Download of the driver here: https://www.10micron.eu/forum/viewtopic.php?f=3&t=1009

I do meridian flips using my GM3000 without problems using the latest ASCOM driver and firmware version 2.15.20.

Nicolàs


www.mainsequencesoftware.com