"Error connecting to QHYCCD FilterWheel!"

“Error connecting to QHYCCD FilterWheel!”
I get the above message when trying to connect my QHY CFW3 filter wheel in SGP. Nothing changed in my setup since the last time I used it. I get this error message using two different computers, so the issue either has to be the filter wheel itself, SGP, or a cable.

Could someone take a quick look at this LOG and tell me if you see anything obvious?


I am not familiar with that CFW, but it is insisting the camera be connected first. I will fix the part of that where we cleverly hid that from the error message that pops up.

Well, the camera is connected first and I can take images with it. Like I said nothing changed in my setup. I’ll have to do a few more tests and try to figure out where the problem is, but I wanted to eliminate SGP as the problem. This is the first time I’ve used and this issue came up. I rolled back to and still get the same problem, so it’s likely not an SGP thing.

Right… I missed that. The logs show that the exception originates from the ASCOM driver itself and SGPro is just relaying. How does the CFW communicate with the camera? Is there a dedicated cable for that?

The filter wheel is directly connected to the QHY183 camera via a serial cable. I’ve now brought the camera and FW inside. Same thing happens on my desktop computer. I’ve tried a spare serial cable, and I’ve also tried it with my QHY163 camera with same results. I’m not sure what else it could be other than the filter wheel itself. The strange thing is that the filter wheel powers up and spins and I can access the ASCOM driver settings for it, but when I try to import the filters in SGP, or actually connect it I get this error.

Next step will be to install QHY’s capture program and see if that makes any difference.

best… hobby… ever

1 Like

The only issue i’ve had with my 163m is that the filter wheel has to initialize after the camera is connected before it will succesfully connect to the filter wheel driver.

I don’t get what happened here, but I have found a combination that gets the FW to work. I actually have two QHY cameras and two QHY CFW3. The ASCOM driver presents:
Filter Wheel1
Filter Wheel2

The SGP sequence that I have always used presents Camera1 and Filter Wheel1. But that combination does not work. If I use Camera2 and Filter Wheel1 the filter wheel works. Weird.