Error in ReflectDataModel - Beta 3.1.0.198

I used the Beta version 3.1.0.198 successfully for a few days about a week ago. It is clear out there again finally tonight and when I double clicked my sequence to open the app and the sequence file it threw the error: “Error in ReflectDataModel: value cannot be null”. It was on the start up splash screen in the ‘Creating default sequence…’ step when this happened. I tried opening the app through the main icon rather than a sequence file, but the same thing happened. I have resorted to reinstalling 3.1.0.153 and the app is working properly again. Here is the log file:

Thanks,
Gav.

Can you attach the sequence?

Thanks,
Jared

Hi Jared,

The sequence is here: https://www.dropbox.com/s/9qou1wnb4kc1qzo/Edge8-Mesu.sgf?dl=0. The error occurred even when trying to open SGP on its own and not opening this particular sequence.

As an aside - there is a .bak file of this sequence, how do I open that to get the sequence back, please?

Thanks,

Gav.

just rename the .bak to a .sgf. If you open it with the beta it will convert it back to a .bak.

Thanks,
Jared

Sadly I wasn’t able to duplicate it with that .sgf. If you happen to have the .bak, I can take a look at that too.

Thank you,
Jared

Hi Jared,

Thank you for looking into this. Weird that you can’t replicate the issue. I have just reinstalled 3.1.0.198 and it opened successfully to begin with. I could even open the .bak file after changing its extension as you suggested - thank you. However, very quickly it started throwing the same error as detailed above. Possibly after doing a save - I’m not entirely sure. Anyway, I’ve installed 3.1.0.170 and all works perfectly again, so I definitely have an issue with 3.1.0.198…

I have put the .bak file and all the log files from this morning here:

Thanks,

Gav.

My english isn’t perfect, but i have the same problem. And I cannot install older version.
My beta version woked correctly many times …

Version 3.0.3.151 work , but the Version 3.0.3.169 do not launch !!

Have you an idear ??

Many thanks

Uwe KAMIN

This is not the same issue as reported above… that issue was specific to the 3.1 beta software. Try this:

http://www.mainsequencesoftware.com/Content/SGPHelp/SGProWontStart.html

If that doesnt work, try this:

www.mainsequencesoftware.com