Error Message: "Error transforming JNOW to J2000!"


#1

Hi, I have used SGP for the trial period and got everything working fine. I bought the licence and on reopenening SGP, connecting all equipment and pressing “Solve and SynC” or “Blind Solve” or “Take One” I keep getting this error message: “error transforming JNOW to J2000”. If I choose to continue, I cannot do anything (camera is greyed out). I’ve tried opening several times but always with the same error message. I have checked the log files and they are massive! (hundreds of MB). I enclose a “small” log file of 8 MB (Zipped is only 64KB).

I appreciate your help, since I cannot use the program anymore!

Miguel

sg_logfile_20151106205744.zip (42.1 KB)


#2

Trial vs licensed version of SGPro have no effect on how positional data is read from the telescope. It has to be purely coincidental.

Is this reproducible? Does it happen every time you open SGPro and connect the mount? It looks like the mount disconnected somehow (in a non-software kind of way) and started returning bogus JNow data to the epoch transform function.

If this is producible on demand, I will create a special beta build with better logging on this particular failure.


#3

Hi Ken, thanks for your reply. I have been for a couple of hours trying out several options. Initially it seemed there was some kind of conflict between the two ASCOM drivers (Gemini 1 GM8 and QHY6 and vice-versa. -which I use as guide cam in PHD-2): when one was disconnected, the other worked. Also, If I connected the Canon and then the Gemini, it seemed to work, but not when I used Ctr+Shift C to connect all …

After reinitializing Windows 7 3-4 times (and also the hardware), suddenly everything started to work again (Gemini, QHY6, Canon 550D and Robofocus. I haven’t got the error message again. PHD-2 doesn’t seem to work very well now, but that’t another forum!

I will try again tomorrow and see if everything works normally again. Thanks for your help.

Miguel


www.mainsequencesoftware.com