Error message 'Scope does not support meridian flip


#1

Hi,
I have a Paramount ME, SGPRO Beta 24.0.2768 and PHD2 2.4.1.h. Also using the latest version of TheSky6 and the ASCOM Driver for TheSky. Everything works well (focus, plate solve, image collection, etc). However, when I set up a run that requires a meridian flip, I get an error from SGPro that the mount does not support meridian flip. I have the appropriate boxes checked (even had a friend verify this). The error allows me to continue, but I make sure it does not get to a the point where it will try a meridian flip, as I am unsure what it will do.
Has anyone else seen this? Is there some check box somewhere unchecked?

Thanks
Tom C


#2

Tom,
Please see here:

Also I believe the Paramount uses slew in order to flip. Which means you’ll need to be past the meridian in order for it to flip. So the degrees to flip in SGP will need to be a positive number.

Thanks,
Jared


#3

I think Jared misunderstood Tom’s post. I think what Tom meant was that because he was getting the “flip not supported” message, he was therefore not allowing it to get to the point (time-wise) where flip would be expected to happen since the message was telling him it would not work so it was not safe to allow it to get to that point unattended.

I was the one that he was working with so I know he had the degrees past meridian set to a positive number ( 2 degrees if I recall correctly).

I wonder if this is not an issue with TheSky6 and the Paramount as opposed the TheSkyX (which I am using). I know this is similar to the issue I had where the mount was not sending pierside information and therefore giving me that message. I corrected that by inserting and activating “cangetpierside” property in ASCOM profile explorer. With the new driver this can be toggled from the driver dialog by selecting “pointing state”. My understanding is that Tom does have this set properly in the new driver and has even checked it’s state in Profile explorer.

Since it works for me with the same mount and driver (and, as far as I know, settings) I have to wonder if this is not something specific to TheSky6 vs TheSkyX as that seems to be the only difference between his system and mine as far as I know. The mount and even the camera and focuser are the same in our two systems.

I wonder if anyone else is using the combination of TheSky6, The New Driver, and SGP? I would doubt it but if so we would like to hear from you! TheSky 6 is pretty old, that last update was in May of 2009…

Might be time to have a look at Tom’s logs to see what is triggering the message.

Also, FYI Tom is a very experienced imager and knows far more about software than I do so is not too likely to make dumb mistakes except where related to not being totally familiar with SGP/PhD (since he is relatively new to SGP).


#4

It’s likely because SideOfPier isn’t implemented in the ASCOM driver (may not be available from TheSky6). Essentially if the telescope can’t tell us what side of the pier it’s currently located on we can’t make a determination if it needs to flip or not. This is pretty common with wedge mounted scopes, but then again those don’t need a meridian flip like a GEM.

There is nothing that requires the driver to implement SideOfPier. But without we can’t determine where the scope is pointed without guessing. It’s possible that POTH could provide this functionality but POTH would also be making a guess.

Thanks,
Jared


#5

I know it is implemented in the driver for TheSkyX, of course, since I am using that with no issues. I also know the driver itself supports TheSky 6 (and even 5 - if anyone still uses that!). The question is whether TheSky 6 is sending pierside information via the driver like it does with TheSkyX. That I have no idea since I stopped using TheSky 6 before I started using SGP.

Bottom line is that it is probably not SGP, probably not the driver, but may (or may not be) be an issue with TheSky 6.

I will let Tom comment at this point.


#6

I agree with Bill, it is most likely something odd with TheSky 6. Since I was thinking about upgrading TheSky 6 to TheSkyX anyway, I will go ahead and do that. I will let you know of my results soon.

Thanks
Tom


#7

I will chime in with Tom’s results since I have heard from him. Upgrading to TheSky X did indeed solve the problem.

The question that remains is why it solved the problem. I would wonder if pierside via the driver is supported in TheSky 6, perhaps not. Either that or there is some obscure setting in TheSky 6 that caused this.

Interestingly, he also ran into the problem I did the other night where the “internal” setting for the SBIG guider reverted to “none”, apparently as a result of him upgrading SGP from the beta to the current release. Too bad this setting does not save with profiles and sequences. Not a problem if you are aware of it but sure can mess you up if you do not know about this peculiarity. Can the authors comment on why this happens? Is it an SBIG driver thing?


#8

The ASCOM interface to TheSky uses the TheSky scripting; exactly what is implemented depends on the version of TheSky and on the mount that it’s controlling.

There’s no way to tell what can be done other than to try it.

Get Side of Pier was added quite recently so could easily only be available with TSX. Set Side of Pier is not available at all.


www.mainsequencesoftware.com