Error with Canon T3 - "EDS_ERR_TAKE_PICTURE_CARD_NG"


#1

I picked up an iOptron iEQ30 for eclipse chasing and imaging with my smaller camera platforms and last night was the first time I used it for imaging (really the first time the mount was used for other than testing at the PC). I used the mount with an AT65EDQ, Canon T3, QHY5-II guider and usb-focus for the focuser. Everything was working great. Centering, focusing (perfect v curves), guiding.

I then started the sequence, and everything was fine until the sequence went to take the first frame in the target. At that time I received the following message “EDS_ERR_TAKE_PICTURE_CARD_NG” from the Canon T3. Note than I had no problems getting frames from the Canon from all the other functions including frame a focus shots of the same duration (180 seconds) as the target sequence. I was running the Canon T3 form a powered USB hub with the guider and focuser and had no issues. I swapped out USB cables and had the Canon T3 all to itself on one PC port…the same thing.

The Canon T3 was set to Manual,bulb setting and the SD card was inserted and had lots of room, is working and in any case, I had the camera set to open the shutter without an SD card. I don’t use the Canon a lot for imaging, but even when I did, I did not see this message before.

Here is the log file

Any ideas on how to correct this?

Thanks,

Frank Z…


Canon 6D / T1i - getting error EDS_ERR_INVALID_HANDLE
Running Canon DSLR Sequence
#2

I managed to track this one down, although SGPro seems to be the only program that gives this error.

In normal operations with SGPro, I save all my images to an NAS that is mapped as a local drive. This lets me get to the data from any pc in my network and having 12 TB of space beats the mostly filled 250 GB partition on my notebook. I have had no problems using SGPro as such with my QHY cameras. The last time I tried using my T3 to image, I did not have the NAS. I do not have a problem writing the Canon T3 images directly to the NAS from other software when I tried to troubleshoot this.

So, in a whim, I changed the directory to a local one and an SGPro sequence worked with the T3. I can assume that SGPro uses a temp folder on the SGPro disk to save images for centering and frame and focus. This is why I did not have any problems with these, even with longer exposure to match the sequence. But it saves to the selected drive on the NAS during the sequence that caused some problems with the Canon SDK that SGPro uses.

So for me, if I use the T3 to image, I cannot save to the NAS. Don’t know if others have seen this, but the work around is simple…just got a few bumps on my my head from banging it against the desk trying to figure out why it’s not working as usual.

Thanks,

Frank Z…


www.mainsequencesoftware.com