Failed! Failed to sync the telescope!


#1

Ok, so I’m having a new-to-me problem with the plate solving feature. I’m using PlateSolve2 with Astrometry.net as the backup, and although it solves fast and reliably, SGP fails to sync the telescope afterwards. It happens in both the “Center Now” and “Solve and Sync” functions. I’ve never had an issue like this before, so I’m stumped.

I’ve tried several different things, and opened and closed SGP a half-dozen times. I thought that if I changed the Telescope Sync action to “Offset” or “None” that it may help, but then it just skips the Sync step and tries to center up but never does. The scope never centers on the target. Oh, and if I try to use Solve and Sync it will hang on the solving and not release the camera until I click Abort. (It’s actually already solved with PS2 and closed the window, it just continues to say solving and the camera controls are gray until I click abort)

Attached is the most recent log, with a single instance of the failed sync. Please let me know if you need more logs, and thanks for any suggestions.

Sorry, forgot to mention the gear. I’m using TheSkyX, latest build, and a Paramount MX+.

Austinsg_logfile_20161006213606.txt (33.6 KB)


#2

Ok, my original search for similar issues apparently didn’t include the right terms, or wasn’t nearly thorough enough. I apologize if this has been a known issue.


#3

Just a quick one, what version of .net framework do you have installed? I have found that despite later version of Windows having .net framework 4.5 installed, you still need to install .net framework 3.5 too

It looks like from the log file that .net is having an issue with the sync


#4

It’s broke right now.


#5

Is there a workaround? If so, would I need to roll back SGP, TSX or both to regain functionality?


#6

It is a hot topic right now. At this point in time, the latest TSX build does not support an external sync through ASCOM for Paramount mounts. It does support non-Paramount models.

This has nothing to do with ASCOM or SGP but relies upon TSX. If you go back to 9334 - it still supports syncs.

This caused Ken and Jared to consider doing sync offsets - but that is not yet fully implemented in the latest betas and we have been warned to not use those options on pain of death.

So basically, roll back to 9334, sit tight and give friendly support to SB to pop back the functionality.


#7

Offset has been fixed and will be out in the next beta. You can use ‘none’ now if you want to inhibit sync.

Thanks
Jared


#8

Thanks guys! I guess I’ll have to roll back TSX. Selecting “none” doesn’t fix the problem either, because it just repeatedly slews to the same incorrect position.


#9

Yup. Exactly why I have not updated my TSX. Hopefully the fix with come from both directions (SGP and SB). That way not only can you select one if the other does not work but once they both work, you can select the one that works the best.


#10

Okay, I’ve been on the latest beta of SGP since the “offset” feature went live. I’ve had good success with it, but it’s really weird in getting started. If I try to start sequences with a Target that has “Center Now” selected, it will plate solve and fail to sync. Same as before the latest beta. I can try to resume, but it fails again. This has happened 2 nights in a row, and I don’t know if it’s just a coincidence or what, but it has worked properly on the third try both nights after I’ve clicked into the “Telescope” tab and deselected and reselected “Offset” in the sync behavior.

From then on, it plate solves and centers perfectly all night.

Weird!

Here’s the log, first error occurs at 7:35 PM.
https://drive.google.com/open?id=0B4dA8yxWfYfrSExUZXZuLUIxTnM


#11

I think @Jared is aware of this from a different thread (or this one… can’t remember) and will address it soon.


www.mainsequencesoftware.com