Failed sync with the Sky X

Hello. I am new to the forum. I have a Paramount MyT and running the latest versions of The Sky X (10.5.0) and ASCOM platform 6. I have read extensively on issues with the Sky X and have enable tracking offsets checked and inhibit sync to protect Tpoint model unchecked. I am able to plate solve using 2.29, but sync and center consistently fails.

https://www.dropbox.com/s/1qkixj01edwds8f/sg_logfile_20200626190349.log?dl=0

<>

I believe below is the relevant line in the log file that shows the error:

<[06/26/20 23:55:56.750][DEBUG][Telescope Thread][PS;SQ;CE;] ASCOM Telescope: Error in Sync : CheckDotNetExceptions ASCOM.SoftwareBisque.Telescope SyncToCoordinates System.NullReferenceException: Object reference not set to an instance of an object.

I understand that there can be issues with TPoint models in The Sky X. I have run T point models in the past. I have read to dump them but I’m sure how to do this. I do see that you can set the Tpoint model to default settings and i have not tried that.

I have a related question of whether it is possible to have SGP do a meridian flip without doing a sync. I see folks giving up on sync and center. I could live with centering the target manually in Sky X but I really want to automate the meridian flip with SGP. Any suggestions are greatly appreciated >

OS: <Windows 10>
Ver: <3.1.0.479>

Carl S

Your log shows that your sync behavior is set to “Sync”:

[06/26/20 23:54:58.553][DEBUG][Telescope Thread][PS;SQ;CE;] Telescope: Sync behavior set to “Sync”…

For TheSkyX I believe you either want to set the sync to Target Offset or “None”
image

Sure, just disable Auto Center in the Meridian Flip Options…but setting your sync as mentioned above should also address this:
image

Jared

Use “Target Offset”, not “Synch” in SGP - synch has been broken for some time (as I recall, due to changes in either TSX or the ASCOM driver - don’t recall which).

I use it all the time with both an MX+ and ME with zero issues.

Synch (really target offset) and center works fine as long as you have the parameters set right (for example, if you have .25 arcsec sampling, asking it to do 1-2 pixels might be a bit much to expect to work)

Thank you Jared for the prompt response! I have to admit that I’m a bit embarrassed that I missed this setting in SGP:( I thought it was an ASCOM settings issue and misread “tracking” offset and thought I had target offset covered by checking that box. Oops!

This is reassuring! I found threads a while back and knew there were issues between SGP and Sky X, but wasn’t sure if it had been fixed. I figured it had either been fixed and was working well or Sky X folks gave up one it. Good to know!

Carl